[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline


    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
  2. Offline


    @Schlumpf - should be fixed in #307.
  3. Offline


    Hi, thank you for this fast answer/release!
    But I got still this problem (I made a little video to show):
  4. Offline


  5. Offline


    I am confused, it worked short and I had 1/3 dirt blocks but than it stacked at 1 -.-
    Then I aborted the quest and started new and now it stack again at 0 :(
    Maybe there's something wrong in my Quest:
            description: A fetch quest
            completion: <g>You win! Give me that stone.
            acceptance: <g>Challenge <y>accepted<g> Collect 3 Dirt Blocks.
        repeats: -1
                    type: collect
                    materialid: 3
                    amount: 3
                    message: A voice echoes... "I want that Dirt now!"
                type: item
                id: 3
                amount: 3
                take: true
    I am now using just Citizens and #1337

    Edit: LOL!! I got the Bug -.- As you can see in my Quest the materialID is 3 = Dirt, so when I collect Dirt nothing happens, but if I collect Sand it work?! Maybe this is a bug or I made something really wrong?! I don't know :D

    Edit2: This is really crazy ;D... If I collect Wood or Sand it work, but if I collect Dirt as it is in the Quest it don't work ... Hmm there's something wrong :p
  6. Offline


    Can i get the latest working citizens?
  7. Offline


    Item dupe exploit:
    1. open trader
    2. click on the item you want to sell in your inventory
    3. click on it again, while at the same time closing your inventory
    4. the items are then dropped but also returned into your inventory (you get double the amount you had)

    Please fix this issue as my servers' store had to be shut down because of it. This is on cb1337, citizens 1.1.2.
  8. Offline


    We have a game breaking problem of people not getting iconomy rewards at times. I can go through with multiple accounts of various ranks and do quests and get rewarded, however we have players that do not get paid even though their quest profile says they have completed the quest.

    If it were any other bug we could probably continue to use this, but while this is happening it's simply not fair on our players.

    Using #1337 bukkit and every citizens build as it comes out, currently latest.

    worth mentioning we're using iConomy 5 still - perhaps upgrading will fix it?
  9. Offline


    Hello i have a little problem. Can u help me with some hints about using citizens as a non-op player?
    The main task is so that any non-op player on server could repair their items by smith, trade with traders, and some other stuff.. But all i get if im not an op is "You don't have permission to do that".
    I assume that this is the permission problem, so I've tried a lot of different permission plugins, some of them dosnt work at all, some of them work but not the way i want to.
    Thats all. So the question is: what the permission plugin would be better here and what the permission nodes i should use.
    Thank you anyway.
  10. Offline


    Ive used the citizens plug with most major permissions plugs, 2.7x, 3.x, superpermissions and no permissionsEX. Make sure to use the permissions nodes that are listed in the citizens wiki, and define them in your actual permissions configuration files. For the basic use of Citizens the node "citizens.basic.use" is used. Or to use the blacksmith was "citizens.blacksmith.use" If you dont set up your permission nodes correctly it will still only work for ops.
  11. Offline


    Well im making a new server and one of the mods its citizens.
    Well my members cant add a new NPC, it say they reach the limit, but i have the right permissions to them.
    i tried:
    and after i tried that:

    but any of that permissions resolve the problem.

    Anyone know the problem?

    I already read like 100 pages about some of them having problms with PermissionsEX maybe any problem with that?
  12. Offline


    Hey frozencanadian) I set up the permission 3.1.6 plugin and it works with other plugins but not with citizens.
    There's the config

    default: true
    prefix: ''
    suffix: ''
    build: false
    - 'iConomy.holdings'
    - 'citizens.basic'
    - 'citizens.blacksmith*'
    - 'RepairShop.use'
    - 'RepairShop.create'
    default: false
    prefix: ''
    suffix: ''
    build: true
    - Default
    - 'iConomy.holdings'
    - 'citizens.blacksmith*'
    - 'ChestShop.*'
    - 'RepairShop.use'
    - 'RepairShop.create'
    default: false
    prefix: ''
    suffix: ''
    build: true
    - Member
    - 'RepairShop.create'
    default: false
    prefix: ''
    suffix: ''
    build: true
    - '*'
  13. Offline


    Why after a "/citizens save" all of my NPC are desactivate ?

    Please help me :'(
  14. Offline


    Is there a single player version of this plugin? It would be fantastic to create adventure maps.
  15. Offline


    How come even after I have given members citizens.toggle.all permission they cant toggle. Also they have the other command that i may have screwed up. Is it supposed to be like: citizens.toggle.type or citizens.toggle.guard, citizens.toggle.healer etc?
  16. Offline


    its support so be like citizens.toggle.guard etc not type

    can someone help me with my questin plz? 3 or 4 post behind?
  17. Offline


    Setup question here... not sure what I'm doing wrong. I want an NPC that will just attack... anybody. Any player that gets within range. But so far all he does is just stand there and look dumb. :p Here's what I'm trying..

    /npc create Guard
    /toggle guard
    /guard bouncer
    /guard radius 10
    /guard aggro
    /guard addflag -a

    That seems like it should do it.. yet he just stands there. Equipping doesn't seem to work out too well either, though I believe that's more to do w/ Heroes than Citizens. Can anybody tell me what I might be doing wrong here?

    Citizens 308 / CB leet.
  18. Offline


    @hiro24 - /guard af -p -a ? Also, try /guard aggro again.
  19. Offline


    nope.. tried /guard af -m -a also, he won't attack zombies :(
  20. Offline


    Check if you have the npc types in your types folder. If not, theyre in this forum, or use the folder u get from the download and not the folder that generates wehn you restart your server
  21. Offline


    Hey hiro thank you for you help. Im pretty sure i understand it now, so say i wanted to add someone to a region as a quest rewards it would be
    /questregion $player $region = runas(~op,'/region addowner $region $player')

    edit: @hiro24
    i set up the mining one exactly like you added it with command helper and citizens except i have it giving coal ore as a rewards too so its like
    type: item
    id: 16
    amount: 25
    take: false
    type: command
    command: addxp <player> mining 10000
    server: true

    and the player doesnt get the coal ore or the exp. and in the console i get the bukkit sad bukkit wants you to access command but bukkit cant bukkit tears things. any ideas?[/code][/FONT][/FONT][/SIZE][/FONT][/quote]
  22. Offline


    Can we please get more documentation? At least make the current documentation easier to navigate.

    What are the color codes? Formats for all the quest type rewards and stuff. Examples for all of them.
  23. Offline


    I got citizens and i type /npc create Guard
    and i got this in the terminal:

    2011-11-04 14:22:51 [SEVERE] java.lang.NoSuchMethodError: net.minecraft.server.ItemInWorldManager.<init>(Lnet/minecraft/server/WorldServer;)V
    2011-11-04 14:22:51 [SEVERE] at net.citizensnpcs.resources.npclib.NPCSpawner.spawnNPC(NPCSpawner.java:31)
    2011-11-04 14:22:51 [SEVERE] at net.citizensnpcs.resources.npclib.NPCManager.register(NPCManager.java:164)
    2011-11-04 14:22:51 [SEVERE] at net.citizensnpcs.resources.npclib.NPCManager.register(NPCManager.java:193)
    2011-11-04 14:22:51 [SEVERE] at net.citizensnpcs.commands.BasicCommands.create(BasicCommands.java:226)
    2011-11-04 14:22:51 [SEVERE] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    2011-11-04 14:22:51 [SEVERE] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    2011-11-04 14:22:52 [SEVERE] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    2011-11-04 14:22:52 [SEVERE] at java.lang.reflect.Method.invoke(Method.java:597)
    2011-11-04 14:22:52 [SEVERE] at net.citizensnpcs.resources.sk89q.CommandsManager.executeMethod(CommandsManager.java:522)
    2011-11-04 14:22:52 [SEVERE] at net.citizensnpcs.resources.sk89q.CommandsManager.execute(CommandsManager.java:406)
    2011-11-04 14:22:52 [SEVERE] at net.citizensnpcs.Citizens.onCommand(Citizens.java:202)
    2011-11-04 14:22:52 [SEVERE] at org.bukkit.command.PluginCommand.execute(PluginCommand.java:39)
    2011-11-04 14:22:52 [SEVERE] at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:163)
    2011-11-04 14:22:52 [SEVERE] at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:353)
    2011-11-04 14:22:52 [SEVERE] at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:756)
    2011-11-04 14:22:52 [SEVERE] at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:721)
    2011-11-04 14:22:52 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:714)
    2011-11-04 14:22:52 [SEVERE] at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
    2011-11-04 14:22:52 [SEVERE] at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    2011-11-04 14:22:52 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:92)
    2011-11-04 14:22:52 [SEVERE] at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
    2011-11-04 14:22:52 [SEVERE] at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:464)
    2011-11-04 14:22:52 [SEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:374)
    2011-11-04 14:22:52 [SEVERE] at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    2011-11-04 14:23:12 [SEVERE] java.lang.NoSuchMethodError: net.minecraft.server.ItemInWorldManager.<init>(Lnet/minecraft/server/WorldServer;)V
    2011-11-04 14:23:12 [SEVERE] at net.citizensnpcs.resources.npclib.NPCSpawner.spawnNPC(NPCSpawner.java:31)
    2011-11-04 14:23:12 [SEVERE] at net.citizensnpcs.resources.npclib.NPCManager.register(NPCManager.java:164)
    2011-11-04 14:23:12 [SEVERE] at net.citizensnpcs.resources.npclib.NPCManager.register(NPCManager.java:193)
    2011-11-04 14:23:12 [SEVERE] at net.citizensnpcs.commands.BasicCommands.create(BasicCommands.java:226)
    2011-11-04 14:23:12 [SEVERE] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    2011-11-04 14:23:12 [SEVERE] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    2011-11-04 14:23:12 [SEVERE] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    2011-11-04 14:23:12 [SEVERE] at java.lang.reflect.Method.invoke(Method.java:597)
    2011-11-04 14:23:12 [SEVERE] at net.citizensnpcs.resources.sk89q.CommandsManager.executeMethod(CommandsManager.java:522)
    2011-11-04 14:23:12 [SEVERE] at net.citizensnpcs.resources.sk89q.CommandsManager.execute(CommandsManager.java:406)
    2011-11-04 14:23:12 [SEVERE] at net.citizensnpcs.Citizens.onCommand(Citizens.java:202)
    2011-11-04 14:23:12 [SEVERE] at org.bukkit.command.PluginCommand.execute(PluginCommand.java:39)
    2011-11-04 14:23:12 [SEVERE] at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:163)
    2011-11-04 14:23:12 [SEVERE] at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:353)
    2011-11-04 14:23:12 [SEVERE] at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:756)
    2011-11-04 14:23:12 [SEVERE] at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:721)
    2011-11-04 14:23:12 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:714)
    2011-11-04 14:23:12 [SEVERE] at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
    2011-11-04 14:23:12 [SEVERE] at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    2011-11-04 14:23:12 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:92)
    2011-11-04 14:23:12 [SEVERE] at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
    2011-11-04 14:23:12 [SEVERE] at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:464)
    2011-11-04 14:23:12 [SEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:374)
    2011-11-04 14:23:12 [SEVERE] at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
  24. Offline


    Well im making a new server and one of the mods its citizens.
    Well my members cant add a new NPC, it say they reach the limit, but i have the right permissions to them.
    i tried:
    and after i tried that:

    but any of that permissions resolve the problem.

    Anyone know the problem?

    I already read like 100 pages about some of them having problms with PermissionsEX maybe any problem with that?
  25. Offline


    Ive been trying commands just generally without the command helper idk if this works or waht
    but its like
    type: command
    command: /addxp <player> mining 10000

    with the correct syntax and such im just lazy
    but i get an error in the console saying unknown command. is this normal? do i have t ouse command helper which isnt working for me the way hiro24 described it. any input?
  26. Offline


    I know you'll need either server:true or server:false after command:. Also, remove the / from command, so it'd just be addxp <player> mining 10000

    However, that probably won't work as /addxp is generally not something regular users can do, and the command reward as I understand runs as the player. That's where CommandHelper comes in play. If you notice the runas(~op part... it's telling the server that when this alias is run, it will be run w/ sysop level permissions. That's why it works.
  27. Offline


    just tested it and it works with server:false thank you so much, last question if i want to do different plugin comands like world guard would it be
    /questguard $region $player = runas(~op, /region addowner $region $player)
    in the command helper? then something like
    command: questguard mine <player>
  28. Offline


    saaaddd, noone knows what can i do with my problem?
  29. Offline


    @hiro24 hey it works for me as an op but not for people as normal users? any idea? i get bukkit sasd when a non op player completes the quest. the command helper must not be running as op... but i copied the commandhelper thing exactly as you put it

    @ptangel. i looked into it, but im not giving anyone perms to create npcs... so im sorry i can't help you :( red sad lol
  30. Offline


    Sadly, neither commandhelper or citizens command rewards will work in this way. Both seem to give errors about about needing a player to run the commands in my experience. To get around this on my server, you can use a plugin called CommandSigns, which is compat w/ worldguard and can run them as op level if needed. In one example on my server I have the quest reward move the player via a teleport to a boxed in area w/ a command sign. When they click it, it will update a region and tp them back out. It's a nasty work around but.. if somebody else has another way I'd also love to hear it. :) Anyways, if you want to go this route, here's the link to commandsigns.

  31. Offline


    @hiro24 does that stand the same for the mcmmo exp? is that why im getting bukkit sad errors when non op does the quest? :( tears

Share This Page