[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline


    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
  2. Offline


    Does someone have a small sample of the quest format for the quest.yml? I don't see any examples in the Wiki and all I need is a basic template to get me started, I would really appreciate that.

    Also two more questions.....

    1) how do I make it so a bouncer / guard can take damage?

    2) if I make an NPC - is there a way i can transfer ownership to another player? Thanks - Never mind with this question - I found the answer /npc setowner [player-name]
  3. Offline


  4. Offline


    Hey really great plugin! but when i try spawning NPC players with skins from Minecraft Skin Search...the skins just won't appear! If anyone can help me, i would be VERY VERY grateful to that someone.
  5. Offline


    if you create a npc with an existing account-name, this npc will use the same skin as the account.
    if you change the name of this npc, it will fall back to default skin.
    there is no way (in citizens) to set a dedicated skin to a npc
  6. Offline


  7. Offline


    You have to add world guard support for the evil mobs, they are soooooo anoying when they get into the spawn!
  8. Offline


    I'm using the latest Bukkit (1337?) and the latest Citizens. I know this citizens version wasn't ment for my Bukkit version but i got quite a strange problem so i wanted to check it with others anyway.

    I got a bunch of NPCs with the same name (Watchman) and if i select them, i seem to select them all or at least majority of them. I found out the hard way by doing /npc move and now i got 12 NPCs stacked and flipping out, trying to move away (guess because they are guards although since i updated that doesnt work anymore either) and just blinking through space.

    Does this make sense?
  9. Offline


    @Exanimo - can you try with the latest dev build?
  10. Offline


    Ahh, that works! Do you know what this means? I can have like... reputation grinding!! bwahahaha!! Like... do the "kill 10 wolves" 10x, and then you'd have enough "reputation" to do better quests.

    One friendly suggestion though... maybe 2.

    1. For the "times", it doesn't say how many times you need to have completed it if you try to pick up a quest that requires it. Could you make it say like "You must have completed the quest <quest> # times" ?

    2. Permission requirements don't say exactly what permission node you're missing.. could you have it say what permission node you need to accept a quest?
  11. Offline


  12. Offline


    The latest citizens doesnt have any type's of npc? help?
  13. Offline


    I'd love to but i've been searching for the page with the dev-builds and i can't find a link to it anywhere!
    I have downloaded dev-versions before but i guess the link was on the first page of this thread which has changed since then. :S

    If anyone could give me the link to that please?
  14. Offline


  15. Offline


  16. Offline


    @fullwall - I'd suggest you to do, to allow us to set diffrent prizes for diffrent teleports. That would be great. Just add a command, /wizard prizeloc
  17. Offline

    black twister

    [INFO] [Citizens] NPC types loaded: wizard, blacksmith, healer, trader, guard, quester
    2011-10-27 18:19:23 [SEVERE] Error occurred while enabling Citizens v1.1.1 (Is it up to date?): Path cannot be null
    java.lang.IllegalArgumentException: Path cannot be null
        at org.bukkit.configuration.MemorySection.getConfigurationSection(MemorySection.java:517)
        at net.citizensnpcs.properties.ConfigurationHandler.getKeys(ConfigurationHandler.java:265)
        at net.citizensnpcs.questers.quests.QuestFactory.instantiateQuests(QuestFactory.java:31)
        at net.citizensnpcs.questers.data.QuestProperties.initialize(QuestProperties.java:14)
        at net.citizensnpcs.questers.QuesterType.registerEvents(QuesterType.java:32)
        at net.citizensnpcs.Citizens.onEnable(Citizens.java:88)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:174)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:957)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:280)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:171)
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:154)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:297)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:284)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:152)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:348)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    2011-10-27 18:19:23 [INFO] [Citizens] An error has occurred, please wait while it is sent to the developers...
    2011-10-27 18:19:26 [INFO] [Citizens]
    2011-10-27 18:19:26 [INFO] [Citizens] Citizens Error Reporting - Powered by CreeperHost.net
    2011-10-27 18:19:26 [INFO] [Citizens] Below is the stacktrace that has been transmitted to the developers, no other information has been included other than Citizens version information.
    and ingame " The command was not recognized." but permissions are set correctly...
  18. Offline


    getting the same error as black twister

    also, my npc-profiles.yml seems to have been changed

    Citizens #279

          skeleton: MemorySection[path='22.guard.flags.skeleton', root='YamlConfiguration']
            safe: 'false'
        talk: 'true'
        name: Guard/Imari
        owner: _ei3n_
        color: '2'
        look-when-close: 'true'
        talk-when-close: 'false'
        location: world,-348.0639306911866,67.0,-176.11497151294876,-49.635956,0.0
        inventory: 276/1/0,AIR*35,
        type: BOUNCER
            type: MOB
          skeleton: MemorySection[path='39.guard.flags.skeleton', root='YamlConfiguration']
          spider: MemorySection[path='39.guard.flags.spider', root='YamlConfiguration']
        aggressive: 'true'
        talk-when-close: 'false'
        owner: _ei3n_
        color: '11'
        talk: 'true'
        items: 276:0,310:0,311:0,312:0,313:0,
        location: world,-260.9025485742726,100.0,-1305.0680829712596,106.9825,0.0
        owner: _ei3n_
        items: 276:0,310:0,311:0,312:0,313:0,
        talk: 'true'
        color: '5'
        inventory: 276/1/0,AIR*35,
        look-when-close: 'true'
          zombie: MemorySection[path='4.guard.flags.zombie', root='YamlConfiguration']
  19. Offline


    @Fullwall: I tried using one of the dev-version (278) and this time Citizens didnt load correctly at all.
    It claimed it was version 1.1.1 which is rather strange as thats lower then the current version.

    The same happened with Dev-version #279 (did use the npc types with each version aswell ofcourse).
    This did not load any NPC's by the way, not just an error.
  20. Offline


    really, it would be awesome if we could do this!
  21. Offline


    @Exanimo - try #280, may have fixed some things. The most recent dev builds may have issues with configuration due to Bukkit's new system (which IMO isn't perfect).
  22. Offline


    I saw a lot of Dev Builds in the last time :)
    But when does the official Version come out as 1.2 or 1.1.3? :D
    Can't wait ;)
  23. Offline


    Ok tried #280 and the previous error is gone.
    However i get this new one:

    The above mentioned NPCs seem to miss something like "location: world,323.84611981049903,76.0,83.81624466371845,61.322952,-61.21182", the not-listed npcs dó have a location still. I'm afraid a previous Citizens version messed up my npc-profiles :)

    It seems Citizens isnt loaded further after the final error as i dont get a note like:
    41 NPCs loaded
    1 Quest loaded
    as i normally get when starting the server.
    I can't check ingame atm (logged in remotely on my server from work) but i think it's save to say no NPC has spawned.

    I'll try to find a recent npc-profiles in my backups and see if that still has locations and try that.
  24. Offline


    Okay, that worked! Replacing the messed up npc-profiles and using #280 makes me load Citizens without any error! :)
    (well, apart from these new Register plugin that keeps getting downloaded since i got the new bukkit and keeps giving me nasty errors from each plugin that seem to adress it)
    Do hope guards works again aswell, didnt on last version... can't report on that before end of the day im afraid.

    Thanks for the help again Fullwall :)
  25. Offline


    Damn... cheered too early :(
    Shutting down the server and restarting it will mess up the NPC-profile again in a simular way (removing locations, possibly even more). Replacing the npc-profiles with a correct backup before restarting makes the NPCs load succesfull.

    Does Citizines use/require Register by chance? That generates quite a few errors when stopping the server, might have something to do with that? (although Register is for currency handling, not sure if that should effect a npc profile file but im no expert)
  26. Offline


    @Exanimo - it's the new Bukkit configuration system, there might still be some errors somewhere. It does use Register, though it shouldn't cause any errors...
  27. Offline


    Also, this is the 9000th post :).
  28. Offline


    Register is being downloaded by NarrowtuxLib, I had to disable the crap :p None of my plugins needed it anyway.
  29. Offline


    Ok i'll await a new dev-version and keep testing! :)

    Concerning Register, i got multiple plugins calling Register as i get the same error after it starts various plugins.
    I've tried manually updating Register but that didnt help, i'll go ask the Register developer for help i think.
  30. Offline


    Oh i got NarrowtuxLib aswell! How did you disable it then?
    I think if i remove NarrowtuxLib it will just get downloaded again as i got Showcase and Dropchest from that developer that uses narrowtuxlib.
  31. Offline


    @fullwall: For your information, it's not stopping the server that mess up the npc-profiles... it's Citizens doing when it saves.
    Just noticed citizens saving in my console and at the same time i saw the npc-profiles file go from 31kb to 13kb.
    Hope that helps (or confirms what you already knew :p )


Share This Page