[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline


    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
  2. Offline


    heyya @fullwall I hate to be a bother, but could you check the commandhelper compat when you have some free time? There's a couple things w/ worldguard that don't seem to be jiving when running the commands as rewards from heroes. Like

    //load <schematic>
    //paste -o
    /region setmember <region> <player>
    /region removemember <region> <player>

    There may be more, but the first 2 don't say anything. The last two say it's expected to be run by a player. This is from a commandhelper alias set up like this:
    runas(~op, //load kingofthehill_Cressia)
    runas(~op, //paste -o)
    runas(~op, /region removeowner goldmine g:cressian )
    runas(~op, /region removeowner goldmine g:brokuns )
    runas(~op, /region removeowner goldmine g:boletarian )
    runas(~op, /region removeowner goldmine g:utgaardians)
    runas(~op, /region addowner goldmine g:$nation)
    none of those are working.. other stuff though related to commandhelper and runas are, such as modifying permissions, broadcasts, etc...

    Citizens 267, Bukkit RB leet.

    Again, no rush.. this is more or less a side project.. the king of the hill type thing I mentioned a few days back. I think this is the last piece of the puzzle.. pasting in a repaired "hill" when the quest completes and modifying a worldguard region. The 2nd part I can probably work around.. the first.. not so much. :)
  3. Offline


    @hiro24 - Citizens essentially just tells the server/player to dispatch a command. What specific thing isn't working? You're running a CH command I presume, but which one? Is it server or player?
  4. Offline


    The code I posted above fails to work. Here is the entire alias:

    /claimmountain $player $nation $realnation = >>>
                                                runas(~op, //load kingofthehill_$nation)
                                                runas(~op, //paste -o)
                                                runas(~op, //paste -o)
                                                runas(~op, /region removeowner goldmine g:cressian )
                                                runas(~op, /region removeowner goldmine g:brokuns )
                                                runas(~op, /region removeowner goldmine g:boletarian )
                                                runas(~op, /region removeowner goldmine g:utgaardians)
                                                runas(~op, /region addowner goldmine g:$nation)
                                                runas(~op, /broadcast $player has claimed Widows Peak for the glory of $realnation)
                                                runas(~op, /permissions group unsetperm Boletarian essentials.warp.hilltop)
                                                runas(~op, /permissions group unsetperm Cressian essentials.warp.hilltop)
                                                runas(~op, /permissions group unsetperm Brokuns essentials.warp.hilltop)
                                                runas(~op, /permissions group unsetperm Utgaardians essentials.warp.hilltop)
                                                runas(~op, /permissions group setperm $nation essentials.warp.hilltop true )
    This is run from citizens reward... snipplet:

                type: command
                command: claimmountain <player> Cressian Cressia
                server: true
    In this example, /region, //paste and //load commands are not working. /broadcast and /permissions commands are.

    This is from the server.log when the quest completes..

    2011-10-24 16:27:53 [INFO] CH: Running original command ----> /claimmountain L0rdZ3r0 Cressian Cressia
    2011-10-24 16:27:53 [INFO] from a CommandSender
    2011-10-24 16:27:53 [INFO] ESC[31mA player is expected.ESC[0m
    2011-10-24 16:27:53 [INFO] ESC[31mA player is expected.ESC[0m
    2011-10-24 16:27:53 [INFO] ESC[31mA player is expected.ESC[0m
    2011-10-24 16:27:53 [INFO] ESC[31mA player is expected.ESC[0m
    2011-10-24 16:27:53 [INFO] ESC[31mA player is expected.ESC[0m
    The "a player is expected" is when region commands fail. Nothing is logged for the //load and //paste -o commands. They just don't execute.
  5. Offline


    'Ranks' question:

    My understanding is that these Ranks given/taken via quests are nothing to do with permissions and is something that's just added to a player's Citizens Profile- right? It's a nice idea, but there's not really any way to see or check your rank, is there?

    I'd much rather see the 'Ranks' relating to bukkitPermissions groups. Ie. Putting players into and taking them out of groups. That way, people can ascend to ranks via Citizens quests that means more than just "What quest I can and cannot do now". It would mean that their ranks are displayed (Through other prefixing plugins) and that they give new abilities and permissions.

    Gotta admit it makes much more sense. Hopefully it's not too daunting a task to implement.

    Loving the whole plugin thus far, though!
  6. Offline


    Rank does go by permissions groups. In fact, I have it set up on my server similarly.. I have an ice world w/ 5 dungeons where normal users cannot build in. (separate from the main world) If they manage to take the quests for and complete all dungeons, they are given the rank "champion", which in permissionsbukkit has build rights in that world. :)

    So short answer, yes. Ranks are bukkitpermission groups
    Deide likes this.
  7. Offline


    That is amazing 8D I had no idea. Now I can get to work! Thanks, Hiro :)
  8. Heres my error AGAIN for traders
    /trader buy cobblestone 10 5
    it then shows me
    trader is now buying 1 cobblestone for $5
    its doing this for everything, it used to not and now it is!
  9. Offline


  10. Offline


    This plugin has come a long way :O
  11. Offline


    I'll have to check on the region ones, but I'm 99% sure //load and //paste do not.
  12. Offline


    Delivering air doesn't work for me. I've looked through the suggestions states in the issues tracker replies and tried copying over the format someone else uses and only changed the NPC ids - still doesn't work for me :x More have reported this so I'm guessing it broke with the last update ?
  13. Offline


    This plugin is awesome, however could you please add or suggest a line of code that would make it so the guards permadied, or cost something to respawn, auto regen mods = exploit, and im wanting to run a survival server.

    Great mod!
  14. Offline


    @fullwall - Emm.. The server gets a big lag when guard is attacked with arrows.. This is kinda ridiculous. And fullwall, Guards are still heading towards you, instead of staying in the place. Is it that hard to do a simple thing ? Dont want to be smart, couse I cannot do it myself, but i don't belive its that hard..
  15. Offline


    Maby have another the problem wih the Questers that they dont hold the quests after Server Restart?
  16. Offline


    no dowlode
  17. Offline


    Hey all.
    Today i was workking a bit on my citizens becuase i have over 150 stand in my town....and after 4 hours the RAM from my Server uses 100% so i am pissed of.
    Now i walk over the whole npc-prifiles.yml and i make for all npcs the "look-at-close: false"
    yet my server run pretty stable
    after 1 hour only 1% ram more usage.
    Maby osome other ones who have the same problem should try it too to let no NPC look at somebody and tell there informations about what happens here in this thread.
  18. Offline


    I need help always when i type /create (and here name) it says error the error in console is:

    23:55:36 [SEVERE] java.lang.NoSuchMethodError: net.minecraft.server.ItemInWorldM
    23:55:36 [SEVERE] at net.citizensnpcs.resources.npclib.NPCSpawner.spawnNPC
    23:55:36 [SEVERE] at net.citizensnpcs.resources.npclib.NPCManager.register
    23:55:36 [SEVERE] at net.citizensnpcs.resources.npclib.NPCManager.register
    23:55:36 [SEVERE] at net.citizensnpcs.commands.BasicCommands.create(BasicC
    23:55:36 [SEVERE] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native M
    23:55:36 [SEVERE] at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown S
    23:55:36 [SEVERE] at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unkno
    wn Source)
    23:55:36 [SEVERE] at java.lang.reflect.Method.invoke(Unknown Source)
    23:55:36 [SEVERE] at net.citizensnpcs.resources.sk89q.CommandsManager.exec
    23:55:36 [SEVERE] at net.citizensnpcs.resources.sk89q.CommandsManager.exec
    23:55:36 [SEVERE] at net.citizensnpcs.Citizens.onCommand(Citizens.java:202
    23:55:36 [SEVERE] at org.bukkit.command.PluginCommand.execute(PluginComman
    23:55:36 [SEVERE] at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCo
    23:55:36 [SEVERE] at org.bukkit.craftbukkit.CraftServer.dispatchCommand(Cr
    23:55:36 [SEVERE] at net.minecraft.server.NetServerHandler.handleCommand(N
    23:55:36 [SEVERE] at net.minecraft.server.NetServerHandler.chat(NetServerH
    23:55:36 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHand
    23:55:36 [SEVERE] at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:3
    23:55:36 [SEVERE] at net.minecraft.server.NetworkManager.b(NetworkManager.
    23:55:36 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHand
    23:55:36 [SEVERE] at net.minecraft.server.NetworkListenThread.a(SourceFile
    23:55:36 [SEVERE] at net.minecraft.server.MinecraftServer.h(MinecraftServe
    23:55:36 [SEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftSer
    23:55:36 [SEVERE] at net.minecraft.server.ThreadServerApplication.run(Sour

    Can some one help? PLS i realy like this plugin and i hope some one will help me fixing this problem :p :D .
  19. Offline


    Thanks, I use PermissionsEx now ;)
  20. Offline


    Whenever I create a NPC with the name of an existing player, it bugs out and follows that person around forever? :/
  21. Offline


    i put the Citizens.jar and the Citizens folder with the sub folder filled with all the citizens types.
    when is type
    "/npc create billy"
    "the command was not recognized see /npc help for a list of commands"
    I type that and I receive the same message

    Please PLEASE help
  22. Offline


    Check your Permisson notes!
  23. Offline


  24. Offline


    @fullwall rut row... I think quest requirements is broken. At least having a quest as a quest requirement.

                type: quest
                quest: 'SunkenBirka'
    used to work.. was on like... 268 and didn't work. Just put on 276 and doesn't work there either.. could the syntax have changed possibly?

    To clarify, it looks like it works, but it says I need to complete the quest, even though the quest has been completed.
  25. @fullwall
    Hey i have a game goin on mc where you gain armies and attack other players but is it possible to make my guards/ bodyguards attack the other persons guards by adding a flag?
  26. Offline


    Hello I have exactly the same problem, which @Drehverschluss has.
    My User have the Permisssion to create Npcs unlimited. But they can
    not create a single one. But i can an i have the '*' permission. So maby
    you made a misstake an cahnge the permission node and forgot about
    it. Could you please look it up in your code.

    Thank you
  27. Offline


    I've got a problem :oops:
    The plugin works but when i want to create a npc, for example blacksmith, he doesn't have the skin.
    I have the blacksmith.jar in my folder.
    An idea ?

  28. Offline


    You have to download CitizenSpout, that will alow you to change their skins, you also need Spout on your server.
  29. Offline


    Ok I thought there was defaults skin for each class ^^

  30. Offline


    Hi. When I create an NPC it all works fine, though when I turn him into a guard, add the appropriate flags and tell him to bodyguard (and thus follow me), he does nothing. We're running the latest citizen, PEX and Bukkit version. Im using /toggle guard, /guard bodyguard, and then add the flags. We've also downloaded the most recent Guard release .jar. Am I doing something wrong here?
  31. Offline


    I think a cool feature you could add eventually to quests would be to have a npc request you to bring someone to them or to someone else, so you go and talk to that npc, he then follows you until you reach where he needs to go, then dialogue, quest completion etc. and some way to configure the dialogue from each npc that can be slowed down i.e

    A Quest:
    description: I'm trapped, you need to find Dave and bring him to free me
    acceptance: Please go and find him quickly he usually hangs around the armory
    completion: Thank you for rescuing me
    repeats: 1
    type: quest
    quest: A previous quest
    type: find
    npcdestination: 47
    message: What! John is trapped! Bring me to him at once!
    type: bringto
    npcrequired: 47
    npcdestination: 55
    time limit: 1440
    npc: 55
    message: Dave what happened!
    delay: 5
    npc: 47
    message: The pirates caught me and locked me in here! Use your lockpick skills to get me out John
    delay: 55
    and then he returns back to his original spot, this could be used in so many ways. also a time limit we're he will just despawn and return to his position if you take too long.
    Pim1234 likes this.

Share This Page