[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline


    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
  2. Offline


    Question as I'm not seeing it outright, so forgive if it is covered. As I understand it blacksmiths can take.. say, iron, in order to get your repairs done without an economy plugin. Can traders be done the same way? Set it up where 1 diamond can be bought for 64 gold or vice versa? Or is an econo plugin a MUST for the trader?
  3. Offline


    I am having this SAME problem.... Anyone have a fix for this?"
  4. Offline


    Can u help me when i create an npc this happens. 2011-10-11_23.47.47.png
  5. Offline


    CB and Citizens versions?
  6. Offline


    Try to post the quest..
    Maybe the problem's in there
  7. Offline


    Sorry for late reply.
    The best thing to do is to simply break it down into a quest for each step.
    After step one, reward with the items and the next quest (be careful. Do not make the next quest require the current one when giving it as reward. Rewards are granted prior to the quest completion)
    Here you can also make use of finishhere: true

    Also keep in mind, when giving a quest as reward, the description text is not shown, so simply add that to the completion text of the previous one.

    I know it's been several days since you asked, and you might have figured it out by yourself in that time.. But this is the best way
  8. Offline


    Heyy @fullwall now that things are relatively stable w/ citizens on this build (as far as I can see, the big bugs are gone :) ) what are the chances of revisiting "heroes" exp as quest rewards? Purty pleeeeease? :D
  9. Offline


    @hiro24 - hahaha. The thing is, it requires an extra dependency, and we already have 12 :/. What would be a much nicer solution is to add it yourself via the static methods of the class QuestAPI if that's possible :p.
  10. Offline


    I have a problem with evil NPCs. Whenever I enable them, they just spawn right behind players and kill them, and the spawn delay does nothing. I've had to disable them on my server, because it was just unplayable. Any fix for this or is it a general problem with evil NPCs?
  11. Offline


    Here's a shameless self-plug to some software that I've been writing that should tremendously help all of you who are trying to write quests.

    See QuestWriter.

    Still in beta stage, but needs all the testing it can get!
    aPunch likes this.
  12. Offline


    Thank you for posting this! I to had the annoying follower.
  13. Offline


    It would be... if I knew how to program java. :) I've got a couple books I've been looking through tough.. so basically I'd take your API and the Heroes API and make like.. a go between? :confused:
  14. Offline


    [diamond]. End of story.
  15. Offline


    yo br o do you know anything about a quest error with citizens like this: i type: /quester assign [mad world!]
    and this is what i get in response:there is no quest by that name.
  16. Offline


    How do install the dev versions of this plugin?
  17. Offline


    I have a probem with waypoints.

    I can set them all fine, but when i am done, the npc just stands still, whatever i do, it just stands there.
    i have tried the latest dev build as well no help
    I might have missed something, if so please tell me.

    I've been searching for quite a while for an answer for this, but i cant find any help anywhere.
  18. Offline


    Make sure to write the exact quest name. All capital letters must be in the right place and there must be no [] surrounding the quest name.
  19. Offline


    1. sorry i know that somebody ask it befor but on the list of pages i dont found it :(
    2.i have the problem that only i can use the trader (i am op the others are normal useres) (i gave the permission "citizens.trader.use.trade" to the user group
    but it doesnt work
    3. i use citizens v1.1.1 and economy 5

    i hope somebody can help us
    Jotolink likes this.
  20. Yes im getting this same thing as well and also is there any way to set the talk items to nothing or every thing so far i have this in my citizens.yml
    select-items: '*'
    talk-items: '*'
    before i had talk items giving out 00, air and it worked fine but i found out the npc's were actually TAKING the air soo i was wondering if i could keep it like this and enable the npc's not to take anything or just let the player use their bare fists to talk to the npc
    toggle: 'true'
    text: Don't forget to fix your weapons and armor!;Ol' Smithy's got yer fix.;No, Im not busy...Lets just hurry up anyway.;Welcome to ye ol' Smithys...What ye be needin?;We repair worn weapons and armor.
    look-when-close: 'true'
    location: <servername here>,120.35540232785438,65.0,-203.30000001192093,239.53445,-28.405474
    items: 0:0,0:0,0:0,0:0,0:0,
    color: '14'
    inventory: AIR*36, <----- is it really taking air from the players when the select the npc?
    name: OldSmithy
    owner: Jotolink
    talk-when-close: 'false'
    thanks to anyone that replys to this
  21. Offline


    is this in the game or in the program?
  22. Offline


    @Jotolink - no, it's not taking the air. By default, inventories are filled with 'air' which represents an empty slot.
  23. ah ok then but then what about the permissions nodes? they are still acting up, i cant get any of my players to access a npc it keeps saying they dont have permission...here lookit permissions:
    running permissions 3.1.6 (yeti):
    default: false
    prefix: ''
    suffix: ''
    build: true
    - '*'
    default: false
    prefix: ''
    suffix: ''
    build: true
    - Player
    default: true
    prefix: ''
    suffix: ''
    build: true
    - 'citizens.trader.use.list: true'
    - 'citizens.trader.use.trade: true'
    - 'citizens.blacksmith.use.repair: true'
    - 'citizens.blacksmith.use.status: true'
    - 'citizens.healer.use.heal'
    - 'citizens.quester.use.quests.view'
    - 'citizens.quester.use.quests.help'
    - 'citizens.quester.use.quests.abort'
    - 'citizens.quester.use.quests.status'
    - 'citizens.quester.use.quests.status'
    - 'citizens.wizard.use.interact'
    - 'citizens.wizard.use.status'
    - 'citizens.wizard.modify.removeloc'
    - 'citizens.wizard.modify.addloc'
    - 'citizens.wizard.use.locations'
    - 'essentials.back'
    - 'commandbook.rules'
    - 'commandbook.who'
    - 'commandbook.msg'
    - 'commandbook.spawn'
    - 'commandbook.whereami'
    - 'easyrpg.canrpg'
    - 'mcmmo.regeneration'
    - 'mcmmo.skills.*'
    - 'mcmmo.ability.*'
    - 'mcmmo.commands.ability'
    - 'mcmmo.commands.myspawn'
    - 'mcmmo.commands.setmyspawn'
    - 'mcmmo.commands.ptp'
    - 'mcmmo.commands.party'
    - 'mcmmo.chat.partychat'
    - 'iConomy.holdings'
    - 'iConomy.help'
    - 'iConomy.payment'
    - 'iConomy.list'
    - 'shop.create.player'
    - 'simplechestlock.*'
    - 'CreeperHeal.trap.create'
    - 'CreeperHeal.trap.remove.own'
    Oh and also what do i put into the items section in the citizens.yml
    select-items: '*'
    talk-items: '*'
    is it ok to leave it like this or do i need to put in an item?
  24. Offline


    Does citizens support Permsissions 3.1 by yeti?
  25. im actually not shure...how do i check it doesnt say aything on the 3x page of permissions
  26. Offline


    Citizens does not support Nijikokun's/Yeti's Permissions.
  27. ah ok then ima just get bukkit permissions then thanks guys.
  28. Offline


    java.lang.NoSuchMethodError: net.minecraft.server.ItemInWorldManager.<init>(Lnet/minecraft/server/WorldServer;)V
    minecraft 1.8.1
  29. Offline


    I can not get the NPCs to move with /npc path. I get to set the waypoints and finish with /npc path. But the NPC stands still. Is there a command i am missing to activate/start?
  30. Offline


    @Kalabahuae - can you pastebin me your npc-profiles.yml?
    @chris_black - using the wrong craftbukkit version for your Citizens version.
  31. Offline


    In-game commands but the name in QuestWriter. Have a look in quests.yml if you are unsure of the exact name.

Share This Page