[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline


    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
  2. Offline



    My trader doesn't want to sell or buy pistons/sticky pistons, I have triple checked each number, and when I tried to add the items to the shop, it said in chat, that he is already selling it at X amount for X price, where I am guessing that isn't my fault, could you look into that? I think that the Piston/Sticky piston may be bugged for traders
  3. Offline


    Is there a incompatibility to iConomy 6 ?
    Or im just too stupid to edit the config correctly ? ^^

    I wanted to make a money reward for completing a quest, but nobody gets money.

    Here is the code of the reward in my config:
                    type: money
                    amount: 500
                    take: true
    Thanks for your help :)
  4. Offline


    money, not amount
    take: true means they pay to complete the quest
  5. Offline


    Ah, thank you for your help. :)
  6. Have you tried renaming them to names not used by players?
  7. Offline


    Of course this doesn't work. It says 'finishere'. In an earlier post you said it was 'finishnow', and even if it's not that, it'd still be 'finishhere', with two h's.

    Anyways, I read this now because I'm trying to look up information as to how quests in Citizens work. I love the features, I'm just quite clueless on how to implement them, and even if I'm aware of all the possibilities. I've read only just now there are the keywords 'finishnow' and 'optional'. It would be really nice if someone could make an example quests.yml with all available options. (I'd be willing to do so if someone could tell me what exactly is possible and how to do it.)

    There's two things I'm struggling with myself right now. I have a quest to collect Sticks. Here it is:
    Sticking Things Back Together:
            description: <g>Sticking Things Back Together<br><y>[Cyrkon]<br>Norgle is to be fixing the mast. Go into town and collect some wood. Bring Norgle 32 Sticks and then come back to me.
            completion: <g>Quest Complete!<br><y>New Quest unlocked!<br><y>[Cyrkon]<br>Great, could you help Onwexry fix the sails now?<br><g>Setting Sail for Fail<br><y>[Cyrkon]<br>To fix the sails, he'll need some Leather. Could you bring him 7 Pieces of Leather?
            acceptance: <y>Challenge Accepted! Collect 32 Sticks, bring them to Norgle and then go back to Cyrkon!<br><y>NOTE; Collect quests require you to pick up items FROM THE FLOOR!!
        repeats: 1
                    type: collect
                    materialid: 280
                    amount: 32
                    message: <y>You've collected 32 Sticks! Now go take them to Norgle!
                    type: delivery
                    npcdestination: 4
                    materialid: 280
                    amount: 32
                    message: <y>=You hand the Sticks over to Norgle=<br><y>[Norgle]<br>Thanks a bunch!
                type: quest
                quest: Setting Sail for Fail
    What I thought this would do is that you first would be required to collect 32 Sticks, which you would afterwards hand over to the NPC named Norgle. Thing is, like this, it's not even letting me collect the Sticks. Am I doing something wrong here? Also, when on a Collect quest, why are we required to pick each of them up from the floor? This is really annoying for items which you craft, and not naturally pick up. Could there be like a feature where picking items from a Crafting Table or your own Crafting Grid would also count towards completion of a Collect quest?

    Btw, I'm still on 1.1.1, it's annoying how the Changelog doesn't show the exact changes.
  8. Offline


    Which Permissions does this support?
  9. Offline


    For as far as I know only Permission Plugins that support SuperPerms. This would be PermissionsBukkit or bPermissions
  10. Offline


    Pierwsze kroki:
            description: Twoim pierwszym zadaniem bedzie przyniesienie 3 klockow dirta. Do roboty!
            completion: Dobrze sie spisales, lecz do dopiero poczatek.
            acceptance: Powodzenia!
        repeats: 1
                    type: delivery
                    amount: 3
                    materialid: 3
                    message: Czas wracac...
                type: money
                money: 10
                take: false
    Is that okay?
  11. Offline


    your indentation seems perfect to me. I backspaced only in increments of 4 and I set my notepad ++ to have it so whenever I tab it just uses 4 spaces. Never had a problem with that issue before.
    I was wondering.... Am I supposed to keep the "{}" that's at the top of the file there? or should I remove it?

    thanks again!
  12. Offline


    why is it not saving the npc's??????
  13. Offline


    So, I have a small problem, people can not use my NPC's. Here is the citizens permissions I gave them with the Permissions 3 plugin:

    - 'citizens.basic.use.help'
    - 'citizens.trader.use.trade'
    - 'citiznes.trader.use.help'
    - 'citizens.trader.use.list'
    - 'citizens.trader.modify.stock'
  14. Offline


    i have the same problem :S
  15. Offline


    Permissions 3 is not supported. Switch to a superperms manager like permissionsbukkit
  16. Offline


    I always get this error when i try to create an NPC with: /npc Create Name
    Im running CB 1185 (I know its outdated) And citizens version 1.1.2
    GooMan likes this.
  17. Offline


    im getting this same error :(
    GooMan likes this.
  18. Offline


    I am having a problem with the traders. The only way a person can buy is if they are an OP.
    I am using the latest permissions 3, and i have checked, and checked again my permission nodes.
    do i have to switch to a differnet permissions?

    p.s i am using the latest bukkit build, and citizens version 1.1.2
  19. Offline

    David McCahon

    Is the website down? You click download and it jus says please wait.... I left to dinner came back, and it still hangs there. I have tried 3 web browsers
  20. Offline


    yo i downloaded bukkitpermissions and now the quest npc's are not working when i try /quest assign [quest] i put the name in and it said quest doesnot exsist or something like that.....so any advice anyone?
  21. Offline


    me 2.....
  22. Offline


    1.1.2 requires the latest bukkit.

    @fullwall I just remembered another request.. So
    Request no. 3: Quest points.. In addition to rank and quest rewards/requirements.. Addition of quest points
    A quest can award a number of points
    And to expand on that even further.. Maybe make it possible to make an npc visible only to those who have more than or less than a certain amount of quest points (or any other requirement)
  23. Offline


    @GooMan @firecombat4 and @xLoGiiKzZo 1.1.2 works on ONLY 1240.

    Also, @SkyCraft @blitzer88 I think you need the node citizens.[npctype].use.interact.

    @Darkvoltage3 There's probably something wrong in the text of your quest(s) which makes citizens unable to read it. Are you sure you've done everything correctly?

    @ZachQuint You'll need a Permissions plugin that supports SuperPerms.
  24. Offline


    hm i tried the command (last devbuilds)

    /quest reload

    and got "you dont have permissions to to that" i have bukkit permission + OP + citizens.*: true, most commands are functionally.
  25. Offline


    Try /citizens reload instead
  26. Offline


    i know that command, that worked, but i wanted to report a small issue, maybe i should post it in Bukkitdev
  27. Offline


    i'm using groupmanager and when i try to create an NPC i get error message "Please report this error [See consol]

    Why ?
  28. Offline


    thanks so much!
  29. Offline


    @Aeron - from what I understand, the item ID that gets reported by Bukkit is different to what you'd expect. 29 or 39 IIRC...
  30. Offline


    Well can anyone lend a hand?!?!?!?!?!?!??!!??!?!?!!?!?
  31. Offline


    This is an error I found while trying to try out this plugin by trying to make an NPC.
    java.lang.NoSuchMethodError: net.minecraft.server.ItemInWorld
    Please fix this

Share This Page