[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline


    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
  2. Offline


  3. Offline


    is there any permissions plugin that works with citizens 1.1 and minecraft 1.8.1 so my users can use them also?
  4. Offline


  5. Offline


    Did anyone with 1.8.1 and the new devbuilds from bukkit and Citizens 1.1 get it to work with bPermissions?
    I have been trying to get it to work for days now, and it seems it doesn't work with bPermissions.
    There are more people over at the bukkitdev bPermissions thread who can't get it to work.
    Developers, is bPermissions supported?
  6. Offline


    So... how do you assign quests to questers. Is it like they do the quests, or you do it for them?
  7. Offline


    Hello all,
    I have got a problem.
    I have install the plugin, but when i want to create a npc there came this problem:
    "Please report this error:[See console]
    Manager.<init>(Lnet/minecraft/server/WorldServer; )V"
  8. Offline


  9. Offline


    I'm using Permissionsex which is Superperms compatible and Citizens is refusing to acknowledge it. It seems that this plugin isn't superperms compatible but ONLY Permissionsbukkit compatible. The whole permissions system reverts to OP only if it can't see Permisionsbukkit. "PermissionsBukkit or any plugin that utilizes superperms must be used"
    I'm sure it's just a dev build issue, so stay patient. I've got mine working by just using permissionsbukkit in paralell to permissionsex and not configuring permissionsbukkit at all.
  10. Offline


    2011-09-22 14:57:40 [SEVERE] java.lang.NoSuchMethodError: net.minecraft.server.ItemInWorldManager.<init>(Lnet/minecraft/server/WorldServer;)V
    2011-09-22 14:57:40 [SEVERE] at com.citizens.resources.npclib.NPCSpawner.spawnNPC(NPCSpawner.java:35)
    2011-09-22 14:57:40 [SEVERE] at com.citizens.npcs.NPCManager.register(NPCManager.java:46)
    2011-09-22 14:57:40 [SEVERE] at com.citizens.npcs.NPCManager.register(NPCManager.java:89)
    2011-09-22 14:57:40 [SEVERE] at com.citizens.commands.commands.BasicCommands.create(BasicCommands.java:235)
    2011-09-22 14:57:40 [SEVERE] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    2011-09-22 14:57:40 [SEVERE] at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    2011-09-22 14:57:40 [SEVERE] at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    2011-09-22 14:57:40 [SEVERE] at java.lang.reflect.Method.invoke(Unknown Source)
    2011-09-22 14:57:40 [SEVERE] at com.citizens.resources.sk89q.CommandsManager.executeMethod(CommandsManager.java:518)
    2011-09-22 14:57:40 [SEVERE] at com.citizens.resources.sk89q.CommandsManager.execute(CommandsManager.java:404)
    2011-09-22 14:57:40 [SEVERE] at com.citizens.Citizens.onCommand(Citizens.java:196)
    2011-09-22 14:57:40 [SEVERE] at org.bukkit.command.PluginCommand.execute(PluginCommand.java:39)
    2011-09-22 14:57:40 [SEVERE] at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:163)
    2011-09-22 14:57:40 [SEVERE] at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:353)
    2011-09-22 14:57:40 [SEVERE] at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:756)
    2011-09-22 14:57:40 [SEVERE] at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:721)
    2011-09-22 14:57:40 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:714)
    2011-09-22 14:57:40 [SEVERE] at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
    2011-09-22 14:57:40 [SEVERE] at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    2011-09-22 14:57:40 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:92)
    2011-09-22 14:57:40 [SEVERE] at org.getspout.spout.SpoutNetServerHandler.a(SpoutNetServerHandler.java:500)
    2011-09-22 14:57:40 [SEVERE] at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
    2011-09-22 14:57:40 [SEVERE] at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:464)
    2011-09-22 14:57:40 [SEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:374)
    2011-09-22 14:57:40 [SEVERE] at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    plz fix?
  11. Offline


    It would be nice to have some statement about that from the plugin developper :)
  12. Offline


    Untill a few days ago that line was "like PermissionsBukkit and bPermissions" This was the reason i switched to bPermissions.

    But to ask you about the double permissions setup... How did you get that to work. Define everything in your main one, and run PermissionsBukkit alongside. do you need to specify groups in there to have your players utilize the traders?

    I'm sure they're working hard on it. And I'll wait patiently. but it would indeed be nice....

    If I could get this plugin to work I'm sure it would be awesome!
  13. Offline


    Huhu! Going to test it!
  14. Offline


    How do you save the npc-s to the file ? I saw the log saying that the npcs have been saved to the hard disk... But is there any manual way to do it ? Please reply.
  15. Offline


    Confirming Citizens traders now work with bPermissions.
    Just the dissapearing thing with multiple worlds.... I see when the traders load upon server start bPermissions places them in the default group. Since the default group spawns in a different world, they get spawned there, and get transported to they're right place.
    Every now and then they disappear. I'm going to try putting them in a the default group of the world they are supposed to be in. I hope thet helps.

    I'll keep you posted.

    EDIT: Nope not it. bPermissions already placed them in the default group for the world.
  16. Offline


    what ver of bperm you using? also what's the trader nodes?
  17. Offline


    Did the permissions change for waypoint modifiers in the dev build of 1.1? I set the ones described in the wiki, but I am still not able to set any of the modifiers.
  18. Offline


    1.6.0 or 1.6.6 I'm not sure, and I can't check now.
    You needmto be op to make and stock them. Or dig through all the permissions to find the ones you need. Your players need the -citizens.trader.use.trade one to be able to trade with then.
  19. Offline


    ok I was trying the dev builds and I was getting tons of errors pissing me off

    Ok so I tried 1.6.0 and still doesn't work I guess I'll try 1.6.6 now
  20. Offline


    Trying to add some flags to a Guard Bodyguard, and when I try to use /guard addflag, all I can get is:

    No type flags specified.

    Using: Recommended Build: 1185 (MC: 1.8.1)
  21. Offline


    @Aeron - one of the flags -m -p -g -a must be used, to determine which type you are referring to (monster, player, group, all, respectively).
    @remypas - hmm... I'll try tracking this bug down again, it's quite persistent :S.
  22. Offline


    @fullwall, ok, I did like you said, tried, for example, a coomand on a guard: /guard addflag 1 spider -m, but the guard didn't attack the spider, nor a zombie, when I tried toadd another flag: /guard addflag 1 zombie -m

  23. Offline


    @Aeron - can you check a couple of things for me then? 1) is the guard a bouncer? (/guard bouncer) 2) is it aggressive (/guard aggro) 3) is the range wide enough? (/guard radius [amount]).
  24. Offline


    It's a Bodyguard Guard, it moves along the player who it guards.
  25. Offline


    @Aeron - what radius is it set to? And is it aggressive?
  26. Offline


    Do you have any plan about the NPC feature of the 1.9 minecraft update?

    Like using their skins
  27. Offline


    Imma need 1.8 support!!1
  28. Offline


    @fullwall, yes, aggressive, but I didn't set up ownership of that NPC though (didn't think i need to, since its not a trader)
  29. Offline


    when comes Citizens 1.1?
  30. Offline


  31. Offline


    How does the plugin run when there's 50+ npc's going with the latest dev builds. I would like to create enemy npc fortresses that guard loot on a 2 gig ram server thats 24 cores. Can't recall full specs of my server.

Share This Page