[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline


    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
  2. Offline


    The command /npc rename bugs out the npc renamed and he will not get selected and you cant remove him.
  3. Offline


    i keep getting this error no matter how many times i reload my server(and i apolagize for not putting it in code it doesn't load whenever i try);
    10:47:29 [SEVERE] [Hawox's iQuest]:QuestLoader:reader:FileNotFoundException!!!
    10:47:29 [SEVERE] Error occurred while enabling iQuest v3.1.0 (Is it up to date?
    ): null
    at org.yaml.snakeyaml.reader.StreamReader.update(StreamReader.java:148)
    at org.yaml.snakeyaml.reader.StreamReader.peek(StreamReader.java:117)
    at org.yaml.snakeyaml.reader.StreamReader.peek(StreamReader.java:106)
    at org.yaml.snakeyaml.scanner.ScannerImpl.scanToNextToken(ScannerImpl.ja
    at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreTokens(ScannerImpl.ja
    at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(ScannerImpl.java:18
    at org.yaml.snakeyaml.parser.ParserImpl$ParseImplicitDocumentStart.produ
    at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:163)
    at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:148)
    at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:104)
    at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseCons
    at org.yaml.snakeyaml.Yaml.load(Yaml.java:264)
    at sddddgjd.iquest.questclasses.QuestLoader.<init>(QuestLoader.java:67)
    at sddddgjd.iquest.iQuest.theQuestsLoadAllIntoArray(iQuest.java:398)
    at sddddgjd.iquest.iQuest.onEnable(iQuest.java:184)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:162)
    at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:146
    at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:284)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:271)
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:148)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:335)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
  4. Offline


    how to make, that they speak, when you walk tp them?
  5. Offline


    Hello everyone!

    We recently installed this plugin and it was working fine for about 5 minutes. Now our npcs are all frozen and wont move or look around. I tried /citizens reload and I got this error : :(

    11.08 18:32:12 [Server] SEVERE at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
    11.08 18:32:12 [Server] SEVERE at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
    11.08 18:32:12 [Server] SEVERE at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    11.08 18:32:12 [Server] SEVERE at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:85)
    11.08 18:32:12 [Server] SEVERE at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    11.08 18:32:12 [Server] SEVERE at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
    11.08 18:32:12 [Server] SEVERE at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:670)
    11.08 18:32:12 [Server] SEVERE at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:677)
    11.08 18:32:12 [Server] SEVERE at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:713)
    11.08 18:32:12 [Server] SEVERE at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:320)
    11.08 18:32:12 [Server] SEVERE at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:129)
    11.08 18:32:12 [Server] SEVERE at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    11.08 18:32:12 [Server] SEVERE at com.citizens.Citizens.onCommand(Citizens.java:196)
    11.08 18:32:12 [Server] SEVERE at com.citizens.resources.sk89q.CommandsManager.execute(CommandsManager.java:404)
    11.08 18:32:12 [Server] SEVERE at com.citizens.resources.sk89q.CommandsManager.executeMethod(CommandsManager.java:518)
    11.08 18:32:12 [Server] SEVERE at java.lang.reflect.Method.invoke(Method.java:597)
    11.08 18:32:12 [Server] SEVERE at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    11.08 18:32:12 [Server] SEVERE at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    11.08 18:32:12 [Server] SEVERE at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    11.08 18:32:12 [Server] SEVERE at com.citizens.commands.commands.BasicCommands.reload(BasicCommands.java:98)
    11.08 18:32:12 [Server] SEVERE at com.citizens.properties.properties.UtilityProperties.initialize(UtilityProperties.java:21)
    11.08 18:32:12 [Server] SEVERE at com.citizens.properties.ConfigurationHandler.<init>(ConfigurationHandler.java:33)
    11.08 18:32:12 [Server] SEVERE at com.citizens.properties.ConfigurationHandler.load(ConfigurationHandler.java:55)
    11.08 18:32:12 [Server] SEVERE at org.bukkit.util.config.Configuration.load(Configuration.java:82)
    11.08 18:32:12 [Server] SEVERE at org.yaml.snakeyaml.Yaml.load(Yaml.java:264)
    11.08 18:32:12 [Server] SEVERE at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:124)
    11.08 18:32:12 [Server] SEVERE at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:105)
    11.08 18:32:12 [Server] SEVERE at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:122)
    11.08 18:32:12 [Server] SEVERE at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    11.08 18:32:12 [Server] SEVERE at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:230)
    11.08 18:32:12 [Server] SEVERE at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    11.08 18:32:12 [Server] SEVERE at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:230)
    11.08 18:32:12 [Server] SEVERE at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    11.08 18:32:12 [Server] SEVERE at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:228)
    11.08 18:32:12 [Server] SEVERE at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:148)
    11.08 18:32:12 [Server] SEVERE at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:163)
    11.08 18:32:12 [Server] SEVERE at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingKey.produce(ParserImpl.java:576)

    Then I tried /citizens debug and I got this error :

    11.08 18:42:04 [Server] SEVERE at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    11.08 18:42:04 [Server] SEVERE at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
    11.08 18:42:04 [Server] SEVERE at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
    11.08 18:42:04 [Server] SEVERE at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    11.08 18:42:04 [Server] SEVERE at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:85)
    11.08 18:42:04 [Server] SEVERE at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    11.08 18:42:04 [Server] SEVERE at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
    11.08 18:42:04 [Server] SEVERE at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:670)
    11.08 18:42:04 [Server] SEVERE at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:677)
    11.08 18:42:04 [Server] SEVERE at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:713)
    11.08 18:42:04 [Server] SEVERE at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:320)
    11.08 18:42:04 [Server] SEVERE at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:129)
    11.08 18:42:04 [Server] SEVERE at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    11.08 18:42:04 [Server] SEVERE at com.citizens.Citizens.onCommand(Citizens.java:196)
    11.08 18:42:04 [Server] SEVERE at com.citizens.resources.sk89q.CommandsManager.execute(CommandsManager.java:404)
    11.08 18:42:04 [Server] SEVERE at com.citizens.resources.sk89q.CommandsManager.executeMethod(CommandsManager.java:518)
    11.08 18:42:04 [Server] SEVERE at java.lang.reflect.Method.invoke(Method.java:597)
    11.08 18:42:04 [Server] SEVERE at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    11.08 18:42:04 [Server] SEVERE at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    11.08 18:42:04 [Server] SEVERE at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    11.08 18:42:04 [Server] SEVERE at com.citizens.commands.commands.BasicCommands.debug(BasicCommands.java:148)
    11.08 18:42:04 [Server] SEVERE java.lang.NullPointerException

    If anyone has any help on this matter, it would be GREATLY appreciated! Thanks!!
  6. Offline


    I have set him up properly, all the buy values etc. But whenever anyone or I (After setting the owner to a random name) try to use it, it just lets us take the item out of the inventory no sales or purchases. Just... like a chest.

    Iam using citizens with iconomy without permission and all people on my server are op
  7. Offline


    "' You don't have permission to do this. ''' When i try to create a NPC.
    I'm the Admin and don't use permissions.
  8. Offline


    Will there be a detailed using page?
    Would be grate (=
    And for what is the quests.yml?
    Great plugin anyway (=

    Which plugins are supportet by this one?
  9. Offline


    Hmm. I doesn't sound TOO bad. I still hope that players are unaffected by this. I'm just concerned because they're considered as players by essentials and so... Thanks for the explanation, I'll update.

    Do /npc talkclose


    Due to a change in Citizens, I think that you either have to use permissions or to not be OP. Trust me, I didn't want to use permissions at first, but it's not as bad and complicated as it seems :)
    L3nnyBoss likes this.
  10. Offline


    Where are the modes listed? I want to know the modes for /wizard [mode] for example. I looked on the wiki and I couldn't find it.
  11. Offline


    This isn't a problem with Citizens, you've messed up your yml files in iQuest.
    Go there to check your config.yml and quests.yml.

    Go there to check all of your Citizens yml files.
  12. Offline


    So IS there a way to get cusstom skins on your NPCs?
  13. Offline


    I'm having a rather annoying error. I installed the latest version of BOSEconomy and it can't link to the most up-to-date version of Citizens. In the economy.yml file I tried changing econplugin (Every appearance of it) to BOSEconomy. I then got a message saying that Citizens was successfully linked to it, but when I tried to test a trader and blacksmith, I got a message telling me that my server did not have an economy plugin installed, so I changed every instance of BOSEconomy in the economy.yml file back to econplugin. It still isn't working. I'm using the latest version of CraftBukkit too. Can somebody help me?
  14. Offline


    Thanks for the reply, but I have checked all of my yml files and none of them had any errors..

    Please help!!

    Edit: I have removed all single quote except the ones mentioned on the original page. Now I am getting this for both commands:

    12.08 04:26:39 [Server] SEVERE at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
    12.08 04:26:39 [Server] SEVERE at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
    12.08 04:26:39 [Server] SEVERE at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    12.08 04:26:39 [Server] SEVERE at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:85)
    12.08 04:26:39 [Server] SEVERE at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    12.08 04:26:39 [Server] SEVERE at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
    12.08 04:26:39 [Server] SEVERE at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:670)
    12.08 04:26:39 [Server] SEVERE at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:677)
    12.08 04:26:39 [Server] SEVERE at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:713)
    12.08 04:26:39 [Server] SEVERE at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:320)
    12.08 04:26:39 [Server] SEVERE at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:129)
    12.08 04:26:39 [Server] SEVERE at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    12.08 04:26:39 [Server] SEVERE at com.citizens.Citizens.onCommand(Citizens.java:184)
    12.08 04:26:39 [Server] SEVERE at com.citizens.resources.sk89q.CommandsManager.hasCommand(CommandsManager.java:252)
    12.08 04:26:39 [Server] SEVERE java.lang.NullPointerException
  15. Offline


    alright this might be a nooby question or what not,
    but after i toggle an npc and set it as a trader i stock him up, but
    theres no command to trade with him, when i right click him it goes into the stocking window
    how can i actually buy stuff from the trader?
  16. Offline


    Edit 2: After some more testing, it seems that the plugin keeps breaking itself by adding the quotes every time I switch debug mode.
  17. Offline


    when i try reloading my citizens i get this error

    Please report this error:[See Console]
    java.lang.ClassCastException: java.lang.String cannot be cast to java.lang.Boolean

    i'm using minecraft 1.7.3 , craftbukkit v1000
    was using
    Help would be greatly appreciated
  18. this still havent got answer?
  19. Offline


    As I heard, we were able to connect Citizens to MySQL? Theres no connection option in any of the citizens files to write down my database. Am I just blind or is it just a myth?
  20. Offline


    I got a Problem:

    I already createt a few NPCs.
    Now I create 2 traders.
    But when I stay away for a few min they just disappear.
    When I reload the Server they come back.
    After a few min staying away, the same problem again!
    Help please!
  21. Offline


    Ok thanks man but now I read the changelog from the newest version and there stands:
    -fixed inventory not updating properly while making purchases
    But my server uses bukkit 953 -.- should i update my server to use the newest version or should i just install permission
  22. Offline


  23. Offline


    No you dont must to update! To all people who has the same problem just install permissions! DK why you need it but then it works great
  24. Offline


    If you look in the first post of the thread there should be a list to the wiki that will tell you how to work the various commands. You will want to go over to the wiki and read up on it.
  25. Offline


    Okay I know there is a bug listed as "NPCs disappear when you teleport next to them" but for me, they disappear even when I stand next to them for a period of time.

    I just installed the latest version (1.0.9d) (old version was fine except the right clicking to get messages but that didnt bother me much but I thought maybe it was fixed in new version hence the update) but after creating the first NPC, it first told me I needed 10 red flowers but I have full admin rights so it still created it despite that message. Then I had to select it and tried to add text. After adding text, and turning on "talkclose" it worked fine about 3 times then he disappeared. The text still appears when you goto where he used to be but the actual NPC is not there.

    Im using 1.0.9d
    Bukkit: #1046
    OS: Linux
  26. Offline


    I've been having a few strange errors myself. I sold some stuff to an NPC today, about 10 minutes later the owner of the npc dropped by to pick up the goods. And the goods were gone. I initially suspected pirates or some sort of elaborate NPC driven scam, however it turns out that the NPC just kinda forgot his inventory.

    In the same vein, my wizards mana keeps being set to zero. (maybe more correctly it is being restored to zero?)

    And we are having some errors in moving our NPC's around. They tend to not move half the time. Logging out and back in again seems to fix the problem, half of the time. Sometimes it just winds up duplicating them.

    Nothing really showing up in logs, just a bunch of messages saying "Despawning something at something and something" and then a similar respawning message.
  27. Offline


    I'm using iConomy 5 and Citizens 1.0.9d and it won't hook into iConomy for some reason...

    Here is my economy.yml
        use-econplugin: true
        use-economy: false
                item: 10
                econplugin: 100
                item-currency-id: 37
                    wood: 1
                    diamond: 5
                    stone: 3
                    gold: 2
                    iron: 4
                    misc: 2
                    wood: 0.25
                    diamond: 1.25
                    stone: 0.75
                    gold: 0.5
                    iron: 1
                    misc: 0.5
                item-currency-id: 37
                    diamond: 5
                    gold: 2
                    leather: 1
                    iron: 4
                    chainmail: 3
                    diamond: 1.25
                    gold: 0.5
                    leather: 0.25
                    iron: 1
                    chainmail: 0.75
                item-currency-id: 37
                item: 10
                econplugin: 100
                item-currency-id: 37
                item: 10
                econplugin: 100
                item-currency-id: 37
                item: 10
                econplugin: 100
                item-currency-id: 37
                item: 10
                econplugin: 100
                item-currency-id: 37
                item: 10
                econplugin: 100
                item-currency-id: 37
                item: 10
                econplugin: 100
                item-currency-id: 37
                item: 10
                econplugin: 100
                item-currency-id: 37
                item: 10
                econplugin: 100
                item-currency-id: 37
                item: 10
                econplugin: 100
                item-currency-id: 37
                item: 10
                econplugin: 100
                item-currency-id: 37
                item: 10
                econplugin: 100
                item-currency-id: 37
                item: 10
                econplugin: 100
                item-currency-id: 37
  28. Offline


    I am going to go out on a crazy limb here and say:

    I think if you want to have an economy you may need to have use-economy set to True.

    What puzzles me is that I thought the config file defaulted the use-economy to true. So you would have had to go in and actually had shut it off.

    I may be wrong.
  29. Offline


    My NPCs are vanishing after some time. They are still in the Serverfiles, but they are not on their place (So i dont "bump" against them when I walk there, where they were). After some time they are suddenly there again.
    I think this happens after somebody went to Netherworld.

    I see there are more PPl with this problem, but is there even a solution ?
  30. Offline


    Well my solution was to downgrade back to an older version lol. Now my NPCs dont disappear BUT I figured out 1 problem I was having which is resolved really. I'm gonner stick with this version till NPC guards are setup :)
  31. Not sure what's wrong but I can't give npc's armor no more ? It doesn't seem to "save" the armor in the config file.

Share This Page