[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline


    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
  2. Offline


    I just updated from 1.0.9c to the latest version and i get this error:

    2011-07-25 08:40:17 [SEVERE] Could not pass event CHUNK_UNLOAD to Citizens
    java.lang.NoClassDefFoundError: Could not initialize class com.citizens.CreatureTask
            at com.citizens.listeners.WorldListen.onChunkUnload(WorldListen.java:51)
            at org.bukkit.plugin.java.JavaPluginLoader$49.execute(JavaPluginLoader.java:584)
            at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
            at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:332)
            at net.minecraft.server.ChunkProviderServer.unloadChunks(ChunkProviderServer.java:243)
            at net.minecraft.server.World.doTick(World.java:1705)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:441)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Any Ideas?

    if i delete my citizen folder completely and restart i get tehse errors:
    2011-07-25 08:47:23 [WARNING] Task of 'Citizens' generated an exception
    java.lang.ClassCastException: java.lang.Float cannot be cast to java.lang.Integer
            at com.citizens.SettingsManager$Constant.toDouble(SettingsManager.java:155)
            at com.citizens.waypoints.WaypointPath$WaypointScheduler.run(WaypointPath.java:103)
            at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:137)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:438)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
  3. Offline


    you download the iconomy plugin?
  4. Hi.
    Since I've updatet Citizens from version 1.0.9c to 1.0.9d the members which belong to the default-group aren't able to use the NPCs. Neither the trader nor the healer and so on... :\

    Bukkit version: git-Bukkit-0.0.0-945-g73697a4-b1000jnks (MC: 1.7.3)
    Economy plugin: Essentials v2.4.2
    Permission plugin: EssentialsGroupmanager v1.0(alpha-5)

    The default group has the permission to use all NPCs (- citizens.use.*). If I set the owner of the NPC to another player (no matter of which group he's a member) I – as a member of the admin-group – can use the traders and healer.
    Also if I'm using "- citizens.use.trader" / "[...].healer" nothing changes.

    Any ideas how to solve this problmen without switching to the older version of citizens?

  5. Offline


    Your permissions nodes are incorrect. We switched to new nodes in v1.0.9d. Look here for the new nodes.
  6. Offline


    Your permissions nodes are incorrect. We switched to new nodes in v1.0.9d. Look here for the new nodes.

    @topsub You need to remove all single quotes in your configuration files except for the nodes 'general.chat.format' and 'items.select-items'. Nevermind, hadn't realized you deleted your Citizens folder. I'll look into that error.
  7. Thanks a lot :) I hadn't realized this. *going to try*
  8. Offline


    @aPunch @fullwall
    I also get the error above
    23:04:21 [WARNINGTask of 'Citizens' generated an exception
            at com
    at com.citizens.properties.properties.BasicProperties.getWaypoints(Basic
    at com.citizens.properties.properties.BasicProperties.loadState(BasicPro
    at com.citizens.properties.PropertyManager.load(PropertyManager.java:51)

    at com.citizens.npcs.NPCManager.register(NPCManager.java:64)
    at com.citizens.Citizens.setupNPCs(Citizens.java:305)
    at com.citizens.Citizens.access$0(Citizens.java:286)
    at com.citizens.Citizens$1.run(Citizens.java:120)
    at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(C
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:438)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    CB 1000
    Citizen 1.0.9D

    It appears to be caused by the "npc-profiles.yml" that gets converted from 1.0.9c, If I had to guess it is not converting the paths to the new waypoint standards. Above error is gone with a fresh npc-profiles.yml is generated

    Oh and it also picks up ecoessentials instead of iconomy5 when it initalizes whats with that. Better test with essentials 2.5.5 ;) could be an change there not sure.

    I have included my citizens plugin folder for your to ease on testing for you guys it contains converted data from 1.0.9c and fires the error mentioned above.

    Attached Files:

  9. Thanks a lot :) I hadn't realized this. *going to try*
    ~3 minutes later~

    Works fine! Tyvm :)
  10. Offline


    Is there a way to change the skin of the NPCs?
  11. Offline


    BukkitContrib or name them to a name of the legit minecraft players skin u want.
  12. Offline


    If you read any of the other 200 posts on the subjects, you would know the answer to this..
  13. No thats not the issue dude >.> " works fine for me and citizen loads up fine, but thows this error. As aPunch said up there it's an issue with chunk unloading and stuff if you knew a bit of java you would have seen it in the error log :)
  14. Offline


    Thanks. I was wondering if BukkitContrib would do that or not...

    Wow... Not useful... I've looked through pages of posts on here, but with 200+ pages its a bit tough to find what I'm looking for. And unless I'm mistaken they don't have any info on doing this on their wiki.
  15. Offline


    Did 1.09d fix the trader dupe glitch?
  16. Offline


    Did 1.09d fix the trader dupe glitch?
  17. Offline


  18. Offline


  19. Offline


    In which config can I change when the NPC's talk to me? It works only with books, but I couldn't find #340 (books) in any configuration file :(
  20. Offline


    Citizens.yml :

    item-list-on: true
    select-items: '*'
    talk-items: 340, <-- This one!
    give-health-item: 35
    take-health-item: 278
    mana-regen-item: 348
    interact-item: 288
  21. Offline


    Theres a file in your citizens file that has a option to enable the iconomy plugin I think its
    Iconplugin: true im away from pc right now on trip so good luck
  22. Offline

    tha d0ctor

    the new update makes my server keep restarting over and over and makes a million errors when enabling/disabling citizens..

    did you even test it?

  23. Offline

    tha d0ctor

    this new version seems to be broken

    I want to go back to 1.0.9c :(
  24. Offline


    Same here... deleted all ' and " in my configs, tried it with a clean folder... same error ;) I stay with 1.0.9c for the moment, works fine =)
  25. Offline

    tha d0ctor

    same here, I re-downloaded 1.0.9c and everything works great, no errors, no exceptions
  26. Offline


    could you make a command so they freeze? as in stop moving so you can display the characters that get on the server?
  27. I had the same Problem, but I found a solution, replace all your config-Files (quests.yml, citizens.yml, economy.yml and mob.yml) with the new from the new zip-File, than it works fine again, please don't replace the npc-profiles.yml, else all your NPCs deleted.
  28. Offline


    OK, but what to to if I wanted that they talk to me with all items? A * doesn't work, nothing doesn't work.
  29. Offline


    [WARNING] Task of 'Citizens' generated an exception
    java.lang.ArrayIndexOutOfBoundsException: 1
        at com.citizens.utils.LocationUtils.loadLocation(LocationUtils.java:64)
        at com.citizens.properties.properties.BasicProperties.getWaypoints(BasicProperties.java:261)
        at com.citizens.properties.properties.BasicProperties.loadState(BasicProperties.java:312)
        at com.citizens.properties.PropertyManager.load(PropertyManager.java:51)
        at com.citizens.npcs.NPCManager.register(NPCManager.java:64)
        at com.citizens.Citizens.setupNPCs(Citizens.java:305)
        at com.citizens.Citizens.access$0(Citizens.java:286)
        at com.citizens.Citizens$1.run(Citizens.java:120)
        at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:137)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:438)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    i replaced all my configs except npc profiles and downloaded the d update and i get this when it starts up
  30. Offline


    Could anyone tell me where to get the permission nodes for 109c please? I don't want to update to 109d because it seems to be unstable at them moment, and on the wiki, i am assuming it is only the 109d commands.
  31. Offline


    Is it possible to change the NPC's skins using a bukkit plugin that allows skin changing using bukkitcontrib and something like PlayerEditor? Just wondering, as that would be cool!

Share This Page