[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline


    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
  2. Offline


    I removed all the ' in the configs, using 1.0.9c. Everything but "select-items: '*'2 and "format: '[%name%]: '" worked like a charm. Citizens would not load if I removed those two.

    From what I've been able to gather, Traders should work, right? Oddly enough, I'm still having the bug where the trader says that he does not have enough money to buy it when I myself try to buy something.

    I have a lot of plugins on the server, and I'm starting to think that something is silently conflicting with Citizens.


    Alright, that explains why the configs worked. It just reverted back to having '' around them.
  3. Offline


    It reverts? If so, don't bother until the update, just note that you'll have to do it when the update comes out. Perhaps a separate stripped copy could be kept.
  4. Offline


    ok - and How can I change default NPC's skin to my own skin?
  5. Offline


    You can't.
  6. Offline


    Yeah, I'm keeping a copy for now. But the configs just reverted back again to not having the '

    :confused: Anyway, What's with the traders? I can't seem to find a straight answer. Is the bug fixed?
  7. Offline


    what is you talk item set to in you citizens.yml? the you need to hit the npc with that item to make them talk
  8. Offline


    @fullwall Thx for answer, I've an other question, when i right-clicked on my pnj that's write You select [name_Pnj] (ID0) . I wan't that don't appear for my players. Can I ? I'm boring ? Sorry ^^' I try to understand because I don't find all answer in the wiki
  9. Offline


    @bibivincs - yes, you can change the message in the citizens yml - general.chat.selection-message.
  10. Offline


    Thank you to answer so fast :)
    It's good to have a community like that
  11. Offline


    Can we have native Superperms support?
  12. Offline


    As stated, you can not. However the Plugin 'Player Edit' is planning on doing a Citizens compatible update in the future. I think it is slated not for the next update, but for the one after.

    With that you'll be able to skin NPC's however, any players wishing to see this will need to have Bukkitcontrib installed client side.
  13. Offline


    Is there a way to get npcs to pause at a waypoint during their path? It would be nice if they would move somewhere, wait for a while, then move on to the next point. If not, I'd like this as a feature request! (/npc path, then maybe click twice on a tile to add a wait for a number of seconds)
  14. Offline


    @Tauryuu - yes, we will be implementing Superperms support. @quickclay - we are hopefully going to be implementing more types of waypoints - suggestions appreciated (so far it's just a 'wait' point and a normal walk point).
  15. Offline


    I don't quite understand what you mean. Are you saying to remove quotes? Can you give a example?

    do you mean like:

    look-when-close: 'true' should be look-when-close: true
  16. Offline


    I have a problem!
    Please Help Me!
    What should I do?
    21:25:38 [INFO] [Citizens] Loaded 0 quests.
    21:25:38 [SEVERE] Error occurred while enabling Citizens v1.0.9 (Is it up to dat
    ?): com/nijikokun/bukkit/Permissions/Permissions
    .lang.NoClassDefFoundError: com/nijikokun/bukkit/Permissions/Permissions
    at com
    at com
    at org
    at org
    at org
    at org
    at org
    at net
    at net
    at net
    at net
    at net
    Caused by: java.lang.ClassNotFoundException: com.nijikokun.bukkit.Permissions.Pe
    at java
    .net.URLClassLoader$1.run(Unknown Source)
    at java
    .security.AccessController.doPrivileged(Native Method)
    at java
    .net.URLClassLoader.findClass(Unknown Source)
    at org
    at org
    at java
    .lang.ClassLoader.loadClass(Unknown Source)
    at java
    .lang.ClassLoader.loadClass(Unknown Source)
    ... 12 more
  17. Offline


    Hello, I have a problem, when create a Npc I have a problem, in ma console, i see
    [SEVERE] java.lang.NullPointerException
    2011-07-20 20:03:46 [SEVERE] at org.anjocaido.groupmanager.permissions.NijikoPermissionsProxy.permission(NijikoPermissionsProxy.java:242)
    2011-07-20 20:03:46 [SEVERE] at org.anjocaido.groupmanager.permissions.NijikoPermissionsProxy.has(NijikoPermissionsProxy.java:225)
    2011-07-20 20:03:46 [SEVERE] at com.citizens.Permission.permission(Permission.java:67)
    2011-07-20 20:03:46 [SEVERE] at com.citizens.Permission.isAdmin(Permission.java:33)
    2011-07-20 20:03:46 [SEVERE] at com.citizens.Permission.canCreate(Permission.java:40)
    2011-07-20 20:03:46 [SEVERE] at com.citizens.resources.sk89q.CitizensCommandsManager.hasPermission(CitizensCommandsManager.java:29)
    2011-07-20 20:03:46 [SEVERE] at com.citizens.resources.sk89q.CommandsManager.hasPermission(CommandsManager.java:554)
    2011-07-20 20:03:46 [SEVERE] at com.citizens.resources.sk89q.CommandsManager.executeMethod(CommandsManager.java:451)
    2011-07-20 20:03:46 [SEVERE] at com.citizens.resources.sk89q.CommandsManager.execute(CommandsManager.java:406)
    2011-07-20 20:03:46 [SEVERE] at com.citizens.Citizens.onCommand(Citizens.java:193)
    2011-07-20 20:03:46 [SEVERE] at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    2011-07-20 20:03:46 [SEVERE] at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:129)
    2011-07-20 20:03:46 [SEVERE] at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:298)
    2011-07-20 20:03:46 [SEVERE] at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:711)
    2011-07-20 20:03:46 [SEVERE] at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:676)
    2011-07-20 20:03:46 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:669)
    2011-07-20 20:03:46 [SEVERE] at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
    2011-07-20 20:03:46 [SEVERE] at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    2011-07-20 20:03:46 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:84)
    2011-07-20 20:03:46 [SEVERE] at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    2011-07-20 20:03:46 [SEVERE] at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
    2011-07-20 20:03:46 [SEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
    2011-07-20 20:03:46 [SEVERE] at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)

    Help me please and i'm french but i can translate :)
  18. Offline


    Salut tu as modifié un fichier ou autre ?
  19. Offline


    what's the permission of the /trader list [buy/sell] for a normal player?
  20. Offline


    Non je n'ai rien modifer, j'ai juste ajouté le Citizen.Jar dans mon dossier plugins.
  21. Offline


    bisarre, tu utilise quoi d'autre comme autre plugin? Tu utilise permission?
  22. Offline


    I get this with Citizens git version on CB1000:
    00:55:36 [SEVERE] Could not pass event ENTITY_DAMAGE to Citizens
    java.lang.NoClassDefFoundError: Could not initialize class com.citizens.CreatureTask
        at com.citizens.listeners.EntityListen.onEntityDamage(Unknown Source)
        at org.bukkit.plugin.java.JavaPluginLoader$58.execute(JavaPluginLoader.java:649)
        at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
        at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:332)
        at net.minecraft.server.EntityLiving.R(EntityLiving.java:122)
        at net.minecraft.server.Entity.m_(Entity.java:195)
        at net.minecraft.server.EntityLiving.m_(EntityLiving.java:217)
        at net.minecraft.server.EntityMonster.m_(EntityMonster.java:30)
        at net.minecraft.server.World.entityJoinedWorld(World.java:1198)
        at net.minecraft.server.WorldServer.entityJoinedWorld(WorldServer.java:48)
        at net.minecraft.server.World.playerJoinedWorld(World.java:1180)
        at net.minecraft.server.World.cleanUp(World.java:1104)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:447)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Compiles fine.
  23. Offline


    @Dimochka , do you have any PvP-controlling plugin? 'Cause I was using Pvptoggle and it gave me the same error.
  24. Offline


    I want this time the bug report in the official forum.
    I find that very often: our NPCs lose their configuration.

    As an example:
    We have a trader who sells/buy 7 or 8 items . Sometimes he loses his Skill and is NOT a trader anymore.

    I can not use this plugin. The players pay Coins for the skill of there NPCs..

    - This is not only by renaming the NPC! it happens randomy
    - This happens without any plugin-reload or server reboot..
    - for example the Trader: his part in the Configfile "trader:" is completly removed...
    - NO exceptions in the serverlog

    Please please please fix this i will give you maanyyy [diamond][diamond] for that! ;)
  25. Offline


    I get this error when starting up Citizens 1.0.9c

    17:42:52 [SEVERE] Error occurred while enabling Citizens v1.0.9 (Is it up to date?): org.bukkit.util.config.Configuration.getAll()Ljava/util/Map;
    java.lang.NoSuchMethodError: org.bukkit.util.config.Configuration.getAll()Ljava/util/Map;
    at com.citizens.properties.CachedYAMLHandler.clear(CachedYAMLHandler.java:57)
    at com.citizens.properties.CachedYAMLHandler.load(CachedYAMLHandler.java:35)
    at com.citizens.properties.CachedYAMLHandler.<init>(CachedYAMLHandler.java:29)
    at com.citizens.properties.PropertyManager.<clinit>(PropertyManager.java:14)
    at com.citizens.Citizens.registerTypes(Citizens.java:269)
    at com.citizens.Citizens.onEnable(Citizens.java:86)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:125)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:799)
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:253)
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:140)
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:118)
    at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:232)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:219)
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:146)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
  26. Offline


    Who currently are the developers right now? I know someone was finished with their work here.

    EDIT: By the way, if you are in need of anything, say, tutorial wise, I can put something together. I would donate if I could, but I think this is the best compensation I can come up with. PM me or just reply if you (whoever still develops this) are interested. :p
  27. Offline


    I have a feeling this may have been talked about somewhere but is there any way to have more than one person be served by an NPC at a time? Also is it possible to sell more than one item at a time so as to sell a whole stack?
  28. Offline


    I tried that with clean plugin folder and it still gives me this error :(
  29. Offline


    /trader sell <what>:<quantity> <cost>
  30. Offline


    @SilverMage - you need to update your craftbukkit.
    @morizuki citizens.use.trader
    @JokeTrue @Yougoslave - you both have errors with your permission plugins, not Citizens.
    @Dimochka - that looks like a compile error of some sort - perhaps copied over before the JAR file was fully created?
  31. Offline


    I use the citizens.use.trader but they said they don't have permissions :(

Share This Page