[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline


    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
  2. Offline

    Marco Moreira

    Would be cool if you could give your NPC's nicknames which show up instead of the name set to create it (skin) if you get what i mean :) Thanks for the updated info aPunch :D
  3. Offline


    I imagine you mean an npc. You just do /npc create name

    Which of course there is a nice list of commands on their wiki (link is on the top of the page) of where to go from there. Like toggling whether they are a trader,healer, or even giving them an item to hold.
  4. Offline


    /npc create <Name>
  5. Offline


    Why my NPC says only last text I add by "/npc add <text>"? I want it says ALL texts, I add, not only last! :(
  6. Offline


    Version 1.0.8g

    -added mana for wizards, maximum mana and mana-regen-rate ticks are configurable in citizens.yml
    -added 3 new modes for wizards: spawn mobs, change time, toggle storm (change mode with /wizard mode [mode] command...valid mode names are "spawn", "teleport", "time", and "weather") .... read more about these new modes and how everything works on the wiki
    -many bugfixes, big and small, including major trader bugs and some saving issues
    -other stuff that I have forgotten
    mbsuperstar1, Dope and Simzy like this.
  7. Offline


    2011-06-09 04:04:32 [SEVERECould not load 'plugins\Citizens.jar' in folder 'plugins':
    java.io.FileNotFoundExceptionJar does not contain plugin.yml
        at org
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:194)
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:117)
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:109)
    at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:232)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:219)
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:146)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    On Start ^
    It appears sir you are missing your plugin.yml from the build <> better rebuild it eh.

    CB 839

    All Prev versions working other then the save issue that I was hoping to test now :(
  8. Offline


  9. Offline


    traders fixed in 1.0.8g, or is that still a 1.0.9 target?
  10. Offline


    Server log:
    Could not load 'plugins/Citizens.jar' in folder 'plugins':
    java.io.FileNotFoundException: Jar does not contain plugin.yml

    I confirmed this by extracting your citizens.jar file and there is no plugin.yml. There also seems to be a significant number of files and folders missing from with the jar file.
  11. Offline


    @telmo Many trader bugs were fixed in 1.0.8g. Please report any bugs still there.

    Also, those of you who downloaded right as it was released please redownload. I forgot to add the plugin.yml, but that is fixed now. :p
  12. Offline


    Thank you!
  13. Offline


    Lol, I read the comments, downloaded it and lol there was the plugin.yml! You are fast :D
  14. Offline


    Wow only update this thing 10 mins ago lol ^

    and its working now.
  15. Offline


    having trouble with /npc add, it doesnt add more text to the npc, it just overwrites and make whatever i put the only one available. any help would be greatly appreciated. Thank you.
  16. Offline


    Trader is still not functioning. Will not sell or buy to players on G.

    Since these traders were made on version d. Do I need to redo the original traders or blow them out and restart.

    In the meantime, I will dig deeper and provide you with any details.
  17. Offline


    I would like to official announce that I am a COMPLETE IDIOT....Traders are working perfectly. I am too embarrased to say my mistake. Please remove this post and my last one.

  18. Offline


    I'm going to take stab in the dark and suggest you forgot to re add the permissions for trader use ?
  19. Offline


    quick question, it says i havent enabled economy on my server, how do i go about doing that?
  20. Offline


    I may be really dumb right now but i have tryed ever permission for traders and I still can not get it to work for any one that is not a op or has *
  21. Offline


    my face is very red
  22. Offline


    citizens.trader.stock to your groups and/or users in your permissions yml files
  23. Offline


    nope its there
  24. Offline


    NPC names appear to have glitched for me. For NPCs using slashes as spaces only the first word is displayed.

    I'm using Bukkit 818 and Citizens 1.0.8g
  25. Offline


    nope its there
    default: false
    - citizens.trader.stock
    - citizens.use.trader
    - citizens.use.wizard
    - essentials.back.death
    - essentials.chat.shout
    - essentials.depth
    - essentials.home
    - essentials.mail
    - essentials.mail.send
    - essentials.me
    - essentials.msg
    - essentials.protect
    - essentials.sethome
    - essentials.signs.mail.create
    - essentials.signs.mail.use
    - essentials.signs.protection.create
    - essentials.signs.protection.use
    - essentials.tpaccept
    - essentials.tpdeny
    - factions.participate
    - icoland.basic.info
    - icoland.basic.select
    - icoland.land.buy
    - icoland.land.sell
    - iConomy.access
    - iConomy.list
    - iConomy.payment
    - iConomyChestShop.shop.buy
    - iConomyChestShop.shop.sell
    - iConomyChestShop.shop.use
    - iConomyDeath.use
    - kit.kit
    - mcmmo.ability.*
    - mcmmo.commands.myspawn
    - mcmmo.commands.party
    - mcmmo.commands.ptp
    - mcmmo.commands.setmyspawn
    - mcmmo.commands.setmyspawnother
    - mcmmo.commands.whois
    - mcmmo.item.chimaerawing
    - mcmmo.regeneration
    - mcmmo.skills.*
    - petition
    - sortal.coords
    - sortal.delwarp
    - sortal.warp
    - towny.publicspawntp
    - towny.spawntp
    - towny.wild.*
    - turnstile.use
    - wolfpound.use
    - guest
  26. Offline


    How do i enable economy?​
  27. Offline


    Okay, I can tell you, Im running permissions 3, cb 818, nc 1.6.6, citizens 1.0.8 g. No problems whats so ever. First time in a few weeks.

    Judging by your format for your yml permissions file above, your not using permissions 3 or essentials group. Seems like a mix of the 2. What are you using?

    Finally, if you are new to traders and you have not set them up with stock, setowner, buy, sell, etc, then it will not work. Go http://citizens.wikia.com/wiki/Traders and watch all the videos. Thats how I figured it out...im just a user of this plugin...but I love it and I know they are getting smashed with support questions.
  28. Offline


    Hello again !

    Well, I'm experiencing similar problems :
    1) NPC names like "King/of/Dwarves" only display "King"

    2) When trying to change a NPC's name, I'll get the message "XXX's name is now YYYY" but, the former name stays put on the head of the Npc. Moreover, I can't select it anymore.

    2-b) Changing a NPC color (wich is just renaming ;) ) get the same conclusion.

    3) When trying to remove a NPC, it seems to remain, but I can no longer interract with it. Deco/reco doesn't change anything, nor Reloading the plugins, nor restarting the whole server. More ! The NPC seems to duplicate, but neither of them is selectable.

    What seems fixed : Basic NPC will say all their texts. Good thing on this point.

    Plugins currently running on the server that might cause incompatibility :
    -> Essentials
    -> Borderguard
    -> Spyer
    -> WorldEdit
    -> Slowhealth
    -> Moblimiter
    -> Dontkickme
    -> DnDCraft
    -> Helios

    I've never seen an incompatibility between these, but, who knows ;)

    I've tried to remove the whole former configuration and get all the new files... Same problem.

    By the way, the "interract item" in citizens.yml is always 340, instead of '340' like I think it should be, so I change it everytime. Until now that didn't cause any crash for the plugin.

    Thanks for reading

    EDIT : Okay, the problem only occurs when a name with special characters is used, like "King/of/Dwarves" or "Ancient_Dwarf". With a standard name, such as Berdin, no problem selecting, renaming, recoloring, changing text...

    Tried with a completely clean install of Citizens 1.0.8g
  29. Offline


    essentials group
    and i have run traders for a long time now
  30. Offline


    How to use questers?

Share This Page