[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline


    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
  2. Offline

    Cydox Master

  3. Offline


    In case it helps I've noticed too things in the config of Citizens:
    1.) IDs are screwed up. This shouldn't matter, unless you generate your NPC list badly (ie, a loop that stops as soon as the next number returns no NPC) since I think some number are unaccounted for. But, since deleting NPCs is possible, this shouldn't be a prob.
    2.) This is the interesting thing: when I look into the files in my "Basic NPCs" folder I noticed something really strange about the difference between working and non-working NPCs. The working NPCs are referred to in the config by there name in one instance, and then by their ID the next time. For an example look at this:
    //These TWO lines exist for the Notch NPC:
    //This ONE line exists for an npc that isn't working:
    //And then there's the list:
    list=0_Hunt800,1_Notch,/*bla bla bla*/,32_Newb
    //This was taken (kinda, the locations are made up) from my Citizens.locations file
  4. Offline


    @Joe Burton

    Not sure whats going on there but I would recommend using the default template for your permissions file, for example.

            default: true
                prefix: '&8Guest'
                suffix: ''
                build: false
                - 'citizens.trader.stock'
    From permissions FAQ

    [Q] Permissions are broken. Why can no one use commands? Why am I not an admin?
    [A] First off, make sure that your formatting is correct. Look at the format that the default config file uses. Yours should look like that. Do NOT use tabs. Use 4 spaces (IE. " " <-- Four of those things.). Also, whichever group you give the permission '*' to, do not have that group inherit permissions from anyone else. That is called overloading and it will break things.

    @Cydox Master

    by default, talkwhenclose is set to false, so you will need to enable this

    ./npc talkwhenclose true

    This can also be changed in the Citizens.settings file, to make it the default setting.

    By default, you have to equip a book to allow right click messages, this can also be changed in citizens.settings. Set items=340 to items=* to allow right click messages with all items.
  5. Offline


    the plug-in is running great and i'm loving the environment it's creating on our server. my question is mostly for other users. when ever we try to use beds it creates hundreds of mobs around all our npcs and just turns into a a mess. is there a way to make the npcs not visible to mobs? or maybe turn them off at a certain time so that we can sleep without having to worry about it. it would simulate "stores" opening and closing anyway. any ideas or plug-ins i'm missing?
  6. Offline


    I don't see any bug. Could you explain what the problem is?

    To everyone:

    1.0.8d should be out within a few days. There are just some bugs that were created with some refactoring that need to be squashed first.
  7. Offline


    Just asking again.
  8. Offline


    Yes I do, I have Permissions to...
  9. Offline


    /toggle aliases are coming in 1.0.8d.

    Essentials is buggy with 1.08c. Wait until 1.0.8d AND make sure you are using Essentials RELEASE VERSION 2.2.17 or above.
    LlmDl likes this.
  10. Offline


    alright Will try! I'm letting you know if it worked.

    EDIT: Tryed updating essentials to 2.2.17 but it din't help... Well i guess i just have to be patient :D
  11. Offline


    Are you taking feature requests? If so, could you see if there's a way to synchronise NPCs (i.e. to have multiple instances of the same NPC ID) ?

    This would allow a trader NPCs with global inventories and currency holdings, etc...
    IIGoldII likes this.
  12. Offline


    sweet updates :D keep up the good work :D
  13. Offline


    Is there any way to sell wool? I can't seem to find ID's for specific colors of wool or dye so I can't offer them at my shops. Thank. Oh, and great plugin. Can't wait until you figure a way to change the names.
  14. Offline


    Hunt, were you using the old version of Citizens formerly? That almost looks like you have config lines from the old and new format mixed in the same file. I would imagine you can (and maybe should) remove all of the ones starting with names (backup first :). I think I had a similar problem at first. At which point...

    My migration to the new format of config files a few weeks ago was not smooth at all. It seemed the new version didn't import the thirty (*cough*) old NPCs we made, and I had to hack my config files up manually to get them back. I hope if that was everyone's experience (losing your work) that future upgrades are more friendly :)

    Finally, on the lag. I'm only using basic NPC's as well. This is on a gaming PC (SATA HD's) with nothing else major running in the background. The lag only appears when I enable this mod. Someone mentioned profiling or something. Maybe that can be done if we're all still at a loss as to exact cause since it sounds like it's affecting more than a few people (with all different hardware setups) and causes such unpleasantness.

    Thanks for all your hard work, devs :)
  15. Offline


    I read through a few pages and didn't catch if this problem has been spoken about but I'll ask anyway (sorry if it has been answered several times already :x )

    I will create an npc, them every time I reload the server the npc don't reappear again. I have tried deleting everything then trying to no avail D: I'm using the latest everything.
  16. Offline


    hello, im using #766 and i got this error,
    Could not load 'plugins/Citizens.jar' in folder 'plugins':
    java.lang.UnsupportedClassVersionError: Bad version number in .class file
    any ideas how to fix it?
  17. Offline


    Update to Java v1.6.
  18. Offline


    im using mac os x and they told me to go to the software update but theres no java update there..
  19. Offline


    Love the plugin. Got one issue though. When setting up a trader, I went to give it money by the /trader balance grant command, it says im not using ''iConomy'' when I am. Strange
  20. Offline



    Is it possible to have trader npc's trade items for items? I checked the wiki for trader commands and didn't see the option for item to item.
  21. Offline


    Make sure use-econplugin=true in your Citizens.economy file.
  22. Offline


    I tried the command /trader balance give (amount) and then it said this server is not using iConomy!?!??!
    i have the latest iConomy on my plugins folder. and i can't seem to find any errors from my server.log after using this command. actually i can't find even the command i used:eek:
  23. Offline


    The solution to your problem was literally one post above yours.

  24. Offline


    You can use items as currency to trade, but it isn't possible to trade an item besides the currency. And since fullwall is no longer working on Citizens, I don't plan on adding any features to traders anytime soon. Traders were fullwall's project.
  25. Offline

    Psycho Robot

    What is the format for inputting multiple phrases of text when doing /npc create, set, or add? Do you separate each phrase with a semicolon? Do they have to have quote marks around them?
  26. http://www.youtube.com/watch?v=2e0VbrtFeAM
  27. Offline

    Psycho Robot

  28. yes
  29. Offline


    Just would like to re-mention that you can't have traders buy/sell items with metadata.
  30. Offline


    Why? We are well aware of this and you mentioning it is just cluttering up a thread that is for support. No wonder fullwall quit.....
  31. Offline


    When I right click a trader it lets me see the inventory window but also tells me "you don't have permissions" when I have citizens.trader.stock permission. When I add citizens.* the problem goes away. From what I understand the citizens.trader.stock permission is the only one necessary to allow player to buy/sell to vendors. Why am I getting this "you don't have permissions"?
    onumchuxo likes this.

Share This Page