Inactive [FUN] BoatMod v12 - Make large groups of blocks move! [1.4.5-R0.2]

Discussion in 'Inactive/Unsupported Plugins' started by jackpot51, May 29, 2011.

  1. Offline


    BoatMod - Add large moving objects
    Version: v12

    This plugin adds the ability to make large structures like boats, submarines, and blimps move, along with the players aboard them. It currently allows the usage of the blocks listed below in boats and allows one boat per person on the server. Configuration can be done by editing the default.cfg file or creating a new .cfg file.

    In order to use this mod, you must first captain a boat by left clicking on a block in the boat while holding a boat item. You should click the block that you want the boat to rotate around while facing the front of the boat. You can rotate by facing the way you want the boat to rotate and left clicking while holding a map. You can then move by right clicking in the direction you want to move while holding a map. You can hold down right click to continuously move. You may change your speed (blocks/click) by using the /boatspeed command with a number argument (for example /boatspeed 1 would move the boat one block per right click). If you run into any other blocks, the boat will not move. If the boat is damaged, the blocks will remain damaged.

    • Lets players create large moveable structures like boats.
    • Moves and rotates these structures.
    • Moves any entities that are standing on the structures.
    • Checks for collisions and damage.
    Permissions Support (open)
    In order to implement permissions, look at the default.cfg in the plugins/BoatMod directory. Next to each value in the [CONFIG] section, you can add the permissions node that you want to use followed by a colon. The default permissions nodes are boatmod.admin and none (which is used by non-permissions players). For example, you could make the MaxSize for default players 0, which would make them unable to make boats. You could also add a node (perhaps boatmod.player for a player that can use boatmod) and then set the maximum values for that node. These permissions may also be applied to each script with the syntax node:name of script.
    Boatable Blocks (open)
    Boatable Blocks:
    These blocks may be changed by adding or removing materials to a config file beneath a [MATERIAL] tag, materials are defined in

    Scripting (open)
    The script engine exposes the boat that was setup with the script as an object named boat. Several public functions may be accessed that allow the control of this boat. A demo script named autoship moves a ship in a straight direction whenever the sun rises or sets.
    • getCaptain() returns the Player object that created the boat.
    • Message(String message) sends the captain a message.
    • setSpeed(int movespeed) sets the speed of movement in blocks per move.
    • Move(Vector direction) moves the boat in the direction specified by the vector. It returns true if there was not a collision.
    Screenshots (open)
    Setting up a boat:
    Hitting the block limit:
    Changing speed (Had to upload as a jpg because of size restrictions):
    The large boat I built to test size restrictions (jpg's again):
    The small boat I used for initial testing:
    Daisy helping with entity movement testing:
    Tutorials (open)
    Tutorial, Courtesy of InfctedMushr00m:
    Tutorial, Courtesy of lifesadream52:
    Tutorial, Courtesy of Goldkoron:

    Download BoatMod: Here
    Source: Here

    • jackpot51
    • BurnedKirby
    • Lacaranian
    • GoldKoron
    • superdupernova
    • Dr_fantasmo
    • Saberar
    • Sayerer27276
    • Parker237

    Next Version:
    • Checking some item dupes (beds, pistons)
    Some Future Version:
    • Multiple crafts per person
    • Detachable crafts (life boats, torpedoes, etc)

    Version 12:
    • Update to newest Bukkit
    • Update to use SuperPerms
    Version 11:
    • Bugfixes with powered crafts and block handling
    • Signs and doors should be fixed in many circumstances, let me know specifics about when they fail if they do.
    • Beds also drop dupes, I blame bukkit
    Version 10:
    • Added fuel capabilities
    • Fix for boats breaking block limits no matter what the limits are
    • Fix for boatinfo only being runnable from the server console
    Version 9:
    • Naming of vehicles in the boatmod messages
    • Vertical toggle
    • Additional ticks parameter to automatic boat movement
    • User level permissions
    • Recursion no longer used for block searching
    Version 8:
    • Added note when author logs in to boatmod server
    • Fixed login, logout events
    • Added a boatinfo command that gives information about boatmod
    • Added support for new blocks (brewing stands, jukeboxes, redstone circuits)
    • Added boatauto command for autopilot
    Version 7:
    • Added support for the number of a material to be placed in the material configuration
    • Fixed doors and beds
    • Fixed limit on change speed command
    • Updated to work with newest bukkit
    Version 6:
    • Added rotation using left click with map!
    • Fixed levers and torches
    • Moved change speed to command /boatspeed [speed]
    • Removed support for multi-block items(beds, doors, open pistons) as they were broken from a bukkit update. Will re-add once issues fixed.
    Version 5:
    • Added lava support
    • Damage now does not stop the boat from moving-it simply notifies the player once that the boat's blocks have changed
    • Furnaces can now move while they are burning
    • Redstone, dispensers, and noteblocks can move while keeping state
    • Added script permissions
    Version 4:
    • Added permissions support
    Version 3:
    • Fixed up scripting support
    • Added example script
    Version 2:
    • Added config file support
    • Fixed signs, furnaces
    • Started on scripting support
    Version 1:
    • Released BoatMod
    Pavlov, DoomLord, GrimblyGorn and 7 others like this.
  2. Offline


    Left click with the boat like it says... or am I just being a retard that can't read...
  3. Offline


    And what type of blocks are you trying to turn into a boat?
  4. Offline


    This will be great for me and my friends as we like to move location of house and we can now bring our house
  5. Offline


    if ur interested, i could make a tutorial vid, works fine for me awesome pluginnn, if only it could rotate structures...
  6. Offline


    Sure thing. There will be rotation...eventually
    freeplayo7 likes this.
  7. Offline


    First. sorry for it being long. could not get this to save as attachment.

    hi I'm getting an "2011-06-15 01:15:55 [SEVERE] Could not pass event PLAYER_INTERACT to BoatMod
    java.lang.NoClassDefFoundError: com/nijiko/permissions/PermissionHandler. I tried to change the permission folder in boatmod to groups Admins. which is my default for me and my friend that are the only ones playing on the server. we use essentials and permissions. I haven't made any other adjustments. here is attachment for full permissions and server log.

    2011-06-15 01:30:10 [SEVERE] Could not pass event PLAYER_INTERACT to BoatMod
    java.lang.NoClassDefFoundError: com/nijiko/permissions/PermissionHandler
    at me.Jackpot.BoatMod.BoatMod.GetConfig(
    at me.Jackpot.BoatMod.BoatMod.MaxBoatSize(
    at me.Jackpot.BoatMod.Boat.<init>(
    at me.Jackpot.BoatMod.BoatMod.AddBoat(
    at me.Jackpot.BoatMod.BoatModPlayerListener.onPlayerInteract(
    at org.bukkit.plugin.RegisteredListener.callEvent(
    at org.bukkit.plugin.SimplePluginManager.callEvent(
    at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(
    at net.minecraft.server.ItemInWorldManager.dig(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.Packet14BlockDig.a(SourceFile:42)
    at net.minecraft.server.NetworkManager.b(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    at net.minecraft.server.MinecraftServer.h(
    Caused by: java.lang.ClassNotFoundException: com.nijiko.permissions.PermissionHandler
    at$ Source)
    at Method)
    at Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    ... 18 more


    group: Admins
    group: Admins

    default: false
    prefix: ''
    suffix: ''
    build: false
    - '*'
    - 'essentials.motd'
    - ''
    - '-essentials.give'
    - '-essentials.item'
    - '-essentials.unlimited'
    - '-essentials.signs.mail.create'
    - 'essentials.mail.use'
    - ''
    - ''
    - ''
    - ''
    - ''
    - '-essentials.signs.disposal.create'
    - '-essentials.signs.disposal.use'
    - '-essentials.signs.heal.create'
    - '-essentials.signs.warp.create'
    - ''
    - ''
    - '-essentials.signs.sell.create'
    - '-essentials.signs.balance.create'
    - '-essentials.compass'
    - ''
    - '-essentials.jump'
    - '-essentials.back'
    - ''
    - '-essentials.teleport.cooldown.bypass'
    - '-essentials.teleport.timer.bypass'
    - '-essentials.tptoggle'
    - '-essnetials.tpa'
    - '-essentials.tpaccept'
    - '-essentials.tpdeny'
    - ''
    - '-essentials.tpo'
    - '-essentials.tpahere'
    - '-essentials.tphere'
    - '-essentials.tpohere'
    - '-essentials.tppos'
    - '-essentials.home.others'
    - '-essentials.sethome'
    - '-essentials.home'
    - '-essentials.warp'
    - '-essentials.warp.list'
    - '-essentials.warp.[warpname]'
    - '-essentials.warp.otherplayers'
    - '-essentials.setwarp'
    - '-essentials.delwarp'
    - ''
    - '-essentials.worth'
    - '-essentials.setworth'
    - '-essentials.sell'
    - '-essentials.balance'
    - '-essentials.balance.others'
    - ''
    - '-essentials.helpop.recieve'
    - '-essentials.reloadall'
    - '-essentials.gc'
    - '-essentials.plugin'
    - '-essentials.spawnmob'
    - '-essentials.clearinventory'
    - '-essentials.clearinventory.others'
    - '-essentials.broadcast'
    - '-essentials.antioch'
    - '-essentials.burn'
    - '-essentials.ext'
    - '-essentials.kill'
    - '-essentials.backup'
    - '-essentials.nuke'
    - '-essentials.ban'
    - '-essentials.tempban'
    - '-essentials.banip'
    - '-essentials.mute'
    - '-essentials.kick'
    - '-essentials.kickall'
    - '-essentials.unban'
    - '-essentials.unbanip'
    - '-essentials.toggljail'
    - '-essentials.jail.exempt'
    - '-essentials.setjail'
    - '-essentials.deljail'
    - '-essentials.invsee'
    - '-essentials.kit'
    - '-essentials.kit.<kitname>'
    - '-essentials.kit.*'
    - '-essentials.time'
    - '-essentials.tree'
    - '-essentials.bigtree'
    - '-essentials.god'
    - '-essentials.heal'
    - '-essentials.suicide'
    - '-essentials.powertool'
    - ''
    - '-essentials.thunder'
    - '-essentials.lightning'
    - '-essentials.protect'
    - '-essentials.setspawn'
    - ''
    - ''
    - '-essentials.geoip.hide'
    - ''
    - '-bb.admin.rollback'
    - ''
    - '-bb.admin.cleanse'
    default: true
    prefix: ''
    suffix: ''
    build: true
    - Default
    default: false
    prefix: ''
    suffix: ''
    build: true
    - '*'
    - '-essentials.give'
    - '-essentials.item'
    - '-essentials.unlimited'
    - ''
    - ''
    - ''
    - '-essentials.time'
    - '-essentials.god'
    - '-essentials.heal'
    - '-essentials.suicide'
    - '-essentials.powertool'
    - ''
    - '-essentials.setspawn'
    - ''
    - ''
    - '-bb.admin.rollback'
    - ''
    - '-bb.admin.cleanse'
    default: false
    prefix: ''
    suffix: ''
    build: true
    - '*'
  8. Offline


    You have an older version of Permissions. You need to get Permissions 3, which can be found here
  9. Offline


    I downloaded the new permissions. replaced my old permissions files, rewrote my permissions and I'm still getting the same error. I'm sorry. I'm noob when it comes to this stuff. this is my first foray into running a server. anyone willing to help write my permissions files? the only thing I really need is for the admins to have all the powers. and the admins are only 2
  10. Offline


    So can Permissions load? Does it give any console output?
  11. Offline


    everything works but the boatmod. my essentials is working fine and my help works. under the console it states that permissions (yeti) disabled successfully. 2011-06-15 12:06:47 [INFO] [Permissions] (Yeti) was initialized. 2011-06-15 12:06:47 [INFO] [BoatMod] Script: autoship @ plugins\BoatMod\autoship.js
    2011-06-15 12:06:47 [INFO] [BoatMod] Data file: plugins\BoatMod\default.cfg
    2011-06-15 12:06:47 [INFO] [BoatMod] Version 4 has been enabled.
    2011-06-15 12:06:48 [INFO] [Permissions] (Yeti) disabled successfully.
    2011-06-15 12:06:48 [INFO] [Permissions] SQL Interface enabled!
    2011-06-15 12:06:48 [INFO] [Permissions] (Yeti) disabled successfully.
    2011-06-15 12:06:48 [INFO] Done (0.478s)! For help, type "help" or "?"

    sorry Iwas wrong. I get this
    2011-06-15 12:06:47 [SEVERE] [Permissions] Unable to load permission data.
    2011-06-15 12:06:47 [SEVERE] [Permissions] Shutting down Permissions due to error(s).

    nm found it. I fixed the problem. thank you for helping guide me into where the problem was. under my users I had entered my friend under permissions. it ended up causing it to fail. but it's working and I got control of my ship. wewt! awesome plug-in!

    ok so got it to work with small ship. was making a bigger ship ran into the problem with not enough stack. so I was going to add the -oss4m and -ss4m. unable to locate a craftbukkit.jar. I have a RUN.jar with java script. and I have a craftbukkit-0.0.1-SNAPSHOT. but can't find the java script in it. not sure where to add the scripting. again noob :(

    when I attempted to add the scripting to RUN.jar and started the server It got really laggy then I got disconnected and was unable to Stop the server. had to hard shut it down

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  12. Offline


    What do you use to start craft bukkit? There should be some file or shortcut or something somewhere that starts craftbukkit with the command java -jar [name of craftbukkit jar]
    You need to add the -oss4M and -ss4M to that command so that it is java -oss4M -ss4M -jar [name of craftbukkit jar]
  13. Offline


    working 100% sorry for spamming the forum. thanks for your help
  14. Offline


    Hi i am having problems with with the boatmod. I am running on 860 bukkit with permssion 3.
    Whenever I type in the command /boatmod autoship it says that I dont have access to the boatmod command.

    I have tried adding permission node ''boatmod.script" and "boatmod.admin" and still seem to cant get it working.. could u me help me?
  15. Offline


    Making video.
    jackpot51 likes this.
  16. Offline


    Awesome work.
    It's look like Movecraft, but it's easier to understand.
    Don't stop working.
    We are all waiting for a new update.
  17. Offline


    I'll try to get the next one out but I am really busy with other stuff-next release may be late next week

    You need to be an op on the server to run the boatmod command.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  18. Offline


    Video uploaded!
  19. Offline


    k thanks that fixed the problem. :) now time for boat riding~
  20. Offline


    Lava is working now.
  21. Offline


    Meanwhile my plugin season is working with snow regen but not ice right now
  22. Offline


    Hey, i've built an airship with your awesome mod. However, despite having a clear lane of exit, it says it's going to collide, and does not move. Any idea why?

    Attached Files:

  23. Offline


    Check that no blocks are close to the ship when you make it. It is possible that those torches on the left are getting added.
  24. Offline


    Will you have my babies? I'm going to test this now, and if it works... wow.

    EDIT: Not sure if this is mentioned, but redstone is bugged, iron doors, levers, beds duplicate, torches change walls and it's incompatible with pistons (orientation changes when you move).

    Still good though... just bugged.
  25. Offline


    The changes in 1.7 have killed several things in boatmod (redstone, beds, pistons). I have not gotten a chance to fix these things but I assure you that I will make boatmod compatible with 1.7. For now, redstone and beds only work properly in 1.6.6.
  26. Offline


    I'm on 1.6.6...
  27. Offline


    If you are on 1.6.6 and are using craftbukkit then there is no way that pistons will work as the extra information contained for pistons is inaccessible through the 1.6.6 bukkit api. The bed duplication is something I have never seen and would not expect - can you get a screenshot of this? Iron doors and levers both require a block to be present when they are moved-and are probably not handled like the other blocks that need this yet (torches, wooden doors, pressure plates, ladders, etc.). This should be easy to fix. Can you explain the redstone behavior?
  28. Offline


    Hey, I am french, I apologize for my English and your plugin is really good, very good job, functional, easy to use, but unfortunately impossible to make a rotation, it is the black spot of your plugin with this function, your plugin would be perfect !
    In short good luck and if you can add the posibility to do a rotation of the boat. ;)
    It's just my opinion. :p
  29. Offline


    Rotation is coming in the next big release (version 6 or 7). Lots of blocks require special handling which will take the most time to implement.
  30. Offline


    Okay, thank you for your answer, all the better because I think plugin is well worth this feature, anyway good luck with version 6.
  31. Offline


    I'm using a piston mod- the one that replaces iron blocks. Beds items just pop up all over the place, like with levers and iron doors, and the odd redstone block will break every time I move the ship.

Share This Page