Discussion in 'Bukkit Help' started by Tormidal, Jun 13, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    [INFO] Starting minecraft server version Beta 1.6.6
    [INFO] Loading properties
    [INFO] Starting Minecraft server on
    [WARNING] The exception was: Cannot assign requested address: JVM_Bind
    [WARNING] Perhaps a server is already running on that port?

    getting this in the bukkit prompt when I start it up. Only when I have my ip in the server properties file.
  2. Offline


    well you should never really have your Ip in the server properties file, if its not there, that means it will always look for the ip. If it is, it stays bound to that IP and sometimes will screw up a little. Take it out, see what happens. Alternatively, a failure to bind to ip means you have something else running on that port. Try reinstalling the bukkit server. That could fix it. but you can try and post some more information, like your server properties file and anything else you think might be viable.
  3. Offline


    #Minecraft server properties
    #Mon Jun 13 18:51:37 CST 2011

    Heres the properties without the ip. >.>
  4. Offline


    are you playing this with a cracked client or with a full version with a premium account? Were you able to connect when you took the Server-ip out?
  5. Offline


    I have the full version with a premium account. I took out ther server-ip and typed localhost(in the Minecraft client), and was able to connect.
  6. Offline


    the other time this error will come up is if the server is already running. Open task manager and look for java if its open close it then try opening the server again.
    Edit: well if you were able to connect with local host it means that the server is running.
  7. Offline


    Java isn't running at all, I already tried that. And even if I start it up, it still gives me that error, unless I take my ip out of the server properties and run it. Then I dont get the error. And I can type Localhost etc. etc.
  8. Offline


    go to start, run (window 7 and vista its just the search bar right there at the bottom)type in cmd press enter, type in ipconfig, press enter. Your looking for the ipv4 address. This is your local IP address. your going to need this to connect locally on a different machine. leave your server config alone, without an IP address typed in. Start the server. on another computer type in the servers local IP address, without the port at the end. so it would be something like: "" See if your client can connect to the server.
  9. Offline


    I dont have another computer I can use......

    Ive never had this problem before, but ill see if I can find a computer to try it on.
  10. Offline


    so are you trying to get other people to join your server then?
  11. Offline



    It was a server so me and a friend could play with each other on, and other friends if they wanted to play, and I had a Bukkit server set up perfectly like this, ip on the properties and all. And I didnt get around to updating it for a while and so I finally got the newest software for Minecraft Server/Bukkit, and now it just wont run and its giving me that bind error.

    Tomorrow, I might be able to use my brother's computer, or I can convince my friend to bring his laptop over.
  12. Offline


    well one thing you might wanna try is updating your client to the newest version, server and client have to be the same version in order to connect. If you just updated your server, then your going to need to update your client too. But your failure to bind to port is probably because of the update. Your old bukkit installation is still bound to that port, when closing your bukkit server, just don't click the x. type in stop, wait for the server to stop itself and then close it out. That honestly where my knowledge of bukkit is really going to stop.
  13. Offline


    Their both at the latest version. >.>
    C'mon, don't you think I would've thought of that?
    I can connect just fine, but the server cant bind to the port. And I always use the stop command.

    Im not that idiotic. So, how do I unbind the old installation?

    Heres some extra info.

    Im running Windows XP SP3, (32x i think)
    Im running java 1.6.0_24
    I am running no wrappers, and I am using bukkit version 860 I believe.

    My plugins are CommandBook, SupplySign, and Permissions.

    Heres the error server log, after running from the vanilla minecraft server.
    Same result if running from the bukkit server.

    2011-06-14 14:26:53 [INFO] Starting minecraft server version Beta 1.6.6
    2011-06-14 14:26:53 [INFO] Loading properties
    2011-06-14 14:26:53 [INFO] Starting Minecraft server on
    2011-06-14 14:26:53 [WARNING] **** FAILED TO BIND TO PORT!
    2011-06-14 14:26:53 [WARNING] The exception was: Cannot assign requested address: JVM_Bind
    2011-06-14 14:26:53 [WARNING] Perhaps a server is already running on that port?
    2011-06-14 14:26:58 [SEVERE] Unexpected exception
    at ly.a(SourceFile:275)
    at ly.a(SourceFile:35)
    at net.minecraft.server.MinecraftServer.b(SourceFile:401)
    2011-06-14 14:26:59 [INFO] Stopping server

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  14. Offline


    Go to the task manager,go to the processes tab, find a process that is called java.exe or javaw.exe and end all instances of it. then restart your server. Let me know if this fixes your problem...
  15. Offline


    Ive tried that. It didn't help.(Because its never there) The problem is that the old installation is still bound to the port. >.>
  16. Offline


    "getting this in the bukkit prompt when I start it up. Only when I have my ip in the server properties file."

    You knew the solution before you made the topic... I don't see what the problem is here.
  17. Offline


    u using hamachi?
  18. Offline


    Of course I knew that, you are not understanding the point here. I am trying to make a PUBLIC server, so someone NOT ON my LAN can access it, therefor my IP HAS to be in the config.

    If your not going to be useful, dont post.

    Im going to wind up using Hamachi if I cant figure this out.
    But right now, no, im not using hamachi, however, it is running(so its the network connection is uses) and I have tried disabling it, but it didn't help. However, I had it running when I used my last server.
  19. Offline


    Put in your LAN IP, all in-coming connections from uses who are outside your LAN will connect through your IP. Your LAN IP is in someways connected towards your IP.
  20. Offline


    So, put my LAN IP into the config, and then give people my external IP and they should still be able to connect?
  21. Offline


    Yes. If it doesn't work, just leave it blank and give users the external IP.
  22. Offline


    Okay, so I tried it out(Turns out the port was forwarded to my old IP anyways, dunno if that would affect it at all)

    Put my local IP into the config,( Sent my friend my external IP, and he could login. I didn't leave it blank though.

    However, when I tried to login, I had to type in my local ip, instead of being able to do localhost.

    But, Thanks for the help guys! :D
  23. Offline


    uhm i have the same problem but i still cant connect and also my friends cant, ive port forwarded. so anyone have a idea what to do now?:(
  24. Offline


    1. Portforward your Router.
    2. Give them your external IP.
    3. Log in with your internal (192.168.x.x) which ever.
  25. Offline


    i have portforwarded:
    here is my router
    virtual server:
    and port trigger:

    i dont know what im doing wrong now... :/
    ow yea and my computer firewall is off
  26. Offline


    It should work fine. Just make sure they have the right external IP, and they should be able to join if your server is running.

    Are you getting an error at all?
  27. Offline


    I'll give you my story... maybe it will help a few out there.

    When I first started my bukkit server I used my IPv4 for the file. (which was
    At that time, I gave anyone who wanted to join my server (mostly people I knew) My "Real IP address" (I also used this to log in to my server)

    Why did i do this?
    Because it worked.

    The problem began when I checked my IPv4 again, and it had changed from to So when I tried to start the server it would have the error message most all speak of here.

    So how did I fix this?
    Well lets state "my" problems first
    1. There are no processes running for java in the WTM (windows task manager)
    2. When I started the server it said "[WARNING] Perhaps a server is already running on that port?"
    3. When I started up minecraft, and clicked on multiplayer it said "Can't reach server".

    1. I went to the file again and since it said "[WARNING] Perhaps a server is already running on that port?" I decided to get rid of the IP under the appropriate field. I'll show an example.

    #Minecraft server properties
    #Thu Oct 20 09:22:19 MDT 2011
    server-ip= (I GOT RID OF THE IP)
    motd=A Minecraft Server

    I started up the "CraftBukkit Starter.bat" file
    There was no error message this time. I thought sweet it worked. I started up minecraft, and went to multiplayer.
    It still said "Can't reach server".

    2. I made a new multiplayer server and decided to place my new IPv4 address. that would be the I told you about earlier.

    Then the server showed it was ready to go. I logged in and enjoyed mine-craft with all my friends.

    Clerifications needed?
    1. I gave everyone else I wanted to join my server the IP which was currently my IPv4.
    2. I didn't have to place an IP into the file.
    3. If you don't know what an IPv4 is...(look it up) or what your IPv4 is, go to your cmd (Command Prompt), and type in "ipconfig/all" without the quotations.
    4. I did have minecraft port forwarded, so ruled out that it was an issue.

    What I don't understand.
    1. Why the file no longer needs an IP address at all
    2. Why I don't have to add the :25565 at the end of my IP address in Minecraft anymore. I simply use

    But really I don't care unless I can't start Minecraft up again. If you know the answer to those two questions feel free to let me know. Also I hate myself for re-posting some information that you could have read earlier in this thread.... Read the whole thread before you rage at people... I didn't have to try and help.
  28. Offline


    The server-ip property is mainly for hosting companies which use the same box to host multiple servers - therefore the same box has multiple IP addresses, so the minecraft server needs to know which IP to bind itself to. You need to leave it blank and Java will automatically try and sort this out for you.
    You don't need to add 25565 to the end as the client automatically puts it on in the background. It's only if you are running the server on a port other than the default one, then you have to put :pORT.

    This is why you've got a problem:
    You need to leave the server-ip= blank. At all times, Java will automatically configure that for you, it's only in special cases like explained above where you need to use that.
    Your ip is dynamic, which means it's gonna change every 4 hours or so... this means that the IP you gave your friends will be outdated and they will not be able to connect to your server - as they need you to give them your new ip.
    When were trying to start another server, you still had the old one running. This is why the server could not bind itself to the port. The easiest thing to do when this happens, is just restart your computer.

    Now, since you've got a Dynamic IP - I suggest you go to - You can then give your friends a domain that will always point to your ip - so instead of typing in an ip, they would type in "blabla"

    If you need anymore help, just ask :)
  29. Offline


    i have been trying to do this for about a week now and evry time i go to join it says communication error i need help
  30. Offline


    I updated my server and it still says "failed to bind to port. Maybe it's already running on that port?"

    What should I do???
Thread Status:
Not open for further replies.

Share This Page