Solved Failed to bind to port

Discussion in 'Bukkit Help' started by EpicMinerDude99, Jul 24, 2014.

Thread Status:
Not open for further replies.
  1. Offline


    It helps people who don't want to go through all of that when you can just simply google "PORT CHECKER" and it will tell you if the port is open.

    I don't understand this at all > as root use netstat -a -t --numeric-ports -p to list the ports that are in use by number and process. (On OS/X you need to use lsof)

    but why do I have to if I can just google 2 simple words?
  2. Offline


  3. Offline


    Cancel the java process in the activity monitor (mac) easy way to do it
  4. Offline


    There ain't no java process.
  5. Offline


    This is odd. This could be because of your firewall. I don't use firewalls of any kind (Avast!, Norton, etc) so I wouldn't know what to do when this happens. Hopefully someone else here does.

    EDIT: Even if some other application is using that same port, it would still say "Closed" because that port is occupied not "could not be checked".

    EDIT 2: I did some research for you. I'm not sure if this will work but you can try it.

    1. Press the Windows key on your keyboard, or click the Windows icon to open the Start screen.
    2. Type Control Panel into the Search bar, then press Enter.
    3. Click Windows Firewall.
    4. On the left frame, click Advanced Settings > Select Inbound Rules.
    5. On the right frame, click New Rule...
    6. Select the Port radio button and click Next.
    7. Select the TCP radio button.
    8. In the Specific Local Port field, enter 25565. Click Next.
    9. Select the Allow the connection radio button. Click Next.
    10. Make sure Domain, Public, and Private boxes are all checked. Click Next.
    11. Enter any name for this rule. Click Finish.
    12. Repeat the steps again and this time select UDP.
    Check if the port is open again.
  6. Offline


    I checked on and it says

    Success: I can see your service on on port (25565)
    Your ISP is not blocking port 25565
  7. Offline


    Make sure you are looking at the right place on Task Manager.
    1.) Open Task Manager
    2.) Go to Processes (Not Applications)
    3.) Close java.exe
    If that doesn't work, check on all other computers connected to your LAN to see if they have an application (Minecraft Server) running on port 25565.
  8. Offline



    since port 25565 is so called "taken"

    Try changing the port to another port such as 26656, port forward again, and check if it starts.

    I know, you have to port forward again, but this may be the only way to fix it.
  9. Offline


    I got no java.exe running, no-one else in my family plays Minecraft so I don't know why they'd have a server.

    Done, still says the same thing.

    Trying that now.

    EDIT: That kinda fixed it, server loads up now, gonna test if people can connect. What ip should I use?
  10. Offline


    IIRC you still have server-ip= left blank, so the server will listen on all hostnames. With this proviso your friends should be able to join by using your public IP (look up e.g. at
  11. Offline


    Glad it works!
    You have to use your external ip which can be found here.
    or just perform a simple google search: What's my IP
  12. Offline


    Goddamn it. Now it just says 'Timed out' when I try to join.
  13. Offline


    What IP are you using to connect?

    Remember, if you are hosting on your computer and you are joining, you have to use localhost as the IP to join.
    If you don't understand, when you click on Add Server in the Multiplayer menu, where it asks for "Server Address", you type localhost in the box.

    If someone on your network (same internet connection,, same router), they would have to use your IPv4 address which can be found by using the command prompt and typing in "ipconfig".
    If another player that is not on your network is joining, for example, me. I would have to use your external IP.
  14. Offline


    I'm using localhost. I still cannot connect.
  15. Offline


    I apologize! I forgot to mention, now that you've changed ports, you'll have to add :26656 or whatever port you forwarded to join.
  16. Offline


    Ah! You're a genius! Thank you, and thank you to anyone above that tried to help! :D

    I guess my computer is just blocking 25565 for some weird reason.
  17. Offline


    You're welcome! :)
  18. Offline


    Closed ports in your firewall should not cause this problem.

    When you say there are lots of IP's when you do ipconfig are the all assigned to the one network adapter? If you do have multiple IP address assigned to a single network card, leaving ip-address= blank will not work as the server will not know which IP address to bind to. If this is the case you must set ip-address= to the local IP you used when setting up port forwarding.

    IF this is not the case then do you have a static IP address or are you using DHCP? Servers should always be run on a static IP when possible.
Thread Status:
Not open for further replies.

Share This Page