Failed to bind to port PLEASE HELP!!

Discussion in 'Bukkit Help' started by chasearoo, Sep 8, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Ok. I have tried everything. I am getting really ticked off now. Let me explain the situation. I had a vanilla server for a little while and decided to upgrade to a bukkit server. After watching many youtube videos i finally got it to work. Then one day out of nowhere it says FAILED TO BIND TO PORT MAYBE ANOTHER SERVER IS ALREADY RUNNING ON THIS PORT? To be honest, I am 12 years old. I have read every other thread possible on this and I don't understand any of it. I want a detailed description on how to fix this WITHOUT terms i won't understand. Please help. I have a 32-bit machine. Everything is pulled out as far as plugins go. I deleted all of the old minecraft ports on my router. I tried changing the port. Neither of those things worked. Please help. This problem is the only reason I created a bukkit account.
  2. Offline


    Please post your file (in CODE tags please) and possibly a screenshot of your server when it starts up (or just copy and paste the error from the server.log file).
    chasearoo likes this.
  3. Offline


    #Minecraft server properties
    #Thu Sep 08 16:30:30 EDT 2011


    [INFO] Starting minecraft server version Beta 1.7.3
    2011-09-08 16:32:50 [INFO] Loading properties
    2011-09-08 16:32:50 [INFO] Starting Minecraft server on SECRET
    2011-09-08 16:32:50 [WARNING] **** FAILED TO BIND TO PORT!
    2011-09-08 16:32:50 [WARNING] The exception was: Cannot assign requested address: JVM_Bind
    2011-09-08 16:32:50 [WARNING] Perhaps a server is already running on that port?
  4. Offline


    Remove the "Secret" after server-ip. It should be left blank.
  5. Offline


    I know it is left blank When i remove the ip it works perfectly fine. The server start-up does. I can't get on the server though.
  6. Offline


    Not being able to get onto the server has nothing to do with that field. Just leave the field blank and your server will start up. Not being able to get on it probably means that you port-forwarded incorrectly.
  7. Offline


    So it should still know my ip even though I don't put it in there? Because I know I port forwarded correctly. I'll try it again thanks. I'll tell you if it doesnt work

    It said connection refused: connect

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 19, 2016
  8. Offline


    The serverIP entry is for special situations only (multiple network cards in one machine, where only ONE network card should be used). when blank, minecraft accepts connections on ALL networks.. (THIS IS WHAT YOU WANT).

    as for your connection error:

    if you are running windows 7, do the following:
    Windows 7 Firewall Settings: (req. even if fw is off)
    1. create four rules in your firewall settings
    2. inbound, tcp, 25565, allow, all profiles
    3. inbound, udp, 25565, allow, all profiles
    4. outbound, tcp, 25565, allow, all profiles
    5. outbound, udp, 25565, allow, all profiles
    Even if it worked before on vanilla, you still need to do this.. unless things have changed (i've been off the site for a while), Windows does not allow traffic through to bukkit by default (even though it does w/ vanilla)

    f that doesn't help, we are going to need more info.. follow the instructions in red at the top of this page
  9. Offline


    please make sure you are attempting to connect to the shortest path to your server. "localhost" for same machine
    1. if you play minecraft on the same computer as you run the server, use the local ip address ("ipconfig" at command prompt and try the "IPV4" address line) and not the outside (wan(public internet)) IP of your router (in this example "localhost" should work too.)
    2 if your server is on the same network (same side of the router & not in a DMZ (you would know if you set it up)) use that computers local (LAN) IP address
    3 if you can ping the server. ("ping <IPADDR>" in command prompt should comeback with 0% loss)
    3.1 If you cant: your server is off or you have routing/DMZ problems (with xtremely tiny chance your server/router is filtering ping(icmp))
    3.2 if you can: check firewall rules on router + server ("nmap -p 25565 <IPADDR>" AND use a firewall cheking service like GRC's shields up (Look at both ends. WAN AND LAN))

    EDIT:Changed to better wording for 1
Thread Status:
Not open for further replies.

Share This Page