Question Failed to bind to port! persists even after following the troubleshooting instructions

Discussion in 'Bukkit Help' started by Mantoide, Jun 24, 2016.

Thread Status:
Not open for further replies.
  1. Offline

    Mantoide

    Hey there, I'm running the latest version of CraftBukkit (1.10), having installed several plugins (WorldEdit, Speedcarts...) with an Hamachi IP number, which has worked fine for a couple of weeks. However, I recently updated my OS to Windows 10 from Windows 7, and since then every time I launch the server it displays the 'Failed to bind to port!' message, and then instantly shuts down. I've tried all the troubleshooting instructions I've seen on the Wiki page and other posts on the forum, but none of the solutions seem to fix the problem. I'm aware that this is a common issue which has been tackled in older posts, but since I haven't been able to fix it I would like to know what other things I can do. I've noticed that it also happens when I launch a regular vanilla Minecraft server. Any ideas? :(

    Thanks in advance!
     
  2. Offline

    timtower Moderator Moderator

    @Mantoide Try to find out what is running on the port already and kill it.
     
  3. Offline

    Mantoide

    Thanks for replying. I've already tried that and there appears to be nothing running on port 25565. I've also tried with different ports, but it doesn't seem to solve anything. Any other suggestions?
     
  4. Offline

    MaxFireIce

  5. Offline

    ipodtouch0218

    It could be Windows Firewall changing your Inbound Rules.

    Heck, maybe Hamachi drivers broke while upgrading to Win 10.
     
  6. Offline

    Mantoide

    Thanks for the replies!

    I've found out that reinstalling Hamachi every time the computer is turned on fixes the problem until it's turned off. Once the computer is rebooted, the Hamachi IP address is useless and the server console displays the failed to bind to port message. However, if I reinstall Hamachi, and thus change my Hamachi IP address to a new one, the server runs perfectly (from this new address).

    Since I'm reinstalling Hamachi constantly, this means that my IP address is changing every time I wish to start my server (and not only Bukkit servers).

    As you said, ipodtouch0218, I'm getting the feeling this issue is related to malfunctioning Hamachi drivers.

    Any ideas on what to do to definitely fix this problem?
     
  7. Offline

    Tecno_Wizard

    @Mantoide, if you right click any windows program and open properties, most of them will have a tab labeled "Compatibility". I would try setting the running environment for the program to an older version of windows and see if that fixes it.

    My wording may not be 100% correct. I recently got a mac and don't have to deal with issues like this anymore (although gatekeeper is pretty annoying).
     
  8. Offline

    Unknown025

    It isn't necessarily Hamachi's drivers that are at fault. It could also be that Windows 10 itself could be running something on that port, and when you reinstall Hamachi, it temporarily overrides that port. After a restart, Windows 10 then reclaims control.
    But that's just a theory, it could be Hamachi's drivers after all.
     
Thread Status:
Not open for further replies.

Share This Page