Failed to bind port

Discussion in 'Bukkit Help' started by Jacksontexan, Jan 6, 2014.

Thread Status:
Not open for further replies.
  1. Offline


    I only have one server.command page open but this happens when I start the server
    [19:23:00 INFO]: Starting minecraft server version 1.7.2
    [19:23:00 INFO]: Loading properties
    [19:23:00 INFO]: Default game type: ADVENTURE
    [19:23:00 INFO]: Generating keypair
    [19:23:00 INFO]: Starting Minecraft server on
    [19:23:00 WARN]: **** FAILED TO BIND TO PORT!
    [19:23:00 WARN]: The exception was: Can't assign requested address
    [19:23:00 WARN]: Perhaps a server is already running on that port?
  2. Offline


    Moved to Bukkit Help.
  3. Offline


    Oops! Sorry about putting that in the wrong forum! But do you know whats wrong?
  4. Offline


    I have had this happen to me. I think what happened is you shut down your server wrong or it crashed on you, and now your server is running endlessly on that port. However, I have had this happen to me and fixed it a couple of times. You will have to go and forward another port (25566, or 25564 have worked for me) and then go into your server properties and change the port to your new one. This is how I have fixed it, hope I help!
  5. Offline


    It's still not working!
  6. Offline


    You did what I said and set it to your new port? After that you can switch back. If it still doesnt work I would make a third and connect it to that one too.
  7. Offline


    Make sure you don't have multiple ports running. This happened to me before. Usually a good fix is to just restart your computer. You're not trying to run multiple servers at once right? Sometimes you may forget to do "stop" or you might accidentally click start.command or start.bat (whatever you named your file) twice and then all these terminals or command prompts open. Make sure you save and do /stop and wait for all of it to finish completing.

    It always fixes for me if I just restart my computer. Make sure multiple aren't up. Perhaps the Java needs a start? Stop process? On Mac you would go to Activity Monitor and stop the process from there.
  8. Offline


    I know exactly how to fix this, but I need to know what type of computer you have. Mac, Pc?
  9. Offline


    open task manager, and end all processes that are Java.exe that is your server.
    Then start server back up.
Thread Status:
Not open for further replies.

Share This Page