Faction Permissions HELP!

Discussion in 'Bukkit Help' started by HunterT, Jan 29, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    HunterT

    Okay This was my original permissions:
    groups:
    default:
    default: true
    options:
    rank: '1000'
    permissions:
    - -worldedit.*
    - modifyworld.chat
    - SpawnControl.spawn.use
    - SpawnControl.sethome.basic
    - SpawnControl.home.basic
    - iConomy.holdings
    - iConomy.holdings.others
    - iConomy.help
    - factions.admin
    - factions.autoclaim
    - factions.chat
    - factions.claim
    - factions.join
    - factions.show
    - factions.who
    - factions.create
    - factions.deinvite
    - factions.description
    - factions.disband
    - factions.help
    - factions.home
    - factions.invite
    - factions.kick
    - factions.leave
    - factions.list
    - factions.map
    - factions.mod.any
    - factions.power
    - factions.unclaim
    - factions.unclaimall
    - factions.enemy
    - ChestShop.shop.buy
    - ChestShop.shop.sell

    VIP5:
    prefix: '&f[&25$&f] '
    inheritence: default
    permissions:
    - modifyworld.*
    - weathercontrol.help
    - weathercontrol.status
    - weathercontrol.thunder
    - weathercontrol.clear
    - weathercontrol.status
    - iConomy.payment
    - -worldedit.*
    - modifyworld.chat
    - SpawnControl.spawn.use
    - SpawnControl.sethome.basic
    - SpawnControl.home.basic
    - iConomy.holdings
    - iConomy.holdings.others
    - iConomy.help
    - factions.admin
    - factions.autoclaim
    - factions.chat
    - factions.claim
    - factions.join
    - factions.show
    - factions.who
    - factions.create
    - factions.deinvite
    - factions.description
    - factions.disband
    - factions.help
    - factions.home
    - factions.invite
    - factions.kick
    - factions.leave
    - factions.list
    - factions.map
    - factions.mod.any
    - factions.power
    - factions.unclaim
    - factions.unclaimall
    - factions.enemy
    - ChestShop.shop.buy
    - ChestShop.shop.sell
    options:
    rank: '900'
    VIP10:
    prefix: '&0[10$]&7 '
    permissions:
    - -modifyworld.mobtarget.monster.creeper
    - modifyworld.*
    options:
    rank: '800'
    Moderator:
    prefix: '&f[&3Moderator&f] '
    permissions:
    - -modifyworld.mobtarget.*
    - modifyworld.*
    - modifyworld.chat
    - SpawnControl.spawn.use
    - SpawnControl.sethome.basic
    - SpawnControl.home.basic
    - iConomy.holdings
    - iConomy.holdings.others
    - iConomy.help
    - factions.admin
    - factions.autoclaim
    - factions.chat
    - factions.claim
    - factions.join
    - factions.show
    - factions.who
    - factions.create
    - factions.deinvite
    - factions.description
    - factions.disband
    - factions.help
    - factions.home
    - factions.invite
    - factions.kick
    - factions.leave
    - factions.list
    - factions.map
    - factions.power
    - factions.unclaim
    - factions.unclaimall
    - ChestShop.shop.buy
    - ChestShop.shop.sell
    - ChestShop.shop.create
    - iConomy.payment
    - iConomy.accounts.give
    - iConomy.accounts.take
    - factions.mod

    options:
    rank: '100'
    Admin:
    prefix: '&f[&4Admin&f]&f '
    permissions:
    - -modifyworld.mobtarget.*
    - '*'
    options:
    rank: '2'
    Owner:
    prefix: '&f[&4Owner&f]&f '
    permissions:
    - '*'
    options:
    rank: '1'

    users:
    urmumma23:
    group:
    - Owner
    8ian1:
    group:
    - Admin
    MIDNIGHTXLegend:
    group:
    - Moderator
    Grundel:
    group:
    - Moderator
    I_Assination_Pro:
    group:
    - VIP5


    ----------------
    It worked just fine but users couldn't /f ally /f mod or /f enemy or /f neutral
    so I tried to add - factions.mod
    didn't do anything for me
    so then I tired
    - factions.kit.fullplayer
    Now players couldn't even use /f!!!
    if you would like to try to help over skype or something my id is hunter.shenep
     
  2. Offline

    Zipcord_1

    i want to make a safe zone and war zone you know how
     
  3. You need to do:
    - <plugin>.<cmditem>: true/false
     
  4. Offline

    Jeyge

    1 year ago when this thread was created, he was running PermissionEx which does not use that format. But I'm pretty sure in the year after he posted it, he has probably figured out how to fix it. Nice thread necro though. :)
     
  5. Offline

    HunterT

    Yeah dude, that file is now this
     
Thread Status:
Not open for further replies.

Share This Page