Problem/Bug Ezrankslite problem - owner not helping.

Discussion in 'General Help' started by mattonfire, Jun 6, 2015.

Thread Status:
Not open for further replies.
  1. Offline


    Hi, I run the server on my PC and the plugins run fine but once I upload it to my hosted server and the plugins mess up. I look in the logs and it says that the rank 'B' doesn't exist when obviously it does since it worked before and if I do the command manually it also works...

    Here are the configs.
    Rankup.yml - ""

    Groups.yml - ""

    PS. I am using group manager.
  2. Offline


    Fine-on-mine but not-on-there suggests that either
    1) You haven't got the exact same versions of each plugin/server on the hosted server system as you do on your home test-server (and assuming that on your home test server, it does run the plugin to switch to B is part of your 'runs fine' testing)

    2) You have a perfect copy of all the plugins and server build version, but, the java version on the host is a lower version than your test server, and one of the plugins you have was compiled to run on a higher java version such as what you have on your test server, and not on the host server -- this is manefested as an "unsupported major.minor version #.#" error in your log for a plugin.

    3) Your files may have been saved in an encoding format that once uploaded to the host server, are interpreted as having extra control characters in them , and it is trying to promote to "<invisiblecharacter>B" rank for example.

    Look at your entire logs/latest.log file on your test server for a complete start up, and compare it to the one on your host server - do you see the same things, or do you see blobs of error text and warnings appear on the host that are not on your test server
  3. Offline


    Okay, I found something interesting there is no log except that rank B doesn't exist. I do the same command ingame - done! fine, then I do it in console and it comes up with the same error in what happens with the plugin.

    Conclusion; I can type the command manually in game but not though console or plugin. I have no idea why, also on a different subject when I use Votifier with Ezrankslite Ezranks sidebar stops working (but there is a error message for that).
  4. Offline


    I would like to see what the log says when it says "rank B doesn't exist" - i would like to see what the server is processing when it is in game, and what it is processing when done on the console..

    But if you are trying a "rank ME up to rank B" command via the console, it SHOULD fail - though the error message should be more intuitive rather than failing down a chain later, since there is no way for a console to be given permissions, to switch ranks...
  5. Offline


    I fixed it, I wasn't specifying what world to place their rank into as I have 2 that and the plot world. Although the sidebar still isn't working with votifier for some really odd reason. Tell me if you would like to see that error.
  6. Offline


    open a new question for that problem to get other people to look at it
Thread Status:
Not open for further replies.

Share This Page