Solved Essentials Signs

Discussion in 'Plugin Help/Development/Requests' started by JoshCove12, Jul 8, 2016.

Thread Status:
Not open for further replies.
  1. Offline

    JoshCove12

    I'm having difficultly with adding essential signs, such as buy and sell etc. I've enabled them in the config, added the right permissions, allowed shop in the world-guard region and I just cant seem to get the sign to function.
    I know its working properly because when I enter the sign incorrectly I get notified; however when it's done correctly nothing happens and the sign stays blank.

    Plugins i'm using:
    Announcer, ClearLag. CombatActionBar, Essentials, HideAndCustomPlugins, PEX, ProtocoLIB, PVPmanager, ScoreboardStats, Vault, Worldedit and WorldGuard.

    Thanks for the help.
     
  2. Offline

    OTF Catastrophe

    Mind posting a pastebin of your essentials config file and you permissions.yml file just so I could make sure you have all the right stuff for players to be able to use signs?
     
  3. Offline

    JoshCove12

    Last edited: Jul 10, 2016
  4. Offline

    OTF Catastrophe

    Thats so strange, when I put your essentials config.yml file into a test server the buy and sell signs work perfect. Are you sure you're using the right format for server shops?

    Code:
    [Buy]
    (Amount)
    (Item)
    $(Price)
    
    [Sell]
    (Amount)
    (Item)
    $(Price)
     
  5. Offline

    JoshCove12

    Yeah that's exactly how I do it. Could it be something to do with worldguard?

    @OTF Catastrophe

    And what confuses me the most is that it gives me a error when I do it wrong but when it's correct the sign just stays blank.
     
  6. Offline

    hmmdazpotato

    Would you mind showing us a screenshot of the error. And of what you type in to the sign
     
  7. Offline

    JoshCove12

    @hmmdazpotato Do you want an error of when the sign is incorrect
     
  8. Offline

    hmmdazpotato

    yes and of what you typed in
     
  9. Offline

    JoshCove12

  10. Offline

    OTF Catastrophe

  11. Offline

    hmmdazpotato

    Hmm I don't know why this is happening
     
  12. Offline

    JoshCove12

    @OTF Catastrophe Yes I've tried the way you did it. I have no Knowledge on why this isn't working
     
  13. Offline

    JoshCove12

    @hmmdazpotato @OTF Catastrophe Good news guys... I've updated my Spigot to 1.10 and the signs are now functioning how they should be.
    Thanks for your help!
     
  14. Offline

    OTF Catastrophe

    Ahh gotcha, glad everything works now! If your issue is resolved don't forget to change the thread tag to "Solved"! :D
     
  15. Offline

    Lupus_Z

    @JoshCove12 can you sen me the link where you downloaded your spigot version (or the version name)? I have your same problem (MC 1.10.2) with all the "special" signs like essentials spawnershop etc. So.... can you help me? I'm desperate!
     
Thread Status:
Not open for further replies.

Share This Page