Problem/Bug Essentials Signs HELP PLS

Discussion in 'General Help' started by voltageg2, Jul 5, 2015.

Thread Status:
Not open for further replies.
  1. Offline


    So, earlier yesterday I purchased a Minecraft server through endermite, and the server runs through Multicraft. I have it set to Craftbukkit 1.8 and I wanted to get Essentials plugin. I installed it to the server, and everything works except the signs. I have already removed all of the #s from the beginning of the what-chu-ma-call-its but it still doesnt work. I also have Vault and worldedit installed. Not sure if those affect it. I have included a pastebin of my essentials config, pls help

    essentials config:

    pls help :(

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 12, 2016
  2. Offline


    you need to issue permissons to use the signs with your permission plugin
    You also need to be using the right essentials version for 1.8, which is not gotten from the official Essentials site.

    pastebin your latest.log after restarting (not /reload) can show everything you have.
  3. Offline


    I am using the latest version of the essentials plugin. I got it from here:
    I also downloaded all 9 of the .jar files, do I need all of them? Or are some of them like not compatible with each other? Sorry, this is the first time I have tried hosting a server, so I kinda dont know much about what Im doing. :p

    here is the latest .log after a restart:
    here is the console after a restart just incase that is any kind of help as well:

    Also, about the permissions. Would I still need to issue permissions if I have op'd myself? Cause they still do not work whether I am op'd or not. Thanks for the help :)
  4. Offline


    Make sure that in your the spawn-protection is set to 0, not 16. This is often the fix to Essentials signs problems.

    Also, you probably only need Essentials, Chat, and Spawn.
  5. Offline


    It is already set to 0, but still doesn't work. :( Idk whats wrong.
  6. Offline


    your log shows multiple versions of the same plugins (essentials xmpp and geoip - do you need those plugins at all? Virtuallly no one needs xmpp, geoip is nice if you like errors and server lag but otherwise...) Anytime you see an ambiguous-plugin error, you have two files for the same plugin, and the server is flipping a coin between which version to use, one time an old version, next a newer, each time ripping your configs apart, or choking on an invalid config file ...
    As for the other ess-plugins... essentials chat for chat formatting, if you dont want to use something else; essentials protect is global feature control but worldguard is 99.99% the same; essentials antibuild is good for distinguishing guest/default user ranks from other ranks on the server and not leting anyone build/break until they get a non default rank (most servers do not operate this way, so delete that if you wont).
    Ess spawn lets you make 1/2 spawnpoints (general and noobspawn) for players to respawn at / spawn upon joining first time.

    Nothing else in your startup log shows indication that would fail, so it is possible that it is these crappy/unneeded/broken versions of the ess-files that you have (ambiguous) that are hooking into a sign event and throwing the error back through the essentials class managers.

    Clean out the crap, try again
  7. Offline


    Okay, Ive completely reset all of the server's files. I installed ONLY Essentials and took away the #s in the config for the signs that I want to use, and made the spawn protection 0. Still doesn't work. :(
  8. Offline


    restart, and pastebin the latest.log after that.
    Then, while waiting for a response here, disable all other plugins except essentials, essspawn, esschat, and worldedit. Disable == just rename the plugin jar file to .jam instead, dont delete anything. Try again. Still having issues? Disable everything except for essentials. Still having issues? Try making a sign 500 blocks away. Still having issues?
    Do what you can to narrow down from the small assortment of things you'll have on your server at this current point as to which is calling interference. Does the problem go away when you disable 4 other plugins? Yes? Okay then, try to reenable two of them, restart the server and check now. Problem still gone> Reenable one of the remaining... problem still gone> likely its that last plugin - reenable and confirm. ETC

    Do some detective work to say "its when this plugin is running as well" or "wow, i've ripped off everything except essentials.jar only, and its still not working"

    This also assumes that you've added the right abilities/ess permissions into the essentials to allow sign usage on a server without permissions (you have to configure essentials specially if not using a permissions plugin)... Though as op that _shouldn't_ matter - though it will depend on what op-level your op is set at in the server config
  9. Offline


    I did rip everything off and have ONLY Essentials running. Still does not work. Moved 500+ blocks from spawn, still does not work. I am op'ed on my server, with the op level set at the maximum. So I shouldn't need to do any permissions yet. Still doesn't work.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 12, 2016
  10. Offline


    Lol Mojang has changed the way signs work and for some reason Spigot has not fixed their version of Essentials to apply to it.
  11. Offline


    Completely untrue.. I use Essentials signs on my 1.8 server.
  12. Offline


    If you ripped everything off except essentials, then you will need to find resources on running essentials without permissions in order to figure out how to add the permissions into the essentials configuration - its not something most people do, and familiarity with the process is limited. But that seems to be the issue, despite being opped - cause ops means all permissions IF you are using a permission system, but not using one, it defaults to the internals of how essentials communicates those accessions
Thread Status:
Not open for further replies.

Share This Page