Problem/Bug Essentials not working

Discussion in 'General Help' started by xxxxbulldogxxx, Sep 14, 2015.

Thread Status:
Not open for further replies.
  1. Offline


    hey can someone help me please i cant get
    Essentials working on 1.8.8
    i keep getting an error

    [14:23:05] [Server thread/INFO]: This server is running CraftBukkit version git-Bukkit-53fac9f (MC: 1.8.8) (Implementing API version 1.8.8-R0.1-SNAPSHOT)
    [14:23:05] [Server thread/INFO]: [Essentials] Loading Essentials v2.13.1
    [14:23:05] [Server thread/INFO]: [EssentialsChat] Loading EssentialsChat v2.13.1
    [14:23:05] [Server thread/INFO]: [EssentialsProtect] Loading EssentialsProtect v2.13.1
    [14:23:05] [Server thread/INFO]: [EssentialsSpawn] Loading EssentialsSpawn v2.13.1
    [14:23:05] [Server thread/INFO]: [EssentialsAntiBuild] Loading EssentialsAntiBuild v2.13.1
    [14:23:05] [Server thread/INFO]: Preparing level "world"
    [14:23:05] [Server thread/INFO]: Preparing start region for level 0 (Seed: -3770978577091092124)
    [14:23:06] [Server thread/INFO]: Preparing start region for level 1 (Seed: -3770978577091092124)
    [14:23:06] [Server thread/INFO]: Preparing start region for level 2 (Seed: -3770978577091092124)
    [14:23:06] [Server thread/INFO]: [Essentials] Enabling Essentials v2.13.1
    [14:23:06] [Server thread/INFO]: Bukkit version format changed. Version not checked.
    [14:23:06] [Server thread/INFO]: git-Bukkit-53fac9f (MC: 1.8.8)
    [14:23:06] [Server thread/INFO]: 1.8.8-R0.1-SNAPSHOT
    [14:23:06] [Server thread/INFO]: Creating config from template: /home/tcagame/royalsoldiers/55/plugins/Essentials/config.yml
    [14:23:06] [pool-4-thread-1/INFO]: Creating empty config: /home/tcagame/royalsoldiers/55/plugins/Essentials/upgrades-done.yml
    [14:23:06] [Server thread/ERROR]: java.lang.NoSuchMethodError:;
    [14:23:06] [Server thread/ERROR]: Error occurred while enabling Essentials v2.13.1 (Is it up to date?)
    at com.earth2me.essentials.UserMap.<init>( ~[?:?]
    at com.earth2me.essentials.Essentials.onEnable( ~[?:?]
    at ~[craftbukkit_server.jar:git-Bukkit-53fac9f]
    at [craftbukkit_server.jar:git-Bukkit-53fac9f]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin( [craftbukkit_server.jar:git-Bukkit-53fac9f]
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugin( [craftbukkit_server.jar:git-Bukkit-53fac9f]
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.enablePlugins( [craftbukkit_server.jar:git-Bukkit-53fac9f]
    at net.minecraft.server.v1_8_R3.MinecraftServer.s( [craftbukkit_server.jar:git-Bukkit-53fac9f]
    at net.minecraft.server.v1_8_R3.MinecraftServer.k( [craftbukkit_server.jar:git-Bukkit-53fac9f]
    at net.minecraft.server.v1_8_R3.MinecraftServer.a( [craftbukkit_server.jar:git-Bukkit-53fac9f]
    at net.minecraft.server.v1_8_R3.DedicatedServer.init( [craftbukkit_server.jar:git-Bukkit-53fac9f]
    at [craftbukkit_server.jar:git-Bukkit-53fac9f]
    at [?:1.6.0_35]
    [14:23:06] [Server thread/INFO]: [EssentialsChat] Enabling EssentialsChat v2.13.1
    [14:23:06] [Server thread/INFO]: [EssentialsProtect] Enabling EssentialsProtect v2.13.1
    [14:23:06] [Server thread/ERROR]: Essentials not installed or failed to load. Essenials Protect is in emergency mode now.
    [14:23:06] [Server thread/INFO]: [EssentialsSpawn] Enabling EssentialsSpawn v2.13.1
    [14:23:06] [Server thread/INFO]: [EssentialsAntiBuild] Enabling EssentialsAntiBuild v2.13.1
    [14:23:06] [Server thread/INFO]: Server permissions file permissions.yml is empty, ignoring it
    [14:23:06] [Server thread/INFO]: Done (1.435s)! For help, type "help" or "?"
    [14:23:06] [Server thread/INFO]: Starting GS4 status listener
    its ok now ive fixxed the problem

    EDIT by Timtower: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 14, 2015
  2. Offline


    Your essentials was out of date!

    Remember to mark your thread as Solved
  3. Offline


    Since the Essentials he has is "not out of date", @Binner_Done -- because The Essentials only goes to 2.13 officially -- then it is not out of date. What is the problem is that the 1.8 server versions require a DIFFERENT, non-official "essentials" that builds on Essentials , and you must find the links in a separate, unrelated place, that does not have links to it at all from the official Essentials site.
    Thus "is out of date" is not a solution to mark as 'solved' without actually pointing out where to jump out of the continuous universe of Essentials, traverse through the etherial plane, and land down in a different territory that continues parallel development of that without having a to-be-continued sign to follow at the end of the real road.

    Google spigot 1.8 essentials, the jars are on a jenkins server
  4. Offline


    @Boomer Sorry, he did add at the bottom though "Its ok now ive fixed the problem"
  5. Offline


    Man this site is really messing with me the past 24h.. I've posted comments in empty threads, then 2h later get a notification of new comment that was posted 8h ago and there it is, unseen changes, etc. I'll write it off as demonic posession of the webserver that i didn't see his edit there earlier as well.
    oceantheskatr likes this.
  6. Offline


    I've been getting that too.
Thread Status:
Not open for further replies.

Share This Page