Problem/Bug Essentials kits not properly defined

Discussion in 'General Help' started by megamidge11, Aug 12, 2015.

Thread Status:
Not open for further replies.
  1. Offline


    I had a few misspellings and all items must have a quantity defined, including items that can only stack up to 1. Flame enchantment still needs a value (flame:1)

    i'm having issue's with defining my kits in Essentials config.
    Here's my essentials config:
    And here's the kits section:

    I want some kits to have items which have enchantments.
    Nowhere on the essentials kits page did i see a clear list to say what name to use for the different in-game enchantments.

    Last edited: Aug 12, 2015
  2. Offline


    Line 25: Efficiency is spelt wrong.
    Line 42: Flame needs a value (flame:1)
    Multiple lines have item IDs that don't exist in vanilla Minecraft, so I'm getting FTP, Tekkit, etc. so I won't worry about it.

    Fix those two and see if it works. If not, then Pastebin your full latest.log.
  3. Offline


    One of my kits gives dirt.. wuht.
    It must be to do with non-vanilla id's?
    Latest log:

    Fixed it mostly. On items that only stack up to 1, you still have to specify you only want one of that item.

    EDIT by Timtower: merged posts
    Last edited by a moderator: Aug 12, 2015
  4. Offline


    Correct, Essentials does not parse non-vanilla item ids (from what I can see)

    1. 2015-08-12 12:57:02 [INFO] BlackPegasus issued server command: /kit obsidian
    2. 2015-08-12 12:57:02 [WARNING] [Essentials] Error parsing kit item: 11676
  5. Offline


    Yeah. It seems fine now though, it seems to give the items anyway now :D
  6. @oceantheskatr It's most likely because there is no item with that id :D Essentials still heavily relies on item ids.

    @megamidge11 Please mark this as solved
  7. Offline


    @bwfcwalshy Ahh alright, wasn't sure if Essentials supported non-vanilla item ids :p
Thread Status:
Not open for further replies.

Share This Page