Essentials kit problem

Discussion in 'General Help' started by cawg, Dec 30, 2017.

Thread Status:
Not open for further replies.
  1. Offline


    Hey, I had an issue with my server today when I tried creating a kit for a rank. When I run /kit Pro, nothing happens. I then try again then it says I have to wait 3 days to use the kit



    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 30, 2017
  2. Offline

    timtower Administrator Administrator Moderator

  3. Offline


    @cawg You have multiple issues with your setup here:

    1) Kit names should be lowercase.
    2) 'protection_environmental' should be 'protection'
    3) On items that don't have byte data, don't use byte date. (ie. a diamond helmet can not have byte data, this 310:0 should be this 310)
    4) A pickaxe doesn't use dig_speed, it uses efficiency.
    5) A bow uses 'power' to deal damage.
    6) A sword uses 'sharpness' for live mobs, or 'smite' for undead mobs.

    Make these changes and report back. Also as timtower mentioned it's much easier to assist when you provide any available stacktrace or log.
  4. Offline


    I strongly suggest using a ingame enchantment system, rather than a Notepad++/MySQL type style, you seem unfamiliar, and that isn't a judgement pass, that's a observation, the typos in the log, unknowingness, of things, I Strongly suggest you use a custom enchanter, like CE or another, will simply improve your gameplay 100%
Thread Status:
Not open for further replies.

Share This Page