Problem/Bug Essentials crashing after working properly

Discussion in 'Bukkit Help' started by IxWolfie, Jan 12, 2017.

Thread Status:
Not open for further replies.
  1. Offline


    Hey everyone,

    So I've been messing around with a server for a bit, and I've been testing out a bunch of different plugins. I deleted the entire plugins folder a few times, as well as reset the server entirely (quite literally recompiling all of the files I need to run a server, etc. - It's about as fresh as I can get). I'm using Bukkit 1.11.2, and I install Essentials. Please note that it worked prior to this perfectly fine. However, I can't get it to work without "Essentials failed to load" or "Essentials Protect is in emergency mode." I've already uninstalled, and reinstalled, Essentials with multiple different versions. Here's the log, since I'm sure you'll want that.


    [00:22:13] [Server thread/INFO]: Starting minecraft server version 1.11.2
    [00:22:13] [Server thread/INFO]: Loading properties
    [00:22:13] [Server thread/INFO]: Default game type: SURVIVAL
    [00:22:13] [Server thread/INFO]: Generating keypair
    [00:22:13] [Server thread/INFO]: Starting Minecraft server on *:47462
    [00:22:13] [Server thread/INFO]: Using epoll channel type
    [00:22:14] [Server thread/INFO]: This server is running CraftBukkit version git-Bukkit-27dd3ca (MC: 1.11.2) (Implementing API version 1.11.2-R0.1-SNAPSHOT)
    [00:22:14] [Server thread/INFO]: [Essentials] Loading Essentials vPre2.14.1.3
    [00:22:14] [Server thread/INFO]: [EssentialsSpawn] Loading EssentialsSpawn vPre2.14.1.3
    [00:22:14] [Server thread/INFO]: [EssentialsChat] Loading EssentialsChat vPre2.14.1.3
    [00:22:14] [Server thread/INFO]: [EssentialsAntiBuild] Loading EssentialsAntiBuild vPre2.14.1.3
    [00:22:14] [Server thread/INFO]: [EssentialsProtect] Loading EssentialsProtect vPre2.14.1.3
    [00:22:14] [Server thread/INFO]: Preparing level "world"
    [00:22:15] [Server thread/INFO]: Preparing start region for level 0 (Seed: -1427581702831350311)
    [00:22:16] [Server thread/INFO]: Preparing spawn area: 0%
    [00:22:17] [Server thread/INFO]: Preparing spawn area: 43%
    [00:22:18] [Server thread/INFO]: Preparing start region for level 1 (Seed: -1427581702831350311)
    [00:22:19] [Server thread/INFO]: Preparing start region for level 2 (Seed: -1427581702831350311)
    [00:22:19] [Server thread/INFO]: [Essentials] Enabling Essentials vPre2.14.1.3
    [00:22:19] [Server thread/INFO]: Bukkit version format changed. Version not checked.
    [00:22:19] [Server thread/INFO]: git-Bukkit-27dd3ca (MC: 1.11.2)
    [00:22:19] [Server thread/INFO]: 1.11.2-R0.1-SNAPSHOT
    [00:22:19] [Server thread/ERROR]: java.lang.NoSuchMethodError:;
    [00:22:19] [Server thread/ERROR]: Error occurred while enabling Essentials vPre2.14.1.3 (Is it up to date?)
    at com.earth2me.essentials.Essentials.onDisable( ~[?:?]
    at ~[minecraft_server.jar:git-Bukkit-27dd3ca]
    at com.earth2me.essentials.Essentials.handleCrash( ~[?:?]
    at com.earth2me.essentials.Essentials.onEnable( ~[?:?]
    at ~[minecraft_server.jar:git-Bukkit-27dd3ca]
    at [minecraft_server.jar:git-Bukkit-27dd3ca]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin( [minecraft_server.jar:git-Bukkit-27dd3ca]
    at org.bukkit.craftbukkit.v1_11_R1.CraftServer.enablePlugin( [minecraft_server.jar:git-Bukkit-27dd3ca]
    at org.bukkit.craftbukkit.v1_11_R1.CraftServer.enablePlugins( [minecraft_server.jar:git-Bukkit-27dd3ca]
    at net.minecraft.server.v1_11_R1.MinecraftServer.t( [minecraft_server.jar:git-Bukkit-27dd3ca]
    at net.minecraft.server.v1_11_R1.MinecraftServer.l( [minecraft_server.jar:git-Bukkit-27dd3ca]
    at net.minecraft.server.v1_11_R1.MinecraftServer.a( [minecraft_server.jar:git-Bukkit-27dd3ca]
    at net.minecraft.server.v1_11_R1.DedicatedServer.init( [minecraft_server.jar:git-Bukkit-27dd3ca]
    at [minecraft_server.jar:git-Bukkit-27dd3ca]
    at [?:1.8.0_111]
    [00:22:19] [Server thread/INFO]: [EssentialsSpawn] Enabling EssentialsSpawn vPre2.14.1.3
    [00:22:19] [Server thread/INFO]: [EssentialsChat] Enabling EssentialsChat vPre2.14.1.3
    [00:22:19] [Server thread/INFO]: [EssentialsAntiBuild] Enabling EssentialsAntiBuild vPre2.14.1.3
    [00:22:19] [Server thread/INFO]: [EssentialsProtect] Enabling EssentialsProtect vPre2.14.1.3
    [00:22:19] [Server thread/ERROR]: Essentials not installed or failed to load. Essenials Protect is in emergency mode now.
    [00:22:19] [Server thread/INFO]: Server permissions file permissions.yml is empty, ignoring it
    [00:22:19] [Server thread/INFO]: Done (5.001s)! For help, type "help" or "?"

    I was considering just using Bukkit 1.11, but I really wanted a 1.11.2 survival server for some friends and I to use. Regardless, any help is appreciated.
    Last edited by a moderator: Jan 12, 2017
  2. Offline


    There is no Bukkit for Minecraft 1.11 (or did I miss something within the last 2 years?)
  3. Offline


    Bukkit is now being updated by Spigot.
    Are you sure you are on the newest build? You should make sure you are up to date.

    Main issue: It looks like you only get this error when essentials is being disabled. Are you sure all the config files are there/valid? Also, since Essentials was not updated since 1.8, don't expect it to work in the future. There have been many reports of it no longer working.
  4. Offline



    Very sure, I've reinstalled it multiple times. It worked at first, then I restarted the server (to reset the Nether map cause the spawn was bad lol), and when the server opened it just didn't work. Nothing would have made it "stop" working, as it was just the Nether world that I moved.

    Yeah, I assumed that once I was looking at the Essentials updates. Do you have any recommendations to do what Essentials for 1.11 Spigot/Bukkit?

    Yeah, I found that odd considering I got it to work for about two days. It just miraculously decided to not work anymore. It's not a huge issue, just a nuisance. I thought that it'd still be compatible considering I got it to work. I guess I assumed wrong.

    Going back to my main question, is there anything for Spigot/Bukkit that did what Essentials did? Even if it's multiple plugins, I'd gladly take the suggestions.

    Thanks for the assistance,
Thread Status:
Not open for further replies.

Share This Page