Error Loading Minecraft World

Discussion in 'Bukkit Help' started by mmitchell816, Oct 29, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    mmitchell816

    So I have a map that we have been running on Vanilla Minecraft server with a few SMP mods. All of our mods were ported to Bukkit so we were going to switch to Bukkit. Long story short the server wont start cause it wont load the map. For awhile i thought it was a mod issues but then I tried something. I launched the map using a plain unmodded version of Vanilla Minecraft. It booted and remove all the extra block ID's from the mods. This worked fine. I think try to boot with and unmodded/no plugins craftbukkit1337 and I get the same error that I got when I was trying to use mods.

    The error is bellow. All i know is that the issues must be with Bukkit its self. Is there anything i could have done to the map to make it not readable by Bukkit? I have ran Chunkster against it with no help.

    Code:
    java -server -Xms1G -Xmx2G -jar craftbukkit-0.0.1-SNAPSHOT.jar
    161 recipes
    17 achievements
    16:24:43 [INFO] Starting minecraft server version Beta 1.8.1
    16:24:43 [INFO] Loading properties
    16:24:43 [INFO] Starting Minecraft server on *:25567
    16:24:43 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-1131-g86b7fa8-b1337jnks (MC: 1.8.1)
    16:24:43 [INFO] Preparing level "world"
    16:24:43 [INFO] Default game type: 0
    16:24:43 [INFO] Unable to find spawn biome
    16:24:43 [SEVERE] java.lang.NullPointerException
    16:24:43 [SEVERE]       at net.minecraft.server.WorldServer.c(WorldServer.java:162)
    16:24:43 [SEVERE]       at net.minecraft.server.World.a(World.java:2224)
    16:24:43 [SEVERE]       at net.minecraft.server.Chunk.addEntities(Chunk.java:634)
    16:24:43 [SEVERE]       at net.minecraft.server.ChunkProviderServer.getChunkAt(ChunkProviderServer.java:81)
    16:24:43 [SEVERE]       at net.minecraft.server.ChunkProviderServer.getOrCreateChunk(ChunkProviderServer.java:106)
    16:24:43 [SEVERE]       at net.minecraft.server.World.getChunkAt(World.java:300)
    16:24:43 [SEVERE]       at net.minecraft.server.World.getTypeId(World.java:247)
    16:24:43 [SEVERE]       at net.minecraft.server.World.isEmpty(World.java:251)
    16:24:43 [SEVERE]       at net.minecraft.server.World.a(World.java:218)
    16:24:43 [SEVERE]       at net.minecraft.server.WorldProviderHell.canSpawn(SourceFile:37)
    16:24:43 [SEVERE]       at net.minecraft.server.World.canSpawn(World.java:104)
    16:24:43 [SEVERE]       at net.minecraft.server.World.c(World.java:202)
    16:24:43 [SEVERE]       at net.minecraft.server.World.<init>(World.java:150)
    16:24:43 [SEVERE]       at net.minecraft.server.WorldServer.<init>(WorldServer.java:27)
    16:24:43 [SEVERE]       at net.minecraft.server.SecondaryWorldServer.<init>(SecondaryWorldServer.java:8)
    16:24:43 [SEVERE]       at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:221)
    16:24:43 [SEVERE]       at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:152)
    16:24:43 [SEVERE]       at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:348)
    16:24:43 [SEVERE]       at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    16:24:43 [SEVERE] Unexpected exception
    java.lang.NullPointerException
            at net.minecraft.server.WorldServer.c(WorldServer.java:162)
            at net.minecraft.server.World.a(World.java:2224)
            at net.minecraft.server.Chunk.addEntities(Chunk.java:634)
            at net.minecraft.server.ChunkProviderServer.getChunkAt(ChunkProviderServer.java:81)
            at net.minecraft.server.ChunkProviderServer.getOrCreateChunk(ChunkProviderServer.java:106)
            at net.minecraft.server.World.getChunkAt(World.java:300)
            at net.minecraft.server.World.getTypeId(World.java:247)
            at net.minecraft.server.World.isEmpty(World.java:251)
            at net.minecraft.server.World.a(World.java:218)
            at net.minecraft.server.WorldProviderHell.canSpawn(SourceFile:37)
            at net.minecraft.server.World.canSpawn(World.java:104)
            at net.minecraft.server.World.c(World.java:202)
            at net.minecraft.server.World.<init>(World.java:150)
            at net.minecraft.server.WorldServer.<init>(WorldServer.java:27)
            at net.minecraft.server.SecondaryWorldServer.<init>(SecondaryWorldServer.java:8)
            at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:221)
            at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:152)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:348)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    >
    
    Server info below.

    Code:
    Linux mdwb01 2.6.32-28-server #55-Ubuntu SMP Mon Jan 10 23:57:16 UTC 2011 x86_64 GNU/Linux
    java version "1.6.0_26"
    Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
    Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02, mixed mode)
    
    Please help, Thanks
     
  2. Offline

    c0mp

    It could be that you were using a mod that created a weird biome, and now that the mod was removed, that biome isn't recognized by bukkit/minecraft. Try renaming your world folder and restart your server, allowing it to generate a new, temporary world, see if it gives you that error again.
     
  3. Offline

    mmitchell816

    Yeah it works if i let it create a new world. The only mods that I used were RedPower and BuildCraft. I know RedPower adds to the map but that mod is fully ported. I guess ill reach out to that mods dev to. Any other ideas?
     
  4. Offline

    c0mp

    If its your world, then it's your world, not a TON you can do about it, unfortunately. If you've got backups, try restoring from a known-good. If you're able to open the map in MCEdit, see if it will let you delete the chunks around your spawn area and then let Minecraft rebuild them, see if that works. Really not much that can be done.
     
  5. Offline

    mmitchell816

    Thanks. Just odd. For now ill just not switch to bukkit. My user base would not like to get the world wiped.
     
  6. Offline

    Karosas

    I think chunkster would "repair" bad chunks, but map may be changed a little, where was bad chunks, there can be mountains or something..
     
  7. Offline

    mmitchell816

    I tried chunkster. Didn't help.
     
  8. Offline

    davr

    It's definitely a bukkit issue -- I just went from a plain vanilla server with no mods ever to bukkit, and am getting this same exact error. It seems like certain worlds bukkit doesn't like for some reason.
     
  9. Offline

    mmitchell816

    Yeah I had to tell all the people on the server that if we wanted bukkit we would have to scrap the map. They voted scrap the map, still sucked.
     
  10. Offline

    TnT Retired Staff

    It was suggested above and I don't know if it will help, but you can try to open your world with MCEdit.
     
Thread Status:
Not open for further replies.

Share This Page