EpicQuest - Moved to DevBukkit. Link in thread!

Discussion in 'WIP and Development Status' started by Randy Schouten, Jun 27, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    He JUST updated lol. I would leave him to fix all the other plugins that are supposed to work with this one before he works on 1.0
  2. Offline

    Randy Schouten

    Well, first I want to bring back the missing features that were in 0.8.
    After that are a few more features I'd like to put in there, such as quest chains.

    Once these few things are done, I will ask a mod to move it over to plugin releases. ;)

    After that, I will update NPC-Quester to work with EpicQuest.
    Probably a small update soon for it to work with 0.9, without any additional features added in.
  3. Offline


    D:\ServeurTest>java -Xmx1024M -Xms1024M -cp ItemCraft.jar;craftbukkit-0.0.1-SNAP
    SHOT.jar org.bukkit.craftbukkit.Main
    151 recipes
    16 achievements
    19:40:35 [INFO] Starting minecraft server version Beta 1.7.3
    19:40:35 [INFO] Loading properties
    19:40:35 [INFO] Starting Minecraft server on *:25565
    19:40:35 [INFO] This server is running Craftbukkit version null (MC: 1.7.3)
    19:40:35 [INFO] [Permissions] Creating storageconfig.yml.
    19:40:35 [INFO] [Permissions] (Yeti) was initialized.
    19:40:35 [INFO] [Permissions] version [3.1.6] (Yeti) loaded
    19:40:35 [INFO] Preparing level "world"
    19:40:35 [INFO] Preparing start region for level 0 (Seed: 5110594420736995398)
    19:40:36 [INFO] Preparing start region for level 1 (Seed: 5110594420736995398)
    19:40:36 [INFO] Preparing spawn area: 8%
    19:40:37 [INFO] Spout has been initialized
    19:40:37 [INFO] [EpicQuest]: Enabling...
    19:40:37 [INFO] [EpicQuest]: Found and will use plugin Permissions v3.1.6
    19:40:37 [INFO] [EpicQuest]: Loading quests...
    19:40:37 [GRAVE] Error occurred while enabling EpicQuest v0.9 (Is it up to date?
    ): null
    at randy.eq.eqQuestLoader.loadQuests(eqQuestLoader.java:194)
    at randy.eq.eq.onEnable(eq.java:77)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:162)
    at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:146
    at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:284)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:271)
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:148)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:335)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    19:40:37 [INFO] Server permissions file permissions.yml is empty, ignoring it
    19:40:37 [INFO] Done (0,218s)! For help, type "help" or "?"
    I've this problem yet :(
    Thx for this plugin.
  4. Offline

    Randy Schouten

    Double check your config.
    If I see it correctly, you have it there that iConomy is enabled, but the actual plugin is not there.
  5. Offline


    Damn, iconomy needed?
    I try with iconomy, but i've this prob:

    D:\ServeurTest>java -Xmx1024M -Xms1024M -cp ItemCraft.jar;craftbukkit-0.0.1-SNAP
    SHOT.jar org.bukkit.craftbukkit.Main
    151 recipes
    16 achievements
    20:46:42 [INFO] Starting minecraft server version Beta 1.7.3
    20:46:42 [INFO] Loading properties
    20:46:42 [INFO] Starting Minecraft server on *:25565
    20:46:42 [INFO] This server is running Craftbukkit version null (MC: 1.7.3)
    20:46:42 [INFO] [Permissions] (Yeti) was initialized.
    20:46:42 [INFO] [Permissions] version [3.1.6] (Yeti)  loaded
    20:46:42 [INFO] Preparing level "world"
    20:46:42 [INFO] Preparing start region for level 0 (Seed: 5110594420736995398)
    20:46:43 [INFO] Preparing spawn area: 93%
    20:46:43 [INFO] Preparing start region for level 1 (Seed: 5110594420736995398)
    20:46:44 [INFO] Preparing spawn area: 20%
    20:46:45 [INFO] Preparing spawn area: 24%
    20:46:46 [INFO] Preparing spawn area: 40%
    20:46:47 [INFO] Preparing spawn area: 85%
    20:46:50 [INFO] [iConomy] Logging is currently disabled.
    20:46:50 [INFO] [iConomy] v5.01 (Eruanna) loaded.
    20:46:50 [INFO] [iConomy] Developed by: [Nijikokun]
    20:46:50 [INFO] [iConomy] hooked into Permissions.
    20:46:51 [INFO] Spout has been initialized
    20:46:51 [INFO] [EpicQuest]: Enabling...
    20:46:51 [INFO] [EpicQuest]: Found and will use plugin Permissions v3.1.6
    20:46:51 [INFO] [EpicQuest]: Loading quests...
    20:46:51 [INFO] [EpicQuest]: iConomy found, enabling.
    20:46:51 [INFO] [EpicQuest]: Quests loaded.
    20:46:51 [INFO] [EpicQuest]: Creating files...
    20:46:51 [INFO] [EpicQuest]: Config file found!
    20:46:51 [INFO] [EpicQuest]: Quests file found!
    20:46:51 [INFO] [EpicQuest]: Chain quests file found!
    20:46:51 [INFO] [EpicQuest]: 0 blank files created.
    20:46:51 [INFO] [EpicQuest]: No progress to load.
    20:46:51 [INFO] Server permissions file permissions.yml is empty, ignoring it
    20:46:51 [INFO] Done (0.925s)! For help, type "help" or "?"
    20:47:04 [INFO] Percene [/] logged in with entity id 541 at ([wor
    ld] -105.9375, 67.0, -34.28125)
    20:47:05 [INFO] Reading data
    20:47:05 [INFO] [Spout] Successfully authenticated Percene's Spoutcraft client.
    Running client version:
    20:47:13 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'q' i
    n plugin EpicQuest v0.9
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
            at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:12
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:3
            at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.
            at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:677)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:670)
            at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
            at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:85)
            at org.getspout.spout.SpoutNetServerHandler.a(SpoutNetServerHandler.java
            at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Caused by: java.lang.ArrayIndexOutOfBoundsException: 0
            at randy.eq.eq.onCommand(eq.java:137)
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
            ... 13 more
    I've: Permissions, Spout (serv+ client), epicquest and Iconomy.

    Thx for your help.
  6. Offline

    Randy Schouten

    No, you don't need iConomy, but I think you had it said enabled in your config, while iConomy was not installed on your server. :p

    What command are you trying to use?
    Does the error occur at other commands too?
  7. Offline


    Hum, I type "/q" and i've an "internal error" but "/q help" or "/q solo" or anything works.
    So, i think it's not matter?!

    Thank you. :)
  8. Offline

    Randy Schouten

    Ah thanks, I will fix that. :)
  9. Offline


    works with npc questers?
  10. Offline


    Is there a convertor for iQuest/uQuest quest files to your format? :)
  11. @Randy Schouten

    Some news from this amazing plugin? ^^
    Did you progress on your TODO and HUD features?

  12. Offline


    Hey man. Are you thinking about updating the plugin at anytime. Bukkit finally has a recommended build for 1.8. I have tried looking at the source code and updating it my self but im not that good, and just updating the libraries to the new build doesn't work either. This plugin is amazing. If you need any help send it on my way.

  13. Offline


    @Randy Schouten
    no worky with 1.8ty

    2011-09-23 19:48:12 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'q' in plugin EpicQuest v0.9
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:41)
        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:163)
        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:353)
        at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:756)
        at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:721)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:714)
        at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
        at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:92)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:464)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:374)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    Caused by: java.lang.NullPointerException
        at randy.eq.eqAPI.getPossibleQuests(eqAPI.java:309)
        at randy.eq.eqAPI.giveQuest(eqAPI.java:223)
        at randy.eq.eq.onCommand(eq.java:182)
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:39)
        ... 12 more
  14. Offline


    Really looking forward to this plugin! Once "waypoint" types are added consider us 100% onboard!
  15. Offline


  16. Offline


    Are you able to create a quest where you have to kill a certain NPC? This would be way very cool because you could set up raids to kill a "King" or something of the sort. Also is this compatible with CitizenSpout? Thanks.
    EDIT: Also, when you say "show quest statistics" are you referring to in a quest book HUD such as WoW or in chat? Thanks.
  17. Offline


    hi :) so does this support 1.8 ? Im waiting to use it when u add money rewards ;-D
  18. @Randy Schouten

    Do you think it would be possible to add the ability to add a reward type: Add permission node.
    I want users to be able to complete a quest chain (one of many), and at the end of the chain, gain the ability to do something (eg, enable a permission node for that user). Whether this is accomplished by changing permission files, or the configuration of a 'reward' being the operation of a command: (eg, for my case:: /permissions player setperm <username> plugin.node true ).
    Thanks for a good job so far!

    (btw, my 'request' with more detail is found here )
  19. Offline


    Please update!
  20. Offline


    Update pleas :(
  21. Offline


    How long do you think it will take to add collect quests?
  22. Offline

    Randy Schouten

    I'm sorry for being inactive for so long.
    I had a Gamesjam previous weekend and I had to brush up my digital art skills.
    I will try to update my plugins as soon as possible.

    Thanks for the patience :)
    RugRats likes this.
  23. Offline


    Is the collect quest a quest where you loose the stuffs you have collected at the end?? I was thinking like giving it to a NPC where you have to gather stuffs for him, like ole farmer needs help getting some seeds.
  24. Offline


  25. Offline


    @Randy Schouten
    Hey. I was wondering if this plugin will be updated soon? I really want a quest plugin for my server. :)
  26. Offline


    this should probably be marked as inactive...
  27. Offline

    Randy Schouten

    I'm very busy rewriting it (once again)!
    I'm very sorry for the delay.

    Progress is steady and pretty fast as well, so be patient just a bit longer!
  28. Offline


    Thanks for your work on this Randy!

    So I thought I'd test this out... And needing some quests I decided to port quests.yml from uQuest. Hopefully it's of use to someone (see attached quests.zip).

    Observation, REQuests, BUGs, thoughts, etc...
    • BUG?: Doesn't (re)create EpicQuests plugin directory and/or missing files.
    • It's quite picky about space indenting and the order of sections with a quest.
    • BUG?: In the Rewards section both Money and at least one Item must always be specified (even if it's all 0s).
    • REQ: Need a setting to limit the number of currently active quests players can have. And maybe an op command to override that for a particular player?
    • BUG?: Doing "/q" on it's own throws a Java exception.
    • Issues with quests can be hard to work out because it tends to throw blind java exceptions rather than print more informative messages.
    • Because of the above I needed the source to work out issues in my quests :)
    • No doco on the quests.yml layout also meant I needed the source to work this out :)
    • BUG?: When a quest is assigned the Reward displays "money" rather than the value of moneyname (i.e., the economy's name for a dollar).
    • BUG?: This is weird. At the start when I stopped my Bukkit I would have a file in the players dir and an entry in the config.yml. But for the last day or so it just won't do that. I tried recreating my EpicQuests/ subdir from scratch but that didn't help.
    • BUG?: Recently I get repeat quests dropped, even when the quest has Onlyonce set to true. Due to the above I think.
    With the "EpicQuest/players/Player.yml" and "/q" bugs resolved I could actually intstall this on our little prod bukkit!


    Edit: File attachments aren't working?!? Try this freakshare link instead.
  29. Offline


  30. Offline


    hi i have a little feature request.

    can it be posseble to run a command when the player complites a quest and also add a varible you can put in for the players name

    i also have a problem that uquest wont be found by bukkit and no commands works. exsample /q solo
    after that nothings happens not any error or anything

    also when i type /plugins epic quest arent there

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
Thread Status:
Not open for further replies.

Share This Page