EGit problem

Discussion in 'Plugin Development' started by raGan., Aug 12, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    I know there are better forums to post, but many of you are using git to share source code. I found out how to work with it at basic level, but now I have a problem.
    I pushed commit, and then I wanted to change it a little, so I used amend previous commit and changed commit description too. Now egit is rejecting my pull request with message:
    rejected non-fast-forward
    Can you please help me with this ? I tried to pull, since I found it as the solution somewhere else, but it told me that my branch is not configured to pull... I really have a hard time with that thing.
  2. Offline

    dark navi

    If anything, you can reset your code (Team->Reset->Hard Reset) and it will pull the latest version. This will cause you to lose work. Sorry I couldn't be more help, git is still pretty weird to me.
  3. Offline

    Sagacious_Zed Bukkit Docs

    When to amend commits, and want to push it to say github you must force the push.
  4. Offline


    Thanks, that worked.
Thread Status:
Not open for further replies.

Share This Page