[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. Offline


    /mvspawn returns the user to the spawn point per world
  3. Offline


    Is there any way to make the /spawn command do the same thing?
  4. Offline


    do you mean when i go to the folder i go to plugins - MultiVerse - Worlds.yml? cuz i have one for all three worlds World - HELL - Flatgrass but i still cant change time of day
  5. Offline


    Hi. I'm in dire need of assistance. I'm not sure what this problem would fall under. Whenever someone goes to a world that isnt the default world, they are unable to break or place blocks. Why is this? And how can i fix it? pleasehalp! D=
  6. Offline


    Whenever I enter a portal my minecraft skin resets to default. How do I fix this?
  7. Offline


    It says [SEVERE] Could not load 'plugins/Permissions.jar' in folder 'plugins'
  8. Offline


    Now how about posting the rest of the error stack
    SCNL errors are just the user friendly message saying it broke, the rest of the stack explains why
  9. Offline


    16:37:07 [SEVERE] Could not load 'plugins\Permissions.jar' in folder 'plugins':

    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

    at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)

    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Sou
    at java.lang.reflect.Constructor.newInstance(Unknown Source)
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.j
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:85)
    at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:217)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:204)
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:144)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:259)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    Caused by: mapping values are not allowed here
    in "<reader>", line 108, column 19:
    prefix: '&9'

    at org.yaml.snakeyaml.scanner.ScannerImpl.fetchValue(ScannerImpl.java:74
    at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreTokens(ScannerImpl.ja
    at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(ScannerImpl.java:18
    at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingKey.produce(Par
    at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:163)
    at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:148)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:12
    at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:105)

    at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseCons
    at org.yaml.snakeyaml.Yaml.load(Yaml.java:264)
    at com.nijiko.configuration.NotNullConfiguration.load(NotNullConfigurati
    at com.nijikokun.bukkit.Permissions.Permissions.<init>(Permissions.java:
    ... 13 more
  10. I have the same problem! Multiverse always worked fine untill i updated it, all the other plugins work fine on permissions.
  11. In your Permissions folder. I have two worlds: Survival and Creative. So my Permissions folder has two files, Survival.yml and Creative.yml. The .yml file being Permission's config file that is initially in the Permissions folder when you are installing Permissions (the one that you have to rename to the name of your world). You have to have a Permissions config file for every world you make. Simply take the one that is already in there, duplicate it, and rename the duplicate to the name of your second world. Repeat for every world. This way, you can also change specific permissions for each world.

    You only need one Worlds.yml file in your Multiverse folder.
  12. Offline


    Not sure why this hasnt been implemented yet... but it would be almost essentials for my server to have MultiHealth... meaning health does not go over from one world to the other... I run 5 worlds, and in some, players have access to /i /give commands, and there is also a PvP world... so if they ever figure it out, they could spawn out of PvP... heal themselves, then spawn back into PvP and they would be full health...

    Can any one recommend a plugin that would take care of this, or maybe this could be a very nice addition to this awesome plugin!
  13. Offline


    I'm getting constant (several a second) errors with MultiVerse 1.6.3 and CraftBukkit 740. It's definite MultiVerse and I tried loading the server with no other plugins enabled.

    They're all something like this:
  14. Offline


    :p after looking at all the problems people are having, I hope mine is a simple fix.
    When i try to create a portal, using the wooden pickax, all i get is set point 2. never 1, just 2.
    I'm a derp, wasn't left-clicking for point 1 :rolleyes:
  15. Offline


    Aye, the new iConomy 5 throws an error to MultiVerse, making it impossible to port to the other world if iConomy is set to true.

    Just letting you know ;)
  16. I have the iConomy 5 fix ready, waiting on the next RB which will *hint hint* add true per-world PVP, but thanks! If you want to build from source and not be running a bukkit RB, feel free to!

    Is it now, or is it the world file? Can you load this world in single player?

    I'll put it in the feature tracker for MV 2.x

    Same? There are around 2800 other posts...

    Hmm, pretty sure I already fixed and tested your permissions file... so looks like this is a question for the permissions thread if it's still not working, this is not an issue with MultiVerse.

    These are both essentials commands. So no.

    All multiverse commands start with "/mv..."

    Obligatory thank you post to @Maxis010

    Thanks for the help battling the massive number of replies to this thread daily!

    You need to set the permissions in your other worlds, by default people basically can't do anything. The instructions are identical to how you setup your main world, just rename that file worldname.yml or whatever.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  17. Offline


    Whenever I left click or right click on a block, it gives me "You cannot do this!" message in the Minecraft Chatbox.
    On the console, it does not show any errors. It happens to the other players in my server too.
  18. Seeing as the string "You cannot do this!" is not anywhere in the MultiVerse code, I find this highly unlikely. Are you sure it's not another plugin?
  19. Offline


    Thanks :) It'd be a nice feature to have though. Any thoughts of highjacking the /spawn command?
  20. Offline


    Perhaps, thnx for pointing this out. I guess I should go checking other plugins. Thnx for your help. :) Deleted some other plugins and it worked perfectly :)
  21. Offline


    Your welcome good Sir

    Caused by: mapping values are not allowed here
    in "<reader>", line 108, column 19:
    prefix: '&9'

    OK, so now (inside of code tags) post your permissions file, the error stack says there is a problem around line 108 so I know where to look
  22. Offline


    Installed multiverse and worked fine for about a week or so and then my server started giving me some serious errors and reverting from memory leaks. Had to remove it...
  23. Offline


    I have 2 extra worlds setup that I want different groups to have access to.
    world2 I only want groups above default to be able to enter and world3 I want only vips.
    I setup config as shown in the pastebin
    playerWhitelist: 'g:member'
    playerWhitelist: 'g:vip'
    but members can join the vip world.
    each of the groups allowed to access another world have the mvtp permission set. Does this bypass the whitelist setting? I even tried to set the groups I dont want to access worlds to playerblacklist and they are still able to enter.
    I am using groupmanager for permissions, could this be part of the problem too?

    Ok whitelist is only for portals and tp bypasses this. This is good enough for now. Great plugin keep up the good work!
  24. Offline


    how do you make it so only people that are whitelisted can go thur portals?
  25. Offline


    [home]07:53:18 [SEVERE] Could not pass event PLAYER_MOVE to MultiVerse
    at com.onarandombox.Rigby.MultiVerse.MVPlayerListener.onPlayerMove(MVPlayerListener.java:212
    at org.bukkit.plugin.java.JavaPluginLoader$7.execute(JavaPluginLoader.java:268)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:274)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:130)
    at net.minecraft.server.Packet10Flying.a(SourceFile:126)
    at net.minecraft.server.NetworkManager.a(NetworkManager.java:195)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:74)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:370)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:285)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    07:53:18 [WARNING] jampacked was kicked for floating too long!
    07:53:18 [INFO] Player "jampacked" was kicked!
    07:53:18 [INFO] Unloading player "jampacked"'s data!
    07:53:18 [INFO] Player "jampacked" quitted!
    07:53:18 [INFO] Unloading player "jampacked"'s data!
    07:53:18 [INFO] BuyAbilities: Player "jampacked"'s data saved.[/code]

    Not sure what's goin on with this... It may be due to the fact I'm running a pre-release version of bukkit from here: http://forums.bukkit.org/threads/entity-already-tracked-error-join-the-discussion.15643/
  26. Offline


    Ok ill attempt that now, thanks for all the help! :D
  27. Offline


    Is the first world in the config made the default world? Or am I missing a flag for setting it.

    Thanks, awesome work!
  28. I created a new world with this plugin named "wldtst", and created a permissions file under /plugins/permissions named "wldtst", (an exact copy of the normal world). when i travel/teleport to 'wldtst', my console is spammed with errors from other plugins that there are no permissions configured for me as player, and all else goes to hell XD

    Does anyone know why a world created by this plugin would NOT be recognized by permissions and not actually load permissions when the world is generated/accessed??

    Any help would be appreciated
  29. I think it'd be a bit obvious that i was talking about the post above me.
  30. If you could post both yml files to pastebin, i'll take a look.

    Should be possible, I know essentials supports command overriding, on that note, if this does not come out in the next relase, couldn't you just revoke people's access to /spawn (essentials.spawn)?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016

Share This Page