[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. Do you have any additional info on how to reproduce this? Could you post, on pastebin, a full console log? I'm currently in IRC trying to help with this exact issue, so feel free to hop in there, i'm much faster to respond :)
  3. Offline


    Forget my last post about that error with death. It seems to have gone away by itself. I have no clue why. S:
  4. Offline


    Hi! I want to thank you for your work on this fantastic plugin. I have a few questions and an observation:

    1) mvtp does not appear to allow me to correctly teleport to named portals. /mvtp world and /mvtp nether work as you'd expect, but if I do something like /mvtp p:trainstation it brings me to a specific coordinate; specifically it brings me to 0,40,0. Any portal that I teleport to in this manner brings me straight here. If I set a portal destination with mvpd or during the mvpc process, it will go to the named portal correctly, as expected. The same behavior happens with many different named portals.

    2) Is it possible to set a named portal as the "default" portal destination? I see that it's possible to set up an splike and a nether, as well as a default world, but how about to portals? I'd like to have any lit obsidian portal defaultly take me to, say, p:portalroom ...

    3) I am a big fan of the sign creation method for portals because this prevents users from creating portals in mid-air or in grief-ish locations; but this prohibits users from naming and setting portals to go to specific points, which would be very nice. I know this is what the new portal creation method is for, but I have no way of controlling WHERE they create these portals-- I'd like to (quite lamely) restrict it to visible, purple portal tiles.
  5. Offline


    Perimissions is not Enabled, or hasn't been found.
    thats odd considering i just installed the latest version
    little help please?
  6. Hello if you could post:
    Bukkit Version
    MultiVerse Version
    Any Errors in console
  7. Offline


    Trying to import a map. One built by the planetoids mod. But when I import it it takes me to some basic map. I've tried it a few times.
  8. Offline


    Seems to work great with Fayconomy, Bukkit 740, Essentials, and GroupManager.

    Thank you for a great plug-in!
  9. Offline


    When I try to use multiverse, its says "Permissions has not been enabled, or cannot be found"

    What do I do!? I installed permissions for 740 and it works for other plugins...
  10. For all of the people who hare having issues with "Permissions", when it says that, it's talking about the plugin with the title of "Permissions". This is the only type supported for the current MultiVerse release.

    Link to Permissions

    This is not a MultiVerse issue. That program produces old minecraft save files. Generate a world, then open it in single player (Note the "Must be converted" message when playing for the first time)

    Then move it to SMP

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  11. Offline


    Thanks. Wasn't sure which was at fault.

    Working like a charm now.
  12. Offline


    Mine says Permissions is not enabled, or hasn't been found... all my other plugins are working with permissions and im using recommended permissions
  13. What other plugins are you running? What version of CraftBukkit? What does your console say?
  14. Offline


    I am running rb740, Plugins:admin cmd,ancient gates,auto save, backtobody, colorme, creaturespawner, essentials, fencesatck, godpowers, heroicdeath, iconomy, permissions 2.5.5, plgsetspawn, superpowers, teleplusplus, weatherplugin, wolfpound (btw it awsome thx for developing), worldedit, worldguard
    Version 1.6.3 enabled, found iconomy, enabling payments, loading world & settings -'TheCastCraft' - NORMAL, 1 world loaded, loading portals, 0 - portals loaded
  15. Could you pastebin the whole startup log, Also you should upgrade permissions, 2.7.2 is out now.
  16. Offline


    Im not sure what u mean by pastebin and i had permissions 2.7.2 but it didnt work that is why i tried the recommended but i will switch back
  17. pastebin.com (makes cli output much easier to read)
    Here is my test rig startup:

    I want to see from Starting Minecraft Server to DONE
  18. Offline


    so how do i get or use pastebin... how do i copy the server stuff basically

    146 recipes
    16 achievements
    21:47:41 [INFO] Starting minecraft server version Beta 1.5_02
    21:47:41 [INFO] Loading properties
    21:47:41 [INFO] Starting Minecraft server on
    21:47:41 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-706-
    gf53e007-b740jnks (MC: 1.5_02)
    21:47:41 [INFO] Preparing level "TheCastCraft"
    21:47:41 [INFO] Preparing start region
    21:47:42 [INFO] Preparing spawn area: 52%
    21:47:43 [SEVERE] Could not load 'plugins\Permissions.jar' in folder 'plugins':

    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

    at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)

    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Sou
    at java.lang.reflect.Constructor.newInstance(Unknown Source)
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.j
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:85)
    at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:217)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:204)
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:144)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:259)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    Caused by: mapping values are not allowed here
    in "<reader>", line 108, column 19:
    prefix: '&9'

    at org.yaml.snakeyaml.scanner.ScannerImpl.fetchValue(ScannerImpl.java:74
    at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreTokens(ScannerImpl.ja
    at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(ScannerImpl.java:18
    at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingKey.produce(Par
    at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:163)
    at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:148)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:12
    at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:105)

    at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseCons
    at org.yaml.snakeyaml.Yaml.load(Yaml.java:264)
    at com.nijiko.configuration.NotNullConfiguration.load(NotNullConfigurati
    at com.nijikokun.bukkit.Permissions.Permissions.<init>(Permissions.java:
    ... 13 more
    21:47:43 [INFO] [AdminCmd] (version 4.5) Enables without Permissions.
    21:47:43 [INFO] [AdminCmd] Instead of Permissions, check if the user is OP.
    21:47:43 [INFO] [AncientGates v1.0.2] Loading conf from disk
    21:47:43 [INFO] [AncientGates v1.0.2] Loading gates from disk
    21:47:43 [INFO] [AncientGates v1.0.2] Enabled
    21:47:43 [INFO] [AutoSave] Server Version is Recommended Build 740
    21:47:43 [INFO] [AutoSave] Loading config file
    21:47:43 [INFO] [AutoSave] Version 1.2.8 is enabled: b553a950-0865-442c-a377-c52
    21:47:43 [INFO] [BackToBody]: Permission system not detected. Disabling Permissi
    ons support.
    21:47:43 [INFO] [BackToBody] v2.2 has been enabled.
    21:47:43 [INFO] [ColorMe]: Permission system not detected. Defaulting to OP perm
    21:47:43 [INFO] [ColorMe] v2.0 has been enabled.
    21:47:43 [INFO] [CreatureSpawner] version 1.1 by [Xstasy] enabled.
    21:47:44 [INFO] Loaded Essentials build 2.2.8 maintained by Zenexer, ementalo, A
    elux, Brettflan, KimKandor, snowleo and ceulemans.
    21:47:44 [INFO] FenceStack version 1.13 loaded.
    21:47:44 [INFO] godPowers version 2.0 is enabled!
    21:47:44 [INFO] It seems you don't have permissions installed. Ops will have pri
    ority with godPowers now!
    21:47:44 [INFO] HeroicDeath: Improper color definition in config.yml, using defa
    21:47:44 [INFO] [HeroicDeath] enabled.
    21:47:44 [INFO] [iConomy] Logging is currently disabled.
    21:47:44 [INFO] [iConomy] v4.65 (Kenzi) loaded.
    21:47:44 [INFO] [iConomy] Developed by: [Nijikokun, Coelho]
    21:47:44 [INFO] [MultiVerse] Commands are disabled unless Permissions is found.
    21:47:44 [INFO] [MultiVerse] - Version 1.6.3 Enabled
    21:47:44 [INFO] [MultiVerse] Found iConomy, enabling payments.
    21:47:44 [INFO] [MultiVerse] Loading World & Settings - 'TheCastCraft' - NORMAL
    21:47:44 [INFO] [MultiVerse] 1 - World(s) loaded.
    21:47:44 [INFO] [MultiVerse] Loading Portals
    21:47:44 [INFO] [MultiVerse] 0 - Portal(s) loaded.
    21:47:44 [INFO] PlgSetspawn version 4.1 is enabled!
    21:47:44 [INFO] [SuperPowers] Couldn't find permissions plugin. Defaulting to op
    21:47:44 [INFO] SuperPowers v0.4 loaded!
    21:47:44 [INFO] If you're using CraftBukkit 617 flying WILL NOT work. Please don
    't post about it to the thread.
    21:47:44 [INFO] [Tele++] version [1.3.3a] loaded
    21:47:44 [INFO] WeatherPlugin version 1.1 is enabled op-only permissions!
    21:47:45 [INFO] [WolfPound] - Version 0.11 Enabled
    21:47:45 [INFO] [WolfPound] using iConomy Economy!
    21:47:45 [INFO] WorldEdit 4.4 enabled.
    21:47:45 [INFO] WorldEdit: No known permissions plugin detected. Using configura
    tion file for permissions.
    21:47:45 [INFO] WorldGuard: No known permissions plugin detected. Using configur
    ation file for permissions.
    21:47:45 [INFO] WorldGuard: (TheCastCraft) Single session is enforced.
    21:47:45 [INFO] WorldGuard: (TheCastCraft) TNT ignition is blocked.
    21:47:45 [INFO] WorldGuard: (TheCastCraft) Lighters are blocked.
    21:47:45 [INFO] WorldGuard: (TheCastCraft) Lava fire is blocked.
    21:47:45 [INFO] WorldGuard: (TheCastCraft) All fire spread is disabled.
    21:47:45 [INFO] WorldGuard: Loaded configuration for world 'TheCastCraft"
    21:47:45 [INFO] WorldGuard 5.0-alpha10 enabled.
    21:47:45 [INFO] Done (0.403s)! For help, type "help" or "?"

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  19. Offline


    Changing the multiverse.jar's name to amultiverse loads mv first and fixes the issue of nether worlds becoming normal worlds.

    Since updating to cb 740 i also updated to WG 5 Alpha 10 which includes support for multi worlds. WG was loading the worlds first and detecting them as normal worlds causing it to generate a normal world region folder in the nether worlds folder.
    fernferret likes this.
  20. Offline


    Can someone help me set the god damn coordinates for portals? The OP doesn't explain it :/
  21. Just because you copied that jar does not mean you installed it... There's a problem with your permissions YML file.

    Step 1. Calm down.
    Step 2. Copied from OP:
    There really is something to be said for politeness in posts...

    Seems like more and more plugins are assuming worlds are NORMAL, we'll have to start working to get some kind of order formed out of all this chaos. Thanks for doing the detective work!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  22. Offline


    No problem :D Definitely need a fix or some way to stop plugins from assuming worlds environments to be NORMAL. Im sure allot of people have encountered the issue and have just given up. It was actually another members suggestion to try renaming all plugins that load and interact with multiple worlds to have them load after mv, but it was much easier changing mv to load first.

    All in all im just very happy the issue has been resolved :D Still get issues when importing worlds elated ot passing creature spawn event that seem to be related to wg, but everything is working fine so im happy :)
  23. Offline


    is there a way to only let certain permission groups goto certain worlds?
  24. Offline


    If only people would use the fundamental skill they learned in school called reading....
  25. Offline


    Several posts back, he mentioned how to do this with groups.

    http://pastebin.com/0atdnj6G <--that is the PasteBin.

    You are looking for: Notice line #13
    1. world2:
    2. animals: true
    3. pvp: true
    4. alias: ''
    5. blockBlacklist: ''
    6. worldBlacklist: ''
    7. spawn: -111:66:27:4.6499944:-10.3499975
    8. mobs: true
    9. price: 0.0
    10. environment: NORMAL
    11. editWhitelist: ''
    12. playerBlacklist: ''
    13. playerWhitelist: 'g:Admins'
    14. editBlacklist: ''
  26. Offline


    That generally means you have a problem in the yml, run it through notepad++ or just look through the logs to see if the YAML reader throws errors as it will give you the point of error
  27. Offline


    Sry for asking if there is already an answer - in that case I seem to be blind - how to define more than one group.
    Do I simply leave a space between them like:

    playerWhitelist: 'g:Admins Trusted'

    Or ist there a "," between them or something?

  28. Hey there, actually im Setting up a server and try to use Stargate Plugin for Waypoint Teleportation and your Plugin (Multiverse) for Nether creation.

    If I build two portals connecting them with each other using a sign and want to use the portal im teleported to the nether world. Neither i using the wooden pickaxe or Obsidian for building up portals. If i use either Multiverse or Stargate alone, everything still fine but if I you both at the same time they mix up.

    Any ideas? I want Stargate for Waypoint teleportation only and Multivese only for Nether.

    A quick suggestion: If you build up portals with multiverse it would be cool if you would add teleportation material (ID: 90) So you may see a Portal more easily.

    Excuse my bad english.
  29. I'll probably get crap because it might be in one of the 93 pages of forum, but, I'm having an issue coloring the world name in the chat log. If I specify alias: '&7Survival', then it becomes [&7Survival] in white not grey. If I specify in iChat [&7+world&f] it works, however I cannot get rid of the one Multiverse places as well. So if alias: '' (blank) I get [Survival][Survival] at the beginning, the first one being white and the one I don't want, and the second one being grey and the one I want. How can I prevent Multiverse from placing the world in front of text or specify a color for the alias?

    alias: '' being in Worlds.yml
  30. It is a ,

    So If you wanted admins and mods, this would be what the file looks like:
    Also remember that the user must be in the group specified in that world. Via my config file, If i'm an Admin in world, and just a Default in world2, I will not be able to enter.
    colddemon likes this.
  31. Offline


    This mod is making me feel like an idiot... I can't figure out how to do it right!
    Right now I'm trying to set up a basic netherworld that can travel back and forth. I built a portal and set it to act as a SSP netherportal in the config file and it brought me to the nether (where I almost pissed myself when the floor in front of me exploded. (wtb SMP graphics, lol))
    I couldn't come back so I used the wooden pick to set up the portal and named it "CathedralNethertoWorld" and set it to go to wold, but I didn't have a portal for the original at the time so I just got sent to the spawn point. I went back to the original portal and set it as "CathedralWorldtoNether".

    Now I have no idea how to connect the portals together... here's what I tried to my best understanding from the instructions.
    /mvps CathedralWorldtoNether
    *CathedralWorldtoNether - Portal Selected*
    /mvpd CathedralNethertoWorld
    *nothing happens*
    so i tried to do the select command again and did this instead
    /mvpd CathedralNethertoWorld w:Nether
    *nothing happens*

    Aahhh, I'm sorry if I'm slow :(... I'm gonna go see if I can find any youtube tutorials, but if someone can answer, that'd be awesome :D.

    Ah, okay I'm retarded... I need to set the destination as p:[portal destination] not just the portal name in the world....

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016

Share This Page