[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. Offline


    Ohh. Thanks for the help but know im having trouble setting whether or not mobs can spawn. Also, is there a way to make plugins specific for certain worlds
  3. Offline


    I have this issue, just with players falling large heights (I have an arena that has long drops). Is there an issue with MultiVerse that it just is overly restrictive on movement, or is this a 1.5 necessary restriction?
  4. Offline


    it is 1.5 but the way either multiverse or command book deals with putting players to spawn causes the hack warning, the fix though is linked in my post (but for plugin devs only, we mere mortals cant fix it lol)
    RomaClanServer likes this.
  5. Offline

    Psycho Robot

    User permissions. You can create multiple permissions files, for example, world1.yml, world2.yml, etc. They will have to be named after your world names, however. With that system, you can allow someone to use a plugin on one world, but not give them permission on another.
  6. Offline


    Latest recommended build and latest Multiverse.... something is stopping my pig_zombies from spawning in my nether. There are ghasts but no piggies. I killed all (spawnmob kill all) creatures in my all worlds (4 total) in case it was the mob count. I tried sleeping in bed to reset things... I could not get out of bed in the nether... Weird. Otherwise, working fine for everything else.
  7. Offline


    Why does mobs and animals spawn although i disabled them in the world.YML file?
  8. Offline


    I've got a tricky question. I am running five worlds on my server with permissions. When I tp between these worlds there isn't created an player.dat in the worlds player folder. And because of this I don't receive any group from permissions which in turn makes me unable to tp to another world. Is there a way to fix this or do I have to restart my server five times with the corresponding world name in the server.properties file ? It's a little troublesome since we are five players on this server. Thanks in advance and awesome plugin. [diamond]
  9. Offline


    Create a permissions file for each of the worlds (except the default world) with this
            system: default
            copies: world
    Change copies: world so that is has the name of your main world, permissions will then clone the permissions of the main world for your other worlds allowing you to continue to use MultiVerse commands to move around without restarts
    Yetzirah likes this.
  10. Offline


    Thank you! [diamond][diamond][diamond]
  11. Offline


    I'm not sure if this is a known problem or not but Ive used multiverse for awhile now and had no problems. Earlier today I installed "herochat" and now when someone dies, the counsel shows an error from multiverse an it kicks the player after they die. I really dont want to delete MV or hero chat. both plugins are very well liked on my server.
  12. Offline


    How do you whitelist a world exactly? I don't see anything about it on the OP.
  13. Offline


    Everytime I edit a block by placing, removing or even just pressing right click itself, it tells me "You cannot do that in this world!"
    Is there any methods to remove this?
  14. Offline


    I'm sorry if this has been brought up recently, but here is the problem I'm having with RB740 and the newest jar of Multiverse.

    2011-04-30 22:34:48 [SEVERE] Could not pass event PLAYER_MOVE to MultiVerse
    at com.onarandombox.Rigby.MultiVerse.MVPlayerListener.onPlayerMove(MVPlayerListener.java:212)
    at org.bukkit.plugin.java.JavaPluginLoader$7.execute(JavaPluginLoader.java:242)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:257)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:130)
    at net.minecraft.server.Packet10Flying.a(SourceFile:126)
    at net.minecraft.server.NetworkManager.a(NetworkManager.java:195)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:74)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:370)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:285)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    Any suggestions?
  15. Offline


    @Rigby90 i am running CB build 740 with the latest multiverse but sometimes my nether gates stop working for no reason and alot later they work again and no console errors
  16. Offline


    I'd like to put in my bug report for MultiVerse 1.6.3 and CB #740. When my players are attempting to go through portals, I'm getting this error on the console:
    2011-04-30 23:40:05 [SEVERE] Could not pass event PLAYER_MOVE to MultiVerse
    while parsing a block mapping
     in "<reader>", line 5, column 1:
    expected <block end>, but found BlockMappingStart
     in "<reader>", line 278, column 4:
           wooky2468: #04/29/2011
            at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingKey.produce(ParserImpl.java:576)
            at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:163)
            at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:148)
            at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:228)
            at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
            at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:122)Okay.
            at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:105)
            at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:124)
            at org.yaml.snakeyaml.Yaml.load(Yaml.java:264)
            at com.nijiko.configuration.NotNullConfiguration.load(NotNullConfiguration.java:58)
            at com.nijiko.permissions.Control.load(Control.java:140)
            at com.nijiko.permissions.Control.loadWorld(Control.java:105)
            at com.nijiko.permissions.Control.getGroup(Control.java:524)
  17. Offline


    Any chance of being able to assign Groups to Portals/worlds? this would be immensely useful!
  18. Offline


    Hey guys. I have a little big problem...
    I installed Bukkit, Multiverse plugin and Permissions to run it in my server. I've followed the instructions on some videos on Youtube and everything seems to be working except for one crucial thing. The "Wand" (default wooden pickaxe) doesn't do what it's supposed to do. I click both mouse buttons but I get no message. I tried to change the wand to another item (88 = feather). and even change the portal material (4 = cobblestone) but nothing changed. I have admin permissions because I already made the Nether world.
    Am I missing something? Tried to google about this problem but it looks like I'm the only one with this problem. I apreciate your help. Thanks.
  19. Offline


    I neeed help Im running a private server and when I teleport from worlds the lag in the other world is massive and uncontrolable, Im running a 6 slot from brohosters.
  20. Offline


    That is because the server is trying to unload up to 441 chunks from the world you are leaving and load up to 441 chunks in the new world
    I've run 12 and 24 slot servers from brohoster and the lag is still there, there is no real way to combat it
  21. Offline


    I disable monster and pvp in a single world and have it on in all the other ones. But that world still spawns mobs at night and you are still able to attack other players,what may be the cause of this problem?
  22. Ahhhhh so many replies in 2 days! I'll be reading these and updating this post as I come to them, sorry for being so slow, you guys reply too fast!

    I'm Investigating your issue first. I have reproduced the bug and am looking into it.
    Don't think so right now, maybe in 2.X. I'll throw it in the feature tracker.
    EDIT: Portals, no, worlds yes
    Here is an example config that only lets Admins into world2:

    Each plugin has the choice to support or not support multi-world. Most do though...

    I cannot reproduce this error. Could you walk me through how you're getting it? I am not using command book, so the error may be there...

    I'll investigate and get back to you.
    EDIT: Nope. I can confirm this one as false. Maybe you haven't explored enough? Steps to produce on a fresh server:
    1. type "/mvcreate nether nether"
    2. type "/mvtp nether"
    3. looked around, saw pigmen, everywhere.

    Maybe you have a mobblocker?(There have been several cases of this on my other plugin WolfPound)

    Are you using other plugins that conflict with the wand(sounds like this is not the case but I figured I'd ask)?
    Are there any errors in the console?
    What version of MultiVerse?
    What version of CB?

    This is not a bug. You have something wrong in your yml file (Looks like either permissions or multiverse.yml) Please post both of those on pastebin.

    Been seeing this error for a while, but so far no one has been able to give me good directions to reproduce it. I need something like this:

    1. I Start my server
    2. I type "/mvcreate world2 normal"
    3. I type "/mvtp world2"
    etc until you see the error.

    Time for a new post... that other one was getting too long...

    Um... so what's the error? It's impossible to help without it. (Sorry about the rant, please post error messages when you receive them along with versions of CB and the plugin)
    EDIT: Tested and Passed (ie, I could not reproduce) with:
    CB 740
    MV 1.6.3
    HeroChat 4.10.3
    LightLevel .2
    WolfPound .12
    iConomy 4.6.5
    Permissions 2.7

    Not really sure, could you give me some more details? Maybe post your config files? Did you try using /mvmodify?

    Alright, so I have made a very small patch to remove the "you have been charged with $0.0" and fixed a rounding error causing the other one (1.6.4 should be out soon, but if you want to try now you can build from source, the fernferret branch), but I could only get these messages to show up when I had iconomy set to true, even with your config these messages did not show up.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  23. Offline


    Thanks for that assessment fernferret. An admin of mine didn't put a space where he should have in the nethworld.yml Permissions file. It's fixed now. :)
  24. No problem, glad it's working!

    As a side note to everyone else, I should be chilling in the multiverse irc channel on espernet, maybe that will reduce the number of enormous replies I have...
  25. Offline



    So no word on my unusually big issue with the nether turning into a normal world.

    I dont know what else im to provide, ive given you all the errors ive received. I really would love to troubleshoot and get this issue resolved.
  26. Offline


    Other plugins can cause the nether to load before MultiVerse so they assume it's a normal world
    AncientGates in particular is a jackass for this, try disabling any multiworld plugins that affect the world itself then when your nether starts working rename that plugin to xPluginname.jar
  27. Offline


    Yes what happens is it makes a region folder with the mc region files in it, normally nethers region files are in a dim folder. Then when i do /mvlist the worlds name is in green. this may be the issue, i,ll try it! thank you.
  28. I'm in irc, if you hop in there we can see if we can get it resolved (EsperNet #multiverse)
  29. Offline


    I cant atm, but if your on often perhaps tomorrow when i have time. I want to take a day of testing anyways to see if having multiverse load first fixes my problem.
  30. Offline


    i really like this plugin only thing it was working without permissions now it doesnt and i have group manager would it be possible for it to work with both or not at all like us the op file
  31. i also have this, and portals do not work because of it :confused:
    is there any chance we could get a fix?

Share This Page