[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. Offline


  3. Offline


    Any way to add the ability to enter a custom seed for a new world?
  4. Offline


    I'm not asking about /mvtp, but about /mvtpt :

        description: Command to teleport between Worlds
        usage: /<command>
        description: Command to teleport a target to a World/Portal
        usage: /<command>
    It does nothing when I type /mvtpt...
  5. Offline


    Having a strange issue with permissions. Server build with Bukkit 670, Essentials .29 with GroupManager and GroupBridge. and MultiVerse 1.6.2.

    Tested locally to a Windows 7 machine, works perfectly. Copied up to live unix server and all the Multiverse commands give the error "Permissions 2.1 hasnt been enabled". Permissions system is working fine for everthing else so problem is just with Multiverse recognising the fake Permissions plugin, but only on the unix box. :confused:

    Anybody got any ideas?
  6. Offline

    Antari Adul

    fixed, just had to remove essentialsgroupbridge.jar because it would only work if you could have permission 2.1 and permissions 2.6
  7. Offline


    I got this error right after a GIANT lag spike almost shut my server down... is this because of your plugin, or a result of some other force? Perhaps it does not agree with epiczones, even?

    I am using CB: 670, and Multiverse 1.6.2 (current)

  8. Offline


    This plugin consumes so much CPU, but all becomes ok when I turn it off.
    I have tried to leave only one MultiVerse in plugins, and yeah it eating whole my CPU :\
    And when I leave ALL my plugins (×8) bukkit eating just 3% of CPU.
    What I should to do, is it a bug?
    Ready to testing betas
    found problem: six worlds is a problem, I leave just one and cpu usage had fallen to 3~5%
  9. Offline


    hen i try to import i get this

  10. Offline


    I think he's talking about the vanilla commands. Which is my problem as well. But I don't see any reason not to just get a commands plugin to fix it.
  11. Offline

    Celtic Minstrel

    Oh. I'm not entirely sure how the vanilla time command works, but it likely doesn't support multiworld.
  12. Offline


    says im not allowed .. im using permissions ....im the host of the server .. where im i meant to chang ethe options ????so that im allowed ?
  13. Offline


    Is it possible to set it so , that every world a own inventory has. ( Sorry for bad english ). Can anybody understand that?
  14. Offline


    I have these options:

    globalrespawns: true
    alternaterespawns: true
    respawntodefault: false

    but I do not respawn to the place I /mvsetspawn
    /mvspawn works just fine to teleport back to the spawn I set, but respawning on death does not work, it's as if it doesn't hook properly, or does not reset the actual worlds respawn location. I would *like* if /mvsetspawn wrote the new spawn coords to the mapfile in case the plugin was ever removed.
  15. Offline


    It does not, /time will ALWAYS apply to your default world
  16. Offline

    Celtic Minstrel

    This does not surprise me one bit.

    What do you mean by "does not work"? Do you respawn back in the default world? Or do you respawn at the spawn point of the world you died in? Which behaviour is it that you want?
  17. Offline


    @Celtic Minstrel - it respawns to the original world default spawn location that bukkit made with the world NOT the spawn location set by /mvsetspawn - I thought that's what it was supposed to do...
  18. Offline


    any chance of adding a configurable time delay to the /mvtp and /mvspawn commands? I don't want my players using them to escape certain death situations... my normal /warp and /spawn commands have a 5 second wait period.. so that they cant jip out on a fight.
  19. Offline

    Celtic Minstrel

    I think /mvsetspawn only sets the spawn point for the current world, not the respawn point for after death. There might be an option or another plugin to change that. I'm not sure really. Sorry.
  20. Offline


    • I got the portals to work so when I enter them, I appear at the corresponding portal (using the p : Portalname command), but I appear next to the portal rather than in front of it... Sometimes I appear several meters behind the portal. Is there a way to specify where in relation to a portal the p : Portalname command will spawn you? Thanks for the great plugin by the way.
  21. Offline


    Really?? How?? :O
    When ever i try it just shuts itself :S
  22. Offline


    I get this when importing a world

  23. Offline


    Yes...create the world, turn off the server, edit the seed in level.dat with NBT edit, delete the region files in the region folder (to get rid of chunks generated with the old seed), start the server, TP to the world, wait for some of it to load (will take quite a long time), and finally restart the server. It will fix the new world and it will have the seed you put in level.dat

    You make the portal any shape, size, or material. Just note that the blocks you left and right click on with the magic wand are the blocks the portal will be IN, so if you want a portal inside of a fenced area, click on the opposite corner fence posts and not opposite corner dirt blocks.
  24. Offline


    I'm having trouble to get mobs to spawn in "Kanto" but not in my nether. Am I missing something?
            animals: true
            spawn: -228:71:89:0.0:0.0
            price: 0.0
            mobs: false
            environment: NORMAL
            pvp: true
            alias: ''
            worldBlacklist: ''
            playerBlacklist: ''
            playerWhitelist: ''
            editWhitelist: ''
            editBlacklist: ''
            blockBlacklist: ''
            animals: true
            spawn: 17:56:-66:266.55038:17.549944
            price: 0.0
            mobs: true
            environment: NETHER
            pvp: true
            alias: ''
            worldBlacklist: ''
            playerBlacklist: ''
            playerWhitelist: ''
            editWhitelist: ''
            editBlacklist: ''
            blockBlacklist: ''
            animals: true
            spawn: 28:70:14:-80.70005:3.1500049
            price: 0.0
            mobs: true
            environment: NORMAL
            pvp: true
            alias: ''
            worldBlacklist: ''
            playerBlacklist: ''
            playerWhitelist: ''
            editWhitelist: ''
            editBlacklist: ''
            blockBlacklist: ''
  25. Offline

    Zach Hinchy

    I get this error whenever I use any of MultiVerse's commands. I'm not sure if this is caused by MultiVerse (it kinda seems like it could be a Permissions error) but I'm going to post it in both places to be safe.

    Using CB670, rcjrrjcr's Permissions 2.6, and MultiVerse 1.6.2.

    22:42:34 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'mvimport' in plugin MultiVerse v1.6.2
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
            at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:80)
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:254)
            at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:596)
            at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:559)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:553)
            at net.minecraft.server.Packet3Chat.a(SourceFile:24)
            at net.minecraft.server.NetworkManager.a(NetworkManager.java:198)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:72)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:368)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:375)
    Caused by: java.lang.LinkageError: com/nijiko/permissions/PermissionHandler
            at com.onarandombox.Rigby.MultiVerse.MultiVerse.onCommand(MultiVerse.java:220)
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
            ... 12 more
  26. Offline


    I'm running GroupManager with the FakePermissions, but your plugin fails to recognize it and say "Permissions 2.1 is not Enabled". Please fix, it is breaking my server.
  27. Offline


    Your nether mobs value is true, switch that to false and give yourself a pat on the back

    Possible stupid answer, stop your server then start it again, another plugin I use had a similar error when I firsr loaded it via /reload, after I restarted it worked fine
  28. Offline


    I not sure that is going to help him get mobs to spawn in Kanto.
  29. Offline


    Misread the post, in my defence it is 4 am here
  30. Offline


    I see what I did now, I did not have monsters set to true in my server properties. Doing this fixed the spawning of mobs.
  31. Offline

    Zach Hinchy

    I wish! I've restarted it too many times to count.

Share This Page