[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. Offline


    is there anyway I can use this or something similar without needing permissions? we've had our differences in the past. haha :) I have multiple worlds saved that i would like to load into my server and teleport to them. Anyone help please?

    Edit: I came across a plugin request asking for the same thing.
    Developers could you please check this out and consider it? :D
  3. Offline


    wow really late response from me.. well first, thanks for answering so quickly, and now i tried again... how u said to, but it still has the same problem.. i have everything updated.. all the version and everything... after the new minecraft came out. so im pretty sure my whole server is up to date. but i still cant get multiverse to allow me to make a world. on permissions... i put my name. and then put myself as an admin. and then on permissions i put '*' and thats it. i tried to do it with and without the '*' please help
  4. Offline


    I need some help here. I've created a nether world named "nether", i've build an obsidian portal, how do I make the obsidian portal transport me to the nether? I just want it to work how it normally does in singleplayer, no different
  5. Offline


    Ok I'm having one issue, it may be minor to you, but it's crippling the mod for me. When I go and edit the config for the worlds (I turn mobs and animals off because they lag my server), restart the server, console tells me there is a mapping error or something like that and points to a ":" in the console. I double check that I have it spelled right and i don't change the number of spaces. Also, the config file is a bit messy for my tastes. Is there a way to have it all "vertical"?


    Animals: True
    PVP: True
  6. Offline


    05:00:43 [SEVERE] Nag author: 'Rigby' of 'MultiVerse' about the following: onPlu
    ginEnable has been replaced with a new signature, (PluginEnableEvent)
  7. Offline


    I got the same problem, the chunk just never load but it appears to do that randomly...
  8. Offline


    how the heck do you make portals? come on does anyone know @_@ why doesn't this thing have a readme?
  9. Offline


    2011-04-08 09:56:33 [WARNING] Failed to handle packet: java.lang.IllegalStateException: Entity is already tracked!
    java.lang.IllegalStateException: Entity is already tracked!
    	at net.minecraft.server.EntityTracker.a(EntityTracker.java:72)
    	at net.minecraft.server.EntityTracker.a(EntityTracker.java:62)
    	at net.minecraft.server.EntityTracker.a(EntityTracker.java:51)
    	at net.minecraft.server.WorldManager.a(WorldManager.java:17)
    	at net.minecraft.server.World.b(World.java:750)
    	at net.minecraft.server.WorldServer.b(WorldServer.java:94)
    	at net.minecraft.server.World.a(World.java:1590)
    	at net.minecraft.server.Chunk.d(Chunk.java:470)
    	at net.minecraft.server.ChunkProviderServer.c(ChunkProviderServer.java:75)
    	at net.minecraft.server.PlayerInstance.<init>(PlayerInstance.java:33)
    	at net.minecraft.server.PlayerManager.a(PlayerManager.java:37)
    	at net.minecraft.server.PlayerManager.a(PlayerManager.java:76)
    	at net.minecraft.server.ServerConfigurationManager.a(ServerConfigurationManager.java:106)
    	at net.minecraft.server.NetLoginHandler.b(NetLoginHandler.java:87)
    	at net.minecraft.server.NetLoginHandler.a(NetLoginHandler.java:27)
    	at net.minecraft.server.NetworkListenThread.a(SourceFile:87)
    	at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:368)
    	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
    	at net.minecraft.server.ThreadServerApplication.run(SourceFile:375)
    Is this from multiverse? Normally its easy to see which plugin its coming from, but this im not sure of.
  10. Offline


    It's pretty clearly described if you bother to READ THE FIRST POST.

  11. Offline


    I have troubles using a nether world as a second world. It's the first time I use this plugin so I don't know if I'm just doing something wrong here.
    Bukkit Version: 670 (git-Bukkit-0.0.0-646-gb61ef8c-b670jnks)
    MultiVerse Version: 1.6.2
    Permissions: 2.5.5

    My server had one world: world.
    I installed the plugin, entered the server and created a new netherworld: /mvcreate nether NETHER
    World got created just fine, and I can freely move between the world with /mvtp nether and /mvtp world.

    The problem starts on server restart:
    The first world loads fine, but the nether gets destroyed. I can still use /mvtp nether, but it will transfer me to another newly created normal non-nether world.

    Checked the logs and saw no errors but it seems like it created a new world called "nether" which replaced the ingame created "nether" world.

    If I remove the nether world and create a new one it's fine again until the next server restart.

    Any Ideas what's going on here?
  12. Offline


    Next version won't require Permissions instead it would default to isOP() if no Permissions plugin is found.

    YAML Syntax error, nothing to do with the plugin from what you're saying there. Try running it through an online YAML Syntax Checker. Feel free to pastebin the config for me or anyone else to see, however I'm only about for a few more hours.

    Also what do you mean by 'vertical'??? If you mean split up the location into individual lines of x y z yaw pitch etc... then it will be in the next version, if that's not what you mean then can you explain?

    Just a heads up guys... I've finished most of the work which was preventing me from working on the plugin...

    However I am now heading away for 4-5 Days and such so I will be unable to respond to any problems (tbh not that I have been that active lately) and I won't be able to fix any issues that may arise.

    Hopefully @fernferret can lend me a hand here if he's still willing to, if so then feel free to make any changes you deem necessary whilst I'm away. Good news though... I intend to finish the new version within the next few weeks.

    Also I'd like to quickly say thanks to all the other developers and users which have been responding to help requests and such within the topic & IRC, it is greatly appreciated and tbh I would of been doomed without you.

    Special thanks to @fernferret @Celtic Minstrel @petteyg359 @Itssnowing and everyone else who has been actively helping people on IRC and in this Topic. - Sorry if I've missed anyone out.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
    grandwazir and Smallie07 like this.
  13. Offline


  14. Offline


    Just an FYI: this works on 670
  15. Offline


  16. I always get this when I start the server:
    2011-04-08 18:59:03 [SEVERE] Nag author: 'Rigby' of 'MultiVerse' about the following: onPluginEnable has been replaced with a new signature, (PluginEnableEvent)
    MultiVerse works fine, but I still want to know what this message mean.
  17. Offline


    It means PluginEvent changed to PluginEnableEvent. It isn't broken yet, and 2.0 will probably be out before it actually gets broken.
    FIX94 likes this.
  18. @Rigby90

    No problem, again, I'll only be making bugfixes to the 1.x, can't wait for 2.0!

    I did have a TINY fix, which was just the warning about Permissions 2.1, changed to Permissions 2.5.5. But It's not worth pushing a new version unless there are bug fixes!

    Thanks for all your hard work @Rigby90!
    (and the other guys who help out here!)

    I'll get a pull request setup for that Nag.
  19. Thanks for the explaination, good to hear it's no problem with the plugin or craftbukkit, only such a small change.
  20. Offline


    Is it possible to deny that the player can teleport there inventory between the worlds? I've startet a new world, but it's boring when you can bring all you good stuff from the old world to it. That would make the Plugin perfect :). Thanks.
  21. This has already been discussed, there is another plugin for this: MultiInv.
  22. Offline


    I just updated to CB 670 and the current MV 1.6.2 and started getting this message at startup:
    2011-04-08 11:31:18 [SEVERE] Entity is already tracked! loading MultiVerse v1.6.2 (Is it up to date?)
    java.lang.IllegalStateException: Entity is already tracked!
        at net.minecraft.server.EntityTracker.a(EntityTracker.java:72)
        at net.minecraft.server.EntityTracker.a(EntityTracker.java:62)
        at net.minecraft.server.EntityTracker.a(EntityTracker.java:51)
        at net.minecraft.server.WorldManager.a(WorldManager.java:17)
        at net.minecraft.server.World.b(World.java:750)
        at net.minecraft.server.WorldServer.b(WorldServer.java:94)
        at net.minecraft.server.World.a(World.java:1590)
        at net.minecraft.server.Chunk.d(Chunk.java:470)
        at net.minecraft.server.ChunkProviderServer.c(ChunkProviderServer.java:75)
        at org.bukkit.craftbukkit.CraftServer.createWorld(CraftServer.java:342)
        at org.bukkit.craftbukkit.CraftServer.createWorld(CraftServer.java:294)
        at com.onarandombox.Rigby.MultiVerse.MultiVerse.loadWorlds(MultiVerse.java:418)
        at com.onarandombox.Rigby.MultiVerse.MultiVerse.onEnable(MultiVerse.java:158)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:127)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:578)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:216)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:115)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:93)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:215)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:202)
        at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:142)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:257)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:375)
  23. Offline


    yeah, first read than "speak". I've found it by my own, 10 seconds after my post. So, sorry and thank you.
  24. Offline


    Does it work with group manager? Because he says: Cant find permissions 2.1
  25. Offline


    Show Spoiler

    I guess since Rigby90 and fernferret posted in the meantime my own got missed.
    Am I really the only one having troubles on server restarts?
  26. I'll look into it.
    @Liger_XT5 - I know this is an odd request, but could you re-download the jar? I looked at the source where your error is, and uh it's a comment :p Also, could you dump your entire startup config to pastebin for me?
    No. It works with permissions 2.5.5+

    That message about not finding 2.1 has been fixed for the next release

    EDIT: I reread this, and it makes me sound rude. I appologize. Took me forever to find the Group Manager thread, and that plugin is basically abandoned, does not even support 602, so, sorry, looks like Permissions 2.X is what's the dominate plugin right now. (For the record, i'm a Permissions fanboy)

    For kicks, after you restart, try doing an /mvlist

    If that shows only one world, do an /mvimport nether NETHER

    Let me know.

    EDIT: For those of you wanting to know about the NAG SEVERE messages, they have all been fixed in 1.6.3, but ATM the ONLY thing 1.6.3 has is a typo fix and these nag fixes. No reason to push it right now!
  27. Offline


    Weird, yesterday with build 612 (And an Old release of this plugin ) , does it works fine with group manager?
  28. I don't have problems with groupmanager (using latest 1.0alpha5 with fake permissions 2.5.1)
    2011-04-08 19:02:23 [INFO] GroupManager - INFO - Scheduled Data Saving is set for every 120 minutes!
    2011-04-08 19:02:23 [INFO] GroupManager version 1.0(alpha-5) is enabled!
    2011-04-08 19:02:23 [INFO] Fake Permissions version 2.5.1 is enabled!
    2011-04-08 19:06:32 [INFO] [MultiVerse] Permissions Found
    2011-04-08 19:06:32 [INFO] [MultiVerse] - Version 1.6.2 Enabled
    2011-04-08 19:06:32 [INFO] [MultiVerse] Loading World & Settings - 'world' - NORMAL
    2011-04-08 19:06:32 [INFO] [MultiVerse] Loading World & Settings - 'letsplay' - NORMAL
    2011-04-08 19:06:33 [INFO] [MultiVerse] 2 - World(s) loaded.
    2011-04-08 19:06:33 [INFO] [MultiVerse] Loading Portals
    2011-04-08 19:06:33 [INFO] [MultiVerse] 0 - Portal(s) loaded.
    2011-04-08 19:06:33 [SEVERE] Nag author: 'Rigby' of 'MultiVerse' about the following: onPluginEnable has been replaced with a new signature, (PluginEnableEvent)
  29. Offline


    does anyone know why i am not spawning at the spawn point that i set? when i use /mvspawn it works correctly but when i die i get sent to the old spawn point
  30. Maybe it does, and this is fine, but the requirements of the plugin state the use of Permissions, and since GroupManager has not been updated for 6XX(let alone 670) I am not going to advocate its use.

    What other plugins are you using? Any interesting console logs? (I just tested this with CB 670 and MV 1.6.2 and it works great for me)

Share This Page