[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. Offline


    oh my god, it works with permissions 2.4 my server is saved! Amazing plugin!
  3. Offline


    lmao. Tell me about it.. I want to move from version 1.1 :O But I don't think its going to be possible. I sit here all day planning and making suggestions and requests but really only gets as far as my test server.
  4. Offline


    I'm running into issues with the essentials home and worldguard plugins when used in conjunction with this plugin. it seems as though homes and regions ignore which world you are in. basically if i protect a region in one world using worldguard, the area with the corresponding coordinates in the other world(s) are recognized as being the same region. Also if I set my home to anywhere in a world that's not the one in server.properties, it just sets my home to the same coordinates but in the world defined in server.properties. I'm using MultiVerse v1.4 - Permissions 2.0 with groupmanager on cb 440.

    My guess is that essentials and worldguard/worldedit need to check which world the player is in and take that into account before processing /region and /sethome (probably among others) But I'm not sure. Is this a MultiVerse issue or a essentials and worldguard/worldedit issue?

    I've poked around the forums a bit but couldn't really find any other reference to this problem. I can't be the only one trying this setup can I?
  5. Offline


    Whenever a portal is used.

    SEVERE] Could not pass event PLAYER_MOVE to MultiVerse
    java.lang.NoSuchMethodError: com.nijikokun.bukkit.iConomy.Database.get_balance(Ljava/lang/String;)I
    at com.onarandombox.Rigby.MultiVerse.MVPlayerListener.onPlayerMove(MVPlayerListener.java:312)
    at org.bukkit.plugin.java.JavaPluginLoader$8.execute(JavaPluginLoader.java:165)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:225)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:115)
    at net.minecraft.server.Packet10Flying.a(SourceFile:126)
    at net.minecraft.server.NetworkManager.a(SourceFile:230)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:70)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:338)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:253)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Am I doing something wrong
  6. Offline


    It's an issue with those plugins, or at least it was... I'm pretty sure they updated to support MultiWorld, are you sure you have the latest version of each plugin?
    --- merged: Feb 28, 2011 7:27 AM ---
    This is to do with iConomy, have you got iConomy if so what version?

    It doesn't support iConomy 3 or 4 yet...
  7. Offline


    I have 3... - If I set iconomy to false in the settings will it stop this and when are you going to support 3.0+ ( I am not begging just wondering)
  8. Offline


    Yeh set it to false in the config shud stop the errors, ermm in the current setup never. (Working on different setup for MV)

    Also with iConomy 4.0 out I'll probaly just skip iConomy 3 support.
  9. Offline


    I'm running Essentials 2.0B, WorldEdit 4.0beta8 and WorldGuard 4.0alpha1 all the latest versions.

    EDIT: I'll pursue this in the other respective threads
  10. Offline


  11. Offline


    2011-02-28 13:06:52 [SEVERE]     at com.earth2me.essentials.User.teleportToNow(User.java:687)
    2011-02-28 13:06:52 [SEVERE]     at com.earth2me.essentials.User.teleportTo(User.java:510)
    2011-02-28 13:06:52 [SEVERE]     at com.earth2me.essentials.User.respawn(User.java:774)
    2011-02-28 13:06:52 [SEVERE]     at com.earth2me.essentials.User.respawn(User.java:779)
    2011-02-28 13:06:52 [SEVERE]     at com.earth2me.essentials.spawn.EssentialsSpawnPlayerListener.onPlayerRespawn(EssentialsSpawnPlayerListener.java:19)
    That's an Essentials problem, chances are you still have the Essentials multiworld crap enabled... either that or theres an error in its respawn section.
  12. Offline


    yeah how to solved it ?
  13. Offline


    Not sure it's not my plugin, you're going to wan't to moan to Zenexer and such or place a bug report on their website. Check the Essentials thread for more details.
  14. Offline


    k thanks :)
  15. Offline


    Awesome & Friendly reminder:

    Player exemptions - multiverse.vip - for skipping payments on portals ;)
  16. Offline


    Hilarious! I've discovered something interesting. My friend was in his world and I was in mine. A creeper went off in his world and I could see the explosion in mine! The blocks came back after just a few seconds but it was WILD to see. Has anyone else reported this?
  17. Offline


    Ok, this is going to sounds retarded...
    Can you tell me in more detail how to use portals? I selected 2 places on the ground using the wood pickaxe, used the /mvpc command, but i don't seem to be able to use my portal :/
  18. Rigby, It seems that Nether auto-portal creation and return portals in general isn't working. (Ie, nothing happens when you stand in return portal)
    Config has correct name for the default world, auto creation is on, using recommended craftbukkit build.
  19. Offline

    Tyler Ferm

    Craftbukkit build 452 what is this? please help.

    14:30:23 [SEVERE] Could not load plugins\MultiInv_1.1.4.jar in plugins: null
            at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.j
            at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.
            at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:59)
            at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:204)
            at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:191)
            at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:131)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:246)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Caused by: java.lang.NoSuchMethodException: uk.co.tggl.Pluckerpluck.MultiInv.Mul
            at java.lang.Class.getConstructor0(Unknown Source)
            at java.lang.Class.getConstructor(Unknown Source)
            at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.j
            ... 8 more
  20. Offline



    Looks like an error with mutli inventory, not multiverse
  21. Offline


    Getting console spam and massive lag if a player who died on an alternate world attempts to respawn. This also prevents the player in question from actually respawning - anyone who dies in an alternate world is essentially permanently dead.

    Spam is:

    2011-02-28 21:02:28 [SEVERE] java.lang.IllegalStateException: Failed to remove player. net.minecraft.server.EntityPlayer@111a isn't in chunk 7, -6
    2011-02-28 21:02:28 [SEVERE] at net.minecraft.server.PlayerInstance.b(PlayerInstance.java:49)
    2011-02-28 21:02:28 [SEVERE] at net.minecraft.server.PlayerManager.b(PlayerManager.java:101)
    2011-02-28 21:02:28 [SEVERE] at org.bukkit.craftbukkit.entity.CraftPlayer.teleportTo(CraftPlayer.java:173)
    2011-02-28 21:02:28 [SEVERE] at com.onarandombox.Rigby.MultiVerse.MVPlayerListener.onPlayerRespawn(MVPlayerListener.java:157)
    2011-02-28 21:02:28 [SEVERE] at org.bukkit.plugin.java.JavaPluginLoader$3.execute(JavaPluginLoader.java:135)
    2011-02-28 21:02:28 [SEVERE] at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
    2011-02-28 21:02:28 [SEVERE] at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:225)
    2011-02-28 21:02:28 [SEVERE] at net.minecraft.server.ServerConfigurationManager.d(ServerConfigurationManager.java:183)
    2011-02-28 21:02:28 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:729)
    2011-02-28 21:02:28 [SEVERE] at net.minecraft.server.Packet9Respawn.a(SourceFile:10)
    2011-02-28 21:02:28 [SEVERE] at net.minecraft.server.NetworkManager.a(SourceFile:230)
    2011-02-28 21:02:28 [SEVERE] at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    2011-02-28 21:02:28 [SEVERE] at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    2011-02-28 21:02:28 [SEVERE] at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:357)
    2011-02-28 21:02:28 [SEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:272)
    2011-02-28 21:02:28 [SEVERE] at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Repeated with changes in the chunk for about 10-15 seconds. Was using essentials, removed it as suggested in other threads but the problem is still there. Not using other plugins that would have a significant effect on MV, current build is #477.
  22. Offline


    iConomy, a cut of the cost goes to the portal owner (Let me know what you think)
    This would be awesome, but will it work for essentials eco?
  23. Offline


    I'm an admin from this server and we just tried to run with only MV 1.4, Perms 2.4, and Whitelist. The error has persisted. It is a very sad time for everyone involved :(
  24. Offline


    That'd be good in question yes. A 'tax' portion % can go to the "mayor" or "teleport owner" heh.
    --- merged: Feb 28, 2011 10:35 PM ---
    Use the recommended version 440.
  25. Offline


    Yup it's a known issue, singleplayer styled portal support was never meant to be great, somehow teleporting back got broken before releasing it.
    --- merged: Mar 1, 2011 12:21 AM ---
    Not my plugin, try run the recommended build.
    --- merged: Mar 1, 2011 12:22 AM ---
    Now that's strange... can you http://pastebin.com your multiverse.yml file as well as your worlds.yml file. This shouldn't be happening unless another respawn plugin or such is screwing things up, however you said you have none.
    --- merged: Mar 1, 2011 12:26 AM ---
    Regarding the idea, yup it's been noted down previously and I think it's a good idea :).

    Essentials Economy??? Sigh... they're branching out into economy as well? If they arn't then skip the next rant, however if they are =)....

    ...well sorry to say but no it probably won't support it anytime soon... fed up of multiple plugins doing the same job and bulky plugins which seem to think they can steer the user base to using their half assed stuff.

    Apologies if I sound grouchy but lately the plugins which I rely upon have been swapping around like crazy and causing unneeded hassle.
    --- merged: Mar 1, 2011 12:28 AM ---
    Sorry about this, hopefully we can fix the issue... I may be wrong but it seems isolated to just your server. If it comes to it you can always zip up your server without the world and sensitive files and I can take a look my end.
  26. Offline


    I'm still getting the portal configuration problems. I've tried updating to Permissions 2.1 and updating to the compatible MV 1.4, but all that does is deny myself any commands at all, and yes, I did assign myself as administrator in config. Whenever I set a portal destination, no confirmation messages come up, and portals don't teleport me to the requested destination.

    For example, typing something like "/mvpc 123" will get me "Portal created, now you need to set a destination", typing "/mvps 123" would get me "123 - Portal Selected" (in other words, these work normally) but any command such as "/mvpc 123" with an included destination, or /mvpd, and I get absoultely no confirmation/error messages at all, and the "destination" section for all portals in the "Portals.yml" file remain at "null".

    Currently the only things on my server are Permissions 2.0 and Multiverse 1.4 (Permisssions 2.0 compatible version). I am an administrator and I'm assigned to use all commands, so there's not much else I can do. Should I post something, or will I just have to sit this out as one of the few with an unfixable problem?
  27. Offline


    Sorry it's just dawned on me... CraftBukkit build 477.... thats with a supposed teleport fix for the chunk updating.... so this means they've changed the way it teleports.

    By any chance does this error occur on the recommended build which the plugin was made against? (Build 440)
    --- merged: Mar 1, 2011 12:35 AM ---
    hmm thats strange, when updating to Permissions 2.1 did you sort out the permissions config by renaming it to the worlds name etc?

    Also have you tried redownloading 1.4? Maybe you have the corrupt version I initially uploaded.

    Apart from that I can't see why some part of it works, but then the others dont. Will need to look into it.
  28. Offline


    Sure doesn't. We figured that would be a problem, and sure enough~
  29. Offline


    hmm that's not good then... I'll need to download 477 and do some testing then...

    Dinnerbone mentioned the fix for the chunk issues etc was... changing the teleport so that when you teleport the player now.... the player is effectively KILLED then RESPAWNED in the new location... I think the problem is.... because the player is already dead... he cant be KILLED and RESPAWNED.
  30. Offline


    Yeah, the 1.4 I tried both ways were downloaded today, literally in the past couple of hours. And I did rename it to the world names, but it just didn't want to recognize me.

    Could it be that I'm running my server through a Linux VPS? I can't say it's ever affected anything before like this, but the more info, the better. :b
  31. Offline


    Seems like there is already a Ticket raised regarding the issue.


    Doesn't look like there's much I can do, I mean theres the possibility of a timed teleport... however thats dangerous and can cause more problems :).
    --- merged: Mar 1, 2011 12:42 AM ---
    Nah the VPS won't be anything to do with it, you can always zip up your server and send it my way.

Share This Page