[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. Offline


    Ok thank, and ahm if i click your account and click on ''Follow'' I will get a message everytime you update this thread, so if you will have a new version from MultiVerse i will get a message for it??????
  3. Offline


    odd because im currently usein permissions 2.0
  4. Offline


    I got bug, Once you enter portal to another world you can break blocks and build ect, if you d/c and relog in, in any world that isn't the original you can't break blocks until you go through the portal again and go back. This is very annoying especially if you are far from the portal. Respawn protection in server.prop is at 0. Any help with this issue would be great.
  5. Offline


    I downloaded the latest version, but its still the same thing. I don't know what to do.
  6. Offline


    My suggestion: add an extra variable to each portal that can be set using syntax like /mvmodify p:MyPortal style:[none|nether|water]
  7. Offline

    Sir Savary

    Nvm, I solved the problem. It turns out that Multi Verse created the nether, but never added it to the worlds.yml file. This explains why the portals did not work. If your portals do not work at all, check the worlds.yml file to make sure there is more than one world, or the world you are trying to go to exists.
  8. Offline


    Okay I read all 28 pages of this post. 1st off let me say "THIS ROCKS" 2nd let me "OH YEAH THIS ROCKS!!"" 3rd I seem to either have missed it in the few posts where I saw it mentioned. The teleporting from normal to nether works great but when I go to teleport back to my normal world it says it can only contain alpha numeric world123 my normal world map name is build_world this world loads with no issues under SMP is there a trick to making this work without me having to renaming my world map?
  9. Offline


    you could make a portal in the "build_world" called "normalworld" at the spawn point (or whereever you want it) and link a portal from the nether to the portal "normalworld" that would work fine.
  10. Offline


    That is a good Idea I will try. I am on my test world right now ( which is a exact copy of my real world ) wanted to work out any possible kinks before i push this life to my production server. Thank you I will try that
  11. Offline


    1.1 works great for me, but 1.2 gives this error:

    2011-02-20 15:16:13 [SEVERE] Feb 20, 2011 3:16:13 PM org.bukkit.craftbukkit.CraftServer loadPlugins
    java.lang.NoSuchFieldError: ENTITY_DAMAGEDBY_PROJECTILE

    using craftbukkit build 402
  12. Offline


    Just updating the thread now, theres now 1.2.1 out just to fix this entity thing...

    For now we shud just be able to ignore the constructor crap, will sort that out in the split, or possibly later on.
  13. Offline


    Thank you so much for 402+ update :D
  14. Offline


    Everything worked perfectly fine, and all the worlds started when I started the server at first, but yesterday they just didn't load when i started the server, so I have to do the /mvimport command when I get into the game every time, and then it always spawn monsters in the Worlds, which I don't want, is there any way to fix this...??
  15. Offline


    anyone else having an issue with creating portals? it tells me the is an internal exception.

    011-02-20 18:13:08 [SEVERE] Feb 20, 2011 6:13:08 PM net.minecraft.server.NetServerHandler c
    SEVERE: null
    org.bukkit.command.CommandException: Unhandled exception executing command 'mvpc' in plugin MultiVerse v1.2.1
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:21)
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:77)
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:171)
    at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:637)
    at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:601)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:593)
    at net.minecraft.server.Packet3Chat.a(SourceFile:24)
    at net.minecraft.server.NetworkManager.a(SourceFile:232)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:78)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:104)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:325)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:240)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:512)
    Caused by: java.lang.NullPointerException
    at com.onarandombox.Rigby.MultiVerse.MVUtils.isPortal(MVUtils.java:321)
    at com.onarandombox.Rigby.MultiVerse.MVCommands.MVPCreate(MVCommands.java:325)
    at com.onarandombox.Rigby.MultiVerse.MultiVerse.onCommand(MultiVerse.java:314)
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:19)
    ... 12 more
  16. Offline


    Can you check the permissions on the files within the MultiVerse folder...

    Also when you load the server up check the contents of Worlds.yml... if it hasnt populated after loading the server then it means theres a permissions problem and it cant save the config to the file.
    --- merged: Feb 21, 2011 12:24 AM ---
    Can you check that the world you are trying to setup the portal to is loaded into the Worlds.yml config?
    --- merged: Feb 21, 2011 12:39 AM ---

    Will have an update out shortly to hopefully prevent this issue.
  17. @Rigby90: Just a suggestion but it's best if you move over to suggesting the recommended craftbukkit builds now.
    In case you missed it:

    Edit: EvilSeph just said I should refer to both recommended and craftbukkit build if I ever have to refer to a build. I've just asked him about what to do with plugin thread titles
  18. Offline


  19. Offline



    I will see I can confrim this broadcasting with the tool sometime today. I also just wanted to note that in our config we have mobs set to false for the mc server.properties and as you already know about nether. its quite odd really.

    Mobs dont on my two normal worlds but only in the nether. I noticed you said that Mobcontrol should not effect anything so I'm going to give it a try if it works for mulitworlds great see if does anything.
  20. Offline


    Thanks for reminding me, going to load up a test server now to check the Nether.
  21. Offline


    oh is it just me or is CB no longer showing a straight build number and now shows its ID number when typing version in console.
    --- merged: Feb 21, 2011 3:42 AM ---
    Im sure I pasted the output of this in a post couple posts up for you as thats the CB build we sticking with for bit longer.
    --- merged: Feb 21, 2011 3:45 AM ---
    Here it is again in case u missed it

    This server is running Craftbukkit version git-Bukkit-"6743361" (MC: 1.2_01)
    This server is also sporting some funky dev build of Bukkit!
  22. Offline


    Ok apart from the 2 Ghasts and couple camps of pigmen which were there from the world creation... there were no other mobs/animals. I ran in one direction for a 5+ minutes and not came across anything, no sound no visible creatures.

    Then I typed "/mvmodify test123 mobs:true", couple seconds later I can hear Ghast noises and camps of Pigmen spawning around me.
  23. Offline


    Is there just a simple way to make this work like the singleplayer nether/portals? Like, 8x distance in Nether, and automatic portal creation in other world? Or can it only be done with wands/signs?
  24. Offline


    There is a Basic Version of SinglePlayer styled portals however its far from perfect, it takes into account the 8x distance and also auto builds portals in the Nether... but as with Notchs first version the portals can sometimes teleport you back to the wrong portal etc.
  25. Offline


    So was aetaric's problem fixed? It's giving me the same error when I try to teleport to my nether world. The world isn't loaded in the worlds.yml file and if I try to do it manually it screams error messages in the console. I have '*' permissions in the Permissions file.

    I can create a portal and remove it, as well as list worlds and somehow the "nether" world shows up, but I'm entirely unable to link the portal to it.
  26. Offline


    Eh, here's my servers feed. My craftbukkit is on version 339, So I don't see why
    Its telling me I don't have 320+.
    2011-02-21 02:04:36 [INFO] This server is running Craftbukkit version git-Bukkit-"8845ffe" (MC: 1.2_01)
    2011-02-21 02:04:36 [INFO] Preparing level "world"
    2011-02-21 02:04:36 [INFO] Preparing start region
    2011-02-21 02:04:37 [INFO] Preparing spawn area: 24%
    2011-02-21 02:04:38 [INFO] Preparing spawn area: 48%
    2011-02-21 02:04:39 [INFO] Preparing spawn area: 69%
    2011-02-21 02:04:40 [INFO] Preparing spawn area: 97%
    2011-02-21 02:04:40 [INFO] [Guardian] version [1.2] (Helmet) loaded
    2011-02-21 02:04:40 [INFO] [Healthy] version [1.0] (Apple) loaded
    2011-02-21 02:04:40 [INFO] [iConomy] version [2.1] (Sophie) loaded
    2011-02-21 02:04:41 [INFO] OtherBlocks: DIAMOND_PICKAXE + GOLD_ORE now drops 1x GOLD_INGOT with 100% chance
    2011-02-21 02:04:41 [INFO] OtherBlocks: DIAMOND_PICKAXE + IRON_ORE now drops 1x IRON_INGOT with 100% chance
    2011-02-21 02:04:41 [INFO] OtherBlocks: DIAMOND_PICKAXE + STONE now drops 2x COBBLESTONE with 100% chance
    2011-02-21 02:04:41 [INFO] OtherBlocks: ALL TOOLS + GLASS now drops 1x GLASS with 100% chance
    2011-02-21 02:04:41 [INFO] OtherBlocks: DIAMOND_SPADE + LOG now drops 64x TNT with 100% chance
    2011-02-21 02:04:41 [INFO] OtherBlocks: DIAMOND_PICKAXE + LEAVES now drops 1x CAKE with 50% chance
    2011-02-21 02:04:41 [INFO] Elevators version 1.2.3 is enabled!
    2011-02-21 02:04:41 [INFO] Loaded Essentials b131 by Zenexer, ementalo, Eris, and EggRoll
    2011-02-21 02:04:41 [INFO] Flashlight 1.0.2 initialized
    2011-02-21 02:04:41 [INFO] [Jail] Loaded 0 jail zones.
    2011-02-21 02:04:41 [INFO] [Jail] Loaded 0 prisoners.
    2011-02-21 02:04:41 [SEVERE] [Jail] You need Permission plugin for the Jail plugin! See http://forums.bukkit.org/threads/permissions-revolutionizing-the-group-system.1403
    2011-02-21 02:04:42 [INFO] [MultiVerse] - Version 1.1 Enabled
    2011-02-21 02:04:42 [WARNING] [MultiVerse] requires CraftBukkit build 320+. Proceed with CAUTION!
    2011-02-21 02:04:42 [INFO] [MultiVerse] Permission system not enabled. Disabling plugin.
    2011-02-21 02:04:42 [INFO] [MultiVerse] - Disabled
    2011-02-21 02:04:42 [INFO] [MYHOME]: 14 homes loaded
    2011-02-21 02:04:42 [INFO] MyHome 1.4 enabled
    2011-02-21 02:04:42 [INFO] OtherBlocks 0.2.4 loaded.
    2011-02-21 02:04:42 [INFO] Done! For help, type "help" or "?"
    2011-02-21 02:13:37 [INFO] Bigglesworth94 [/] logged in with entity id 83
    2011-02-21 02:13:41 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    2011-02-21 02:13:50 [INFO] [PLAYER_COMMAND] Bigglesworth94: /mvcreate Guest normal
    2011-02-21 02:13:50 [WARNING] Failed to handle packet: java.lang.NullPointerException
    at com.onarandombox.Rigby.MultiVerse.MultiVerse.onCommand(MultiVerse.java:146)
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:17)
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:77)
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:171)
    at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:628)
    at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:597)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:589)
    at net.minecraft.server.Packet3Chat.a(SourceFile:24)
    at net.minecraft.server.NetworkManager.a(SourceFile:232)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:74)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:104)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:317)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:232)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:512)
    2011-02-21 02:13:51 [INFO] Freed 68.49420166015625 MB.
    2011-02-21 02:13:53 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
  27. Offline


    Yes his problem was fixed and that was down to a mistake on my part.

    the world needs to be loaded into the Worlds.yml file, try using "/mvimport WORLDNAME ENVIRONMENT"

    Also if MultiVerse isn't loading Nether then it means another addon is, possibly essentials. It may be best to just disable the other plugin and allow one to control the worlds instead.
    --- merged: Feb 21, 2011 7:23 AM ---
    Ok two issues, you're using an outdated version of MultiVerse, i removed the CB Version check in 1.2 as they changed how the version number was displayed which is causing the issue you see. Also you don't seem to have Permissions installed which is also causing errors.
  28. Offline


    My permissions is installed, updated, and all of the commands are in the right places.. I think. Ill try updating the MV.

    [edit]: Yeah, now its just
    2011-02-21 02:45:57 [SEVERE] [Jail] You need Permission plugin for the Jail plugin! See http://forums.bukkit.org/threads/permissions-revolutionizing-the-group-system.1403
    2011-02-21 02:45:58 [INFO] [MultiVerse] - Version 1.2.1 Enabled
    2011-02-21 02:45:58 [INFO] [MultiVerse] Permission system not enabled. Disabling plugin.
    2011-02-21 02:45:58 [INFO] [MultiVerse] - Disabled
    [edit2]: NEVERMIND! Wow im dumbfuck retarded. I took out the "-" in my permisions file and everything works fine. Thanks!
    Where the hell did my permissions go???
    If it helps, heres my permissions yaml
      permissions: {system: default}
        default: true
        info: {prefix: '', suffix: '', build: true}
        inheritance: []
        permissions: [essentials.me, essentials.warp, essentials.home, essentials.sethome,
          essentials.mail, essentials.mail.send, essentials.whois, essentials.getpos,
          essentials.help, essentials.motd, essentials.afk, essentials.rules, essentials.compass,
          essentials.ping, essentials.list, lwc.protect]
        default: false
        info: {prefix: '', suffix: '', build: true}
        inheritance: [guest]
        permissions: [general.time, general.teleport, general.teleport.here, essentials.tp,
          essentials.tphere, essentials.item, essentials.give, essentials.kick, essentials.ban,
          essentials.unbanip, essentials.kill, essentials.tree, lwc.protect]
        default: false
        info: {prefix: '', suffix: '', build: true}
        inheritance: [Mod]
        permissions: ['*', lwc.protect, lwc.admin, - multiverse.world.create, - multiverse.world.remove, - multiverse.tp, - multiverse.world.setspawn, - multiverse.portal.create]
        group: Admin
        permissions: [essentials.item]
    --- merged: Feb 21, 2011 8:04 AM ---
    Sorry for the double post but the one above is full of shit. So, now, any way to get this working with guestbook as in
    "New players warp to the guest world with "/mvtp Guest" because you cant build in the normal world"?
    This would make my day. Month.
  29. Offline


    Is it possible to be warped IN the portal and not OUTSIDE? Im getting teleported like 5 or more or less blocks from the portal and that is in the lava. My portals location is on a bridge over a lava lake....

    So how do I set the teleporter to IN the portal and not OUTSIDE????
  30. Offline


    I also have this issue. Luckily, my portal is NOT on a bridge over lava. Ouch. [​IMG][​IMG][​IMG]
  31. Offline


    well ye maybe its just a bad place to make a portal, but it looks pretty cool ;)

Share This Page