[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. Offline


    Will look into those, I didn't test iConomy on the latest build as it used the same teleportation as the other ones so it should work... but obv I've done something somewhere preventing it from working.
    --- merged: Feb 15, 2011 7:14 PM ---
    hmmm there should be some error checking there, everytime i've typed in a jumble of mess it tells me no world, or wrong formatting. Will look into it.
    --- merged: Feb 15, 2011 7:14 PM ---
    Yeh going to implement that option, and the whitelist idea... sure can look into it as well :).
    --- merged: Feb 15, 2011 7:15 PM ---
    Ok thanks for confirming that will definately look into it.
    --- merged: Feb 15, 2011 7:16 PM ---
    Ok thanks for confirming that I have indeed not validated the /mvtp command, will sort that out.

    Also, I forgot to add in the destination information, will see if that can be put in tonight as well.
    --- merged: Feb 15, 2011 7:17 PM ---
    Sure, will get editting them shortly.
  3. Offline


    OK, im still getting internal server errors every time i try to do a command. Is there a fix to this yet? My craftbukkit version is 326. Permissions 2.0 the only problem is i cant do the commands.
  4. Offline


    Is it just a select few? or all of them?

    All I can think is theres something clashing, or the config is setup wrong.

    Can you list all the plugins you're using as well as deleting the 3 multiverse configs and let the plugin create new DEFAULT configs.
  5. Offline


    trying to /mvpt to a non existing world causes a client crash.
  6. i typed /mvcreate traps normal and the game crashed... what did i do wrong?
  7. Offline


    hmmm the command seems fine... Can you pastebin your server log?

    Including the start section where the server loads up.
  8. Offline


    The portals teleport me back before I can get out. I keep getting stuck in an endless loop
  9. Offline


  10. thanks for quick reply...

    The problem appears to be fixed as i created a world called hello and it worked fine... weird :D
  11. Offline


    May of been Minecraft erroring on world creation, seen it alot lately since doing this plugin.
    --- merged: Feb 15, 2011 10:39 PM ---
    Yeh I need to change the teleportation code, a portal -> portal teleport will not work correctly if the trigger zone is AIR.
    --- merged: Feb 15, 2011 10:40 PM ---
    Have you tried it with just MultiVerse and Permissions on their own? If that works then it may mean theres a clash. I can't seem to see anyone else with the issue of not being able to type any command.
  12. Offline


    I logged into our test - I went to the portal to the "FFA" world (the natural second world) - I ported into blocks - and the server reported this.

    of en -r
    2011-02-15 16:56:30 [INFO] Kainzo suffocated
    Feb 15, 2011 4:56:32 PM org.bukkit.plugin.SimplePluginManager callEvent
    SEVERE: Could not pass event PLAYER_RESPAWN to MultiVerse
            at com.onarandombox.Rigby.MultiVerse.MVPlayerListener.onPlayerRespawn(MVPlayerListener.java:74)
            at org.bukkit.plugin.java.JavaPluginLoader$3.execute(JavaPluginLoader.java:134)
            at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:60)
            at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:214)
            at net.minecraft.server.ServerConfigurationManager.d(ServerConfigurationManager.java:170)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:718)
            at net.minecraft.server.Packet9Respawn.a(SourceFile:10)
            at net.minecraft.server.NetworkManager.a(SourceFile:232)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:74)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:104)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:317)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:232)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:512)
    Player count: 1
  13. Offline


    So this is updating from 1.0 to 1.1? Did you reset the portals.yml file? the lcoation details are different again.
  14. Offline


    Also now - both portals which previously yesterday were taking me to FFA world and Hell world respectively are now taking me to the same spot in Hell world.

    --- merged: Feb 15, 2011 10:59 PM ---
    oh rigby - let me try that really fast. sorry
  15. sorry to bug you about everything, but i have another problem...

    I can't create a portal!!!

    so, i created a world called trap(its normal
    then, i got a wooden pickaxe (270)
    i selected position 1 and 2(said so in chat)
    i then typed /mvpc traptp trap
    that didn't do anything...
    i deleted that portal (or, well, nothing showed up)
    then, i typed /mvpc traptp trap:normal
    still didn't do anything..

    can you give me the command to make a portal to the normal world trap?? Thanks :D

    also, i made sure trap was made correctly by tping to it...
  16. Offline


    Also - sorry about being so brash yesterday in irc :p i didnt realize you were and you were the creator of this plugin ;)
  17. Offline


    Ok looking at that, if the portal was created and setup in the config all you need to do is the following -

    /mvps traptp
    /mvpd w:trap

    What that does is it selects the portal 'traptp' then sets its destination to the world 'trap'

    However if the portal isnt created....

    Selected your 2 points then type '/mvpc traptp w:trap'
    --- merged: Feb 15, 2011 11:24 PM ---
    Absolutely NP, I had forgotten you were running test servers for bukkit :).
  18. Offline


    Okay, not really sure what I'm doing wrong here. I got 2 worlds set up, had to add the nether manually. But /mvtp nether works. So I made 2 portals.
            price: 0.0
            destlocation: p:netherportal
            location: -115.0,46.0,5.0:-115.0,46.0,5.0
            owner: Scuzzball
            world: world
            price: 0.0
            destlocation: p:spawn
            location: 89.0,60.0,-49.0:89.0,60.0,-49.0
            owner: Scuzzball
            world: nether
    Yet when I go into either, nothing happens.
    Any chance I gave enough information to actually get help with this?
  19. Offline


    hmmm is that the exact file? is there a 'portals:' at the top ???

    Also can you pastebin the startup section of your server as well as any errors that pop up during the attempt to telepot.
  20. Offline


    I tried this plugin a few days ago and got the Internal Server Error so i waited for an update thinking it was a bug. it still does it.

    2011-02-15 17:51:03 [WARNING] Failed to handle packet: java.lang.NullPointerException
        at com.onarandombox.Rigby.MultiVerse.MultiVerse.onCommand(MultiVerse.java:146)
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:17)
        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:77)
        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:171)
        at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:610)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:589)
        at net.minecraft.server.Packet3Chat.a(SourceFile:24)
        at net.minecraft.server.NetworkManager.a(SourceFile:232)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:74)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:104)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:317)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:232)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:512)
  21. Offline


    what do i add to permissions to get /mvmodify to work
  22. Offline


    same here, im getting the "Internal Server Error" whenever any of the MV cmds are used
  23. Offline


    Ok the line its erroring on there Darkwizard is a Permissions check line... this hints at an outdated version of Permissions plugin, it needs to be 2.0
    --- merged: Feb 16, 2011 12:14 AM ---

    Sorry need to update front page with some new commands.
    --- merged: Feb 16, 2011 12:14 AM ---
    Can you provide any more information? If it's the same as Darkwizard then it hints at a lack of Permissions or a non 2.0 Permissions version.
  24. Offline


    k i have permissions 2.0 i will try to reinstall it, anyway thanks for ur help if it work the thank you vary much.
  25. Offline


    [Notice] Starting Minecraft Server...
    2011-02-15 19:24:16 [INFO] Starting minecraft server version Beta 1.2_01
    2011-02-15 19:24:16 [INFO] Loading properties
    2011-02-15 19:24:16 [INFO] Starting Minecraft server on *:25565
    2011-02-15 19:24:16 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-407-g247dfc4-b326 (MC: 1.2_01)
    2011-02-15 19:24:16 [INFO] Preparing level "world"
    2011-02-15 19:24:16 [INFO] Preparing start region
    2011-02-15 19:24:17 [INFO] Preparing spawn area: 32%
    2011-02-15 19:24:18 [INFO] Preparing spawn area: 57%
    2011-02-15 19:24:20 [INFO] [Permissions] version [2.0] (Handler) loaded
    2011-02-15 19:24:20 [INFO] WorldGuard 3.2.2 loaded.
    2011-02-15 19:24:20 [INFO] WorldGuard: Permissions plugin detected! Using Permissions plugin for permissions.
    2011-02-15 19:24:20 [INFO] WorldGuard: Blacklist loaded.
    2011-02-15 19:24:20 [INFO] WorldGuard: Single session is enforced.
    2011-02-15 19:24:20 [INFO] WorldGuard: TNT ignition is PERMITTED.
    2011-02-15 19:24:20 [INFO] WorldGuard: Lighters are PERMITTED.
    2011-02-15 19:24:20 [INFO] WorldGuard: Lava fire is blocked.
    2011-02-15 19:24:20 [INFO] WorldGuard: All fire spread is disabled.
    2011-02-15 19:24:20 [INFO] [iChat] version [1.5] (Maria Holic) loaded
    2011-02-15 19:24:20 [INFO] WorldEdit 3.2.2 loaded.
    2011-02-15 19:24:20 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin for permissions.
    2011-02-15 19:24:21 [WARNING] Could not use log file  /plugins/WorldEdit/worldedit.log: Couldn't get lock for  /plugins/WorldEdit/worldedit.log
    2011-02-15 19:24:21 [INFO] Minecart Mania Station version 0.22 is enabled!
    2011-02-15 19:24:21 [INFO] Minecart Mania Sign Commands version 0.17 is enabled!
    2011-02-15 19:24:21 [INFO] Minecart Mania Admin Controls version 0.15 is enabled!
    2011-02-15 19:24:22 [INFO] [MYWARP]: 30 warps loaded
    2011-02-15 19:24:22 [INFO] [MYWARP] Permissions enabled.
    2011-02-15 19:24:22 [INFO] MyWarp 1.9 enabled
    2011-02-15 19:24:22 [INFO] Loaded EssentialsHelp build 191 by Zenexer, ementalo, Eris, and EggRoll
    2011-02-15 19:24:22 [INFO] WorldGuard: Permissions plugin detected! Using Permissions plugin for permissions.
    2011-02-15 19:24:22 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin for permissions.
    2011-02-15 19:24:22 [INFO] Minecart Mania Core version 0.87 is enabled!
    2011-02-15 19:24:22 [INFO] [MYHOME] Connection with MyWarp established.
    2011-02-15 19:24:22 [INFO] [MYHOME]: 9 homes loaded
    2011-02-15 19:24:22 [INFO] [MYHOME] Permissions enabled.
    2011-02-15 19:24:22 [INFO] MyHome 1.8 enabled
    2011-02-15 19:24:22 [INFO] Loaded Essentials build 191 by Zenexer, ementalo, Eris, and Brettflan
    2011-02-15 19:24:22 [INFO] [MultiVerse] - Version 1.1 Enabled
    2011-02-15 19:24:22 [INFO] [MultiVerse] Loading World & Settings - 'world' - NORMAL
    2011-02-15 19:24:22 [INFO] [MultiVerse] Loading World & Settings - 'nether' - NETHER
     Preparing spawn area for nether, 65%
    2011-02-15 19:24:24 [INFO] [MultiVerse] 2 - World(s) loaded.
    2011-02-15 19:24:24 [INFO] [MultiVerse] Loading Portals
    2011-02-15 19:24:24 [INFO] [MultiVerse] 2 - Portal(s) loaded.
    2011-02-15 19:24:24 [INFO] Loaded EssentialsSpawn build 191 by Zenexer, ementalo, Eris, and Brettflan
    2011-02-15 19:24:24 [INFO] Loaded EssentialsTele build 191 by Zenexer, ementalo, Eris, and Brettflan
    2011-02-15 19:24:27 [INFO] [BBROTHER] Permissions enabled.
    2011-02-15 19:24:27 [INFO] BigBrother 1.5 initialized
    2011-02-15 19:24:27 [INFO] Minecart Mania Chest Control version 0.18 is enabled!
    2011-02-15 19:24:27 [INFO] Loaded EssentialsBan build 191 by Zenexer, ementalo, Eris, and EggRoll
    2011-02-15 19:24:27 [INFO] Done! For help, type "help" or "?"
    Exact file:
            animals: true
            spawn: -43:67:-19:0.0:0.0
            price: 0.0
            mobs: true
            environment: NORMAL
            ratio: 1
            alias: ''
            animals: true
            spawn: -43:67:-19:0.0:0.0
            price: 0.0
            mobs: true
            environment: NETHER
            ratio: 8
            alias: ''
    There is no output when I try to use the teleport.
  26. Offline


    I have isolated the issue to be the config.yml for permissions 2.0

    without the config in the server logs it loads the spawn point for both worlds however i do not have access to the commands, when i put in the config.yml i get the following error

    16.02 11:25:14 [Server] INFO SEVERE: Could not load plugins\Permissions.jar in plugins: null
    when i remove the permissions for MV out of the config.yml permissions 2.0 loads as it should

    these are the following permissions typed exactly in my config.yml

            default: true
                build: true
                - 'general.spawn'
        - 'multiverse.world.create'
        - 'multiverse.world.import'
        - 'multiverse.world.remove'
        - 'multiverse.world.list'
        - 'multiverse.tp'
        - 'multiverse.world.setspawn'
        - 'multiverse.world.spawn'
        - 'multiverse.portal.create'
        - 'multiverse.portal.remove'
        - 'multiverse.portal.select'
        - 'multiverse.portal.destination'
        - 'multiverse.portal.rename'
        - 'multiverse.portal.list'
    Let me know if you want any more info

  27. Offline


    hmmm thats strange, if you want I could log on and try build a test portal.

    Also I see you have a Ratio set, atm RATIO isn't implemented although when it does get implemented this may send some portals off.
    --- merged: Feb 16, 2011 12:35 AM ---
  28. it gives me an error saying it cannot find permissions and i have 2.0. do i need to add something to the permission file?
  29. Offline


    oh wow ive never come across code so dependent on format

    permissions is loading fine now

    thanks for the help
  30. Offline


    ok its working now Thank you. :)
  31. Offline


    my users were reporting random stone blocks appearing in any world they were inafter they mined something - is this still occurring?

Share This Page