[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. Offline


    Mmh my players aren't able to use the portals is it normal ? Is it a permission node that I haven't seen or something to configure ? :)
  3. Offline


    Basically yes, I know the Bukkit team are working on mapping as there is a topic somewhere on the forums showing they can go so far as to put youtube videos on a map
  4. Offline


    Is there a way to define the destination of multiverse portals using one's position and facing angle?
  5. Offline


    @Rigby90 or maybe it's @Multiverse

    Is their a whitelist function now sorry been many months been using ServerPort / Proxy but I think its time to move on. I was wondering if I can set whitelist for each world so people can't use the gate unless they have access.
  6. Offline


    Heya, I have just installed this mod and made a skylands map.

    I set the /mvspawn on an island and went back to the main world.
    On the made world I made a portal to w:Skylands (the skyland world's name) and it spawned me over the void and i just keep falling, not lag as i can drop items and chat fine.

    What have I done wrong?
  7. Offline


    Generally if you have a problem it is best to post ALL the information. What other plugins? What CB build? etc...

    Your issue sounds like you aren't using CB820 or higher. If you are then it is most likely a conflict with another plugin (do you have any that change the spawn such as essentials or something?)
  8. Offline


    @Kane yes, but its been broken since 1.6.5
  9. Offline


    Hello, wondering if anyone can help me.
    My friend sent me a world.zip, I uploaded it to my server, extracted it and renamed it.
    I opened the game and typed /mvimport world2 normal.
    It says complete, but when I /mvtp world2, it takes me to what I believe are new chunks, with no noticeable landmarks nearby. I'm running Build #860
  10. Haha, wow, I didn't realize this many people wanted the whitelist! It's been added to the official tracker, and thus it's on my radar. Once a bit more core functionality comes into 2.X I'll make sure this make it in.

    It should be even cooler whitelisting before, I think y'all will like it :D

    Please upgrade your MV version.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  11. Offline

    Matt Phillips

    can anyone help out with me trying to create a world with a certain seed name?
    i have permissions and all that jazz
    /mvcreate nospaces normal [seedname]
    the seed i want to use has a space in the name and i have tried enclosing it in everything i can to make the space work but nothing seems to work (ive tried [,{,(,",' ) and anytime i try to create it just uses the first part (before the space)
    anyone that can help?
  12. This has been fixed in MV2.0 but we will not be porting it back to 1.X For right now, create this world in SP and use /mvimport
  13. Offline

    Matt Phillips

    When i imported my world from single player (peaceful) it now has monsters and no health regen, health regen isnt an issue, i would just rather it not have monsters.
    in the Worlds.yml mobs is set to :false for this specific world. Yet there are still monsters, any ideas?
  14. Offline


    When ever I use /mvtp it tells me that "Multiworkd teleporting is disabled in this build. Nether works" and I even tried creating a portal to the world instead of the command and still the same message. Anyone else have this problem?
  15. Nope, but I'd imagine you need to upgrade your bukkit build, that one is WAY out of date.

    For those of you with White/Black list problems:

    I present to you the latest commit message to the 2.X repo:
    Fix White/Blacklisting

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  16. Offline


    how silly of me! Thank you for such a quick response!
  17. Offline



    I was wondering how to use the playerWhitelist option in the config file Worlds.yml.
    I didn't find any information in this topic.

    May someone know how it's working ?

  18. Offline


    It won't work for me...
    It says "Permissions is not Enabled or not found.'!
    But Permission ist enabled and the server and is working!
  19. Offline


    hello is there anyway i can link different nether's to different worlds

    world1 = world1nether
    world2 = world2nether

    so if some one makes a portal in world1 it will only take them to world1nether

    and if some one makes a portal in world2 it will only take them to world2nether

    is there a nether plugin that is multiworld compatible and can do this?


    AS1LV3RN1NJA likes this.
  20. Black/Whitelist is broken in the current version. It has been fixed in 2.x but 2.x is not stable. Sorry. When it gets released everyone's life will be better!

    Not yet. We plan this for 2.x, maybe i'll go do it now...

    Leaves forums and dives back into eclipse...

    Side note: The syntax will be this:
    world = world_nether
    world2 = world2_nether

    At least for now, maybe we'll make it configurable.

    Check your logs. I'm sure Permissions failed to start, most likely a YAML issue. pastebin your log here or hop into irc and we'll try and get you sorted out.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  21. Offline


    Every time i use /spawn (which teleports me to a designated spawn world) I get kicked for moving too quickly any fix?
  22. What CraftBukkit version do you have ? The 820 might fix that (and older also).
  23. Offline


    I am using build 860 :oops:
    also I end stream when respawning
  24. Offline


    Hi, I have an issue where when I created a skylands world, and /mvtp between that world and the normal worlds, the time will always be stuck at midday and the clouds underneath the world, like in the skylands, but across all worlds. I am the only one who /mvtp'd between worlds, and I am the only one who experiences this. I tried removing the skylands world and the Multiverse plugin, and removing my character's .dat file in world/players/, but to no avail. I am using build 860 of bukkit, and 1.7.2 of multiverse. Is there any way to correct the time in the normal worlds?

  25. @Bakies @2102t

    Quote from the OP:
    For flawless Multiverse GLORY. Update to #863.
    RB #860 has a world creation bug.

    Just to let you guys know, this is done for 2.X now. FYI.

    @wisby @AS1LV3RN1NJA

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  26. Offline


    Yes, there is! The documentation on this and how to do it is lacking, but reading back like 30 pages I managed to figure it out.

    What you need to do is create a portal area as normal per the documentation, but leave off the destination in the initial command. Then, use the /mvps [portalname] to select the portal area you just created. Then, teleport / move to the location where you want that portal to go, face the direction and angle you want player using that port to come out at, then type /mvpd here.

    The documentation says to just type /mvpd, but that's incorrect. You HAVE to add the word 'here' after it. Doing that, it works perfectly.
  27. Offline


    Everytime I create a nether world, it converts to a normal world after server restart, any ideas?
  28. Offline


    I used to have this problem. Do you have the 'Ancient Gates' plugin installed?
    That plugin was what coused it on my server. The solution is to let the Ancient Gates plugin load AFTER multiverse.
    How to do this?
    Just rename the 'AncientGates.jar' file into 'ZAncientGates.jar'
    It loads the plugins in alphabetical order so this way AncientGates will be one of the last plugins loaded.
  29. Offline


    Ahh I see, cool.
  30. Really? This hasn't been fixed yet! The problem is, Ancient gates will load worlds for you, if they're not loaded, but it doesn't check to see what world type (like we over here in the Multiverse cool kids world :)) a world is. Thus, it assumes normal.

    I concur. We all agree the docs aren't up to snuff. (Especially the hidden "here" function :p) For 2.x I'm making it a priority to use the Github style Wikis. This way, the devs (Rigby and Myself) can try to get everything documented, but if we mess up, someone else can fix it without using the silly OP method.
  31. Offline


Share This Page