[EDIT/MISC/TP/FUN] Multiverse 2.3- World Management [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Multiverse, Feb 7, 2011.

  1. Offline


    This plugin is still VERY alive.
    If you guys haven't heard yet, we're now going to be doing the help on DBO (dev.bukkit.org) Our pages are here:



    Feature Requests go in the appropriate Github Issues section. See below.
    Post Bug Reports In the thread
    or join IRC at #multiverse on EsperNet

    Multiverse 2 - World Creation/Management/Teleportation & More​
    Current Version: 2.2-AB

    Multiverse 2 is a ground up rewrite of the popular Multiverse plugin for CraftBukkit. There are many new features, the biggest one being the much better usability and cleaner code! MV2 has been in the works for over 2 months and given the size of it, the developers are confident that you'll find a small bug or two. Please come into our IRC channel and discuss politely with us and we'll get it resolved quick-fastly!

    Looking for the old version that runs on CraftBukkit 1000? We don't have it anymore :( Here's an archive of the old help post. If you're a new user, we REALLY recommend using Multiverse 2..

    The Multiverse Team:
    @Rigby90 - The Multiverse God. 'nuff said
    @fernferret - Coding Person. Don't ask him about P2/P3 or Error 199.
    @lithium3141 - Utility coder or crazy math dude. You decide.
    @main-- - Is this his forum account? Localization person and MV-Adventure dev!


    Testers (official I know a bunch of you have helped, thanks!):

    Want to Try before you buy(er, download for free)?
    Check out the official Multiverse 2 test server: beta.zomgameservers.com

    Some of the MV2 Features:
    • Create multiple worlds of different types, seeds and with Custom Generators
    • Create portals to let users go between other portals, worlds, or locations
    • PermissionsBukkit support (Anything that implements the superperms api (PermBukkit, PEX, bPerms...)
    • iConomy, BOSEconomy, RealEcon, Essentials Econ and Item economy support!
    • Show which users are in what worlds
    • Create portals to let users go between worlds
    • Control who can enter worlds/portals with permissions!
    • World scaling with NetherPortals
    • Allow minecarts/boats through portals
    • Launch users through the air when they enter a portal!
    • Conserve memory by having some worlds NOT keep their spawn chunks loaded!
    • And the list goes on...

    This plugin requires CraftBukkit 1.0.1-R1+

    The Dev versions Require CraftBukkit 1.0.1-R1

    Need help? Check out our AWESOME Wikis!
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Core Downloads
    (Stable Builds | Dev Builds)

    Portals Downloads
    (Stable Builds | Dev Builds)

    NetherPortals Downloads
    (Stable Builds | Dev Builds)

    SignPortals Downloads
    (Stable Builds | Dev Builds)

    Why multiple Downloads?

    Want to use bleeding edge?
    Grab live builds from ci.onarandombox.com

    FAQ: (Frequently Asked Questions)

    How do I make portals:

    How do I separate world inventories?:
    Use the plugin named MultiInv

    People can't log into my 1060 Bukkit Server!:
    Are you using spout? If so, you need to upgrade it to a dev version or disable it until those guys release a 1060 compatible version.

    How do I know if I'm running CB XXXX or higher?:
    Type /version. The number here is your CB version:
    This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    Please check that this version is the same as one of those in the title of the post.

    More Up-To-Date FAQ:

    Commands, Syntax & Permissions:
    Core Wiki
    Portals Wiki
    NetherPortals Wiki
    SignPortals Wiki

    Known Issues:
    Core Issues
    Portals Issues
    NetherPortals Issues
    SignPortals Issues


    Changelogs present on each file on DBO.

    Version 2.0
    • Release the Multiverse 2 Suite
    1.X changelog (For posterity)

    Show Spoiler

    Version 1.7.2
    • Now allow you to mvmodify worlds with _s
    Version 1.7.1

    • Added ability to do seeded world creation via: /mvcreate WORLD ENV SEED
    • Now allow you to import/create worlds with _s
    • Automatically import your DEFAULTWORLD_nether world
    • Add the /mvenvironments command to help you determine what valid environments are!
    • Other nifty bugfixes
    Version 1.7

    • Skylands is now supported as an Environment/Biome Type
    • The plugin should now support any custom Environment/Biomes which are added to CraftBukkit in the future without an update from Multiverse.
    • Fixed the 'Kick on Teleport' issue.
    Version 1.6.4

    • Fixed 0 Price Portals
    • Fixed a bug with new Portals
    • Updated for iConomy 5 (You will need to update to iCo 5)
    • Improved the PVP Setup
      • Now you no longer have to set the server.properties PVP variable to true... this is now completely done via the worlds config and properly stops PVP rather than preventing the damage from being applied.
    Version 1.6.3

    • Update for Minecraft 1.5 and CraftBukkit build 733
    Version 1.6.2

    • Contains updates/features which were introduced in 1.5
    Version 1.6 - Thanks to 'fernferret'

    • Updated for CB Builds 600+
    Version 1.5 - Permissions 2.1+ - (V1.5 - 02/03/2011)[/U]

    • Fixed whitelist/blacklisting once and for all :), thanks to @ledhead900
    • Add permission node 'multiverse.portal.exempt' -- Basically means they don't have to pay the cost of the portal... this is useful for Donors and such.
    • Updated to use iConomy 4.1 -- Would be great if I can get feedback on this... as usual I can only test solo.
    Version 1.4 - Permissions 2.0 & 2.1 - (V1.4 - 26/02/2011 - 01:11 AM GMT)

    • Should be easier on high pop servers now
      • Only checks if a player is within a Portal everytime he changes BLOCK Coordinate instead of every single pixel footstep he/she takes.
    • Now Supports Permissions 2.1 -- Both 2.1 and 2.0 support have seperate JARs, so get the right one.
      • Also commands are properly disabled when a Permissions plugin is not found and it will alert the player trying to use the Command.
    Version 1.3 - Permissions 2.0 - (V1.3 - 24/02/2011 - 02:31 AM GMT)

    • Removed the 'Stupidly Long Constructor'
    • Fixed an error which was loading portals that were on a non existent world which caused errors later on.
    Version 1.2.2 - (V1.2.2 - 23/02/2011 - 03:05 AM GMT)

    • Nothing much just updated so it works with Minecraft Beta 1.3, I suggest you don't use a lower Multiverse build than v1.2.2 otherwise it won't work and errors will occur.
    Version 1.2.1 - (V1.2.1 - 20/02/2011 - 23:35 PM GMT)

    • Changed over to the new Entity Damage...

    TGF, maino, aTxT and 58 others like this.
  2. Offline


    That could be what the latest build is about, can you tell me whether CraftBukkit build 320 is any different as the following change was made.

    Erik Broes
        Make the spawning listen to the server spawn-settings (version 89fcc168a6dfcbb18eddb5585779b8496d3970e4)
    --- merged: Feb 13, 2011 2:21 AM ---
    Install Permissions 2.0, instructions are on the first post of this topic.
  3. Offline


    So if I leave a one-block space between the pillars, there's no chance of conflict?
    Works for me.
  4. Offline


    Yup :)
  5. Offline


    You were right /mvhelp works for them. i have another weird problem.

    i have used /mvsetspawn on each world when myself or players use /mvtp world name we do not appear at the the /mvsetspawn point we appear at the normal world spawn and to be honest it sucks.

    also i was thinking you could maybe make a work around for the no build bug quite easy on join save player pos and world then tp them to the default map you can get its name from the server.prop then tp them back to where they were when they joined.

    I know it seems like a lot of work for a problem that should be fixed by bukkit team but for now that would be nice my players are getting mad. :/
  6. Offline


    How are you travelling between the worlds? If you're having this issue when typing /mvtp then this is a known bug within CraftBukkit and multiworlds. If it's using the portaling system then I'm not sure whats going on, will look into it if its this.

    I attempted the fix you mentioned when I first came across the issue, there needs to be a timed gap between each teleport if you do a teleport right after the other then the server console shows ALOT of errors.
    --- merged: Feb 13, 2011 3:21 AM ---
    Will have another go at the fix... however its not my top priority.
  7. Offline


    ok the portals was to close XD
    i have made a new one on other place and it works now ^^
  8. Offline


    Uh yea its the known bug just didnt quite understand it the way you worded it in the op but i see it now :/

    I dont like the gates cause then i cant restrict who uses it the way i have it now noobs cant get to player land and players can :p
  9. Offline


    That should be fixed in the update... I may release it slightly earlier with slightly less features than I was going to just to get permissions on the gates out of the way.

    Will see how far I get before the weekends up.
  10. Offline


    Err, also Rigby, by chance do you know of what might cause small pieces of nether worlds to be pulled back to the original world?

    We're seeing that occassionally with latest CB.
  11. Offline


    This is a bug with CraftBukkit itself which I believe is being looked into, theres also a similar bug where the light level may be different in specific areas or blocks.

    I'm hoping for a fix soon because some people seem to be getting it more than others.
  12. Offline


    i have that. i figured it out there was a problem with one of the codes.
    --- merged: Feb 13, 2011 5:48 AM ---
    how do u turn off monsters for the other worlds?
    my first and main world (world1) is set so that monsters are off. but when i go to the second world (world2) there is monsters.
  13. Offline


    It's not possible atm, I'm looking into alternatives.
  14. Offline


    I am having a problem on my server. People create a portal 5000+ blocks away in the nether w/o a sign. Then they enter it and it takes them over 100,000 blocks away in the normal world then teleports them to the correct spot in the normal world causing massive amounts of lag. This is with essentials on.
  15. Offline


    Do the following -
    • Make sure Essentials Nether and Portals are turned off
    • Make sure you are running v0.5.4
    • Make sure you have done /mvsetspawn in the location you want them to spawn at when taking a portal to that world.
    MultiVerse currently does not function without a sign, therefore it is Essentials teleporting you all the way out there.
  16. Offline


    can someone help me im not very good with Permissions but can someone tell me how to make this work heres my problem
    2011-02-13 00:26:46 [INFO] [PLAYER_COMMAND] omgmac: /plugin list
    2011-02-13 00:27:15 [INFO] [PLAYER_COMMAND] omgmac: /plugin enable MultiVerse
    2011-02-13 00:27:15 [INFO] [MultiVerse] Loading World & Settings - 'world' - NOR
    2011-02-13 00:27:15 [INFO] [MultiVerse] - Version 0.5.4 Enabled
    2011-02-13 00:27:20 [INFO] omgmac issued server command: mvhelp
    2011-02-13 00:27:20 [INFO] Unknown console command. Type "help" for help.
    heres my set up in permissions
    permissions: {system: default}
    default: true
    info: {prefix: '', suffix: '', build: true}
    inheritance: []
    permissions: [multiverse.mvtp, multiverse.mvspawn, multiverse.mvlist]
    default: false
    info: {prefix: '', suffix: '', build: true}
    inheritance: [Default]
    permissions: [general.time, general.teleport, general.teleport.here, general.player-info]
    default: false
    info: {prefix: 'Admin', suffix: '', build: true}
    inheritance: [Moderator]
    permissions: [multiverse.mvtp, multiverse.mv, multiverse.mvsetspawn, multiverse.mvspawn,
    group: Admins
    permissions: []
    group: Default
    permissions: [general.time]
    group: Admins
    Permissions: [multiverse.mvtp, multiverse.mv, multiverse.mvsetspawn, multiverse.mvspawn,

    plus most of the plugins i get never seem to work at all
    most of them are red when i type /plugin list
  17. Offline


    uh @omgmac its your permissions file thats all wrong dude you dont need any of the [] and your missing a lot of major formatting stuff

    you also have some other bits in there for sk89q that im sure you dont need so heres what im going to do for you im going to fix it cause im so cool

    just give me a few min and i will have this all sorted and edit my post here with what you need.

    and here it is http://pastebin.com/FdhUdBfh

    you will need to scroll down to the bottom and copy the contents of the edit box section so you dont end up with numbers up the side.

    fixed a lot of things where you had un-needed repeat commands
  18. Offline


    Btw, his file was fine, its official YAML just formatted the way Essentials formats it. I have it running without any hiccups with all other plugins.

    That also means the file you pasted will just be re-formatted again into the official YAML once he uses the /mod command of essentials.
  19. Offline


    wow thats screwed up why on earth should esensials be changing the format of another plugins config file thats crossing the line a bit if you ask me. + that format is so hard to read and he had given him self acces to the list command 3 times

    once in the player group once in the admin group and again on his player dam dude talk about unneeded junk any way what i did is way easier to read.

    i dont use essensials i just use general i done see essensials adding any thing to the game that generals done besides a whole lot of complex commands trying to do every thing in 1 plugin !=good idea.
  20. Offline


    My advice is to take a look at Sky89q's WorldGuard Region Flag settings he should be able to help you out with maybe treating other worlds as a Anti mob zone so to speak, You might even want to take a look at CB's Normal Settings.properties file it has Mob control and PvP maybe you could just Hook into this some how to get it to apply to all worlds. Maybe You could attempt to get detect if this setting is on and then have it check as well for other worlds in the Config then other worlds take mob spawn control from the Value it changest to disable them in world 0.

    Just some food for thought Im not a coder just looking for ways it could be done.
  21. Offline


    i have a question dies the multiverse world require alot of the server preformance?
  22. Offline


    I ran into this issue my self as well It is essentials but being Admin it wont stop me from doing so in fact sometimes when I try to spawn it actually crashes the client. I actually asked for Portal to have a Disable like nether did it was included in a Dev build tho It still seems to to take effect for admins :( Might have to catch up with zenexer again and see if we can it sorted.
    --- merged: Feb 13, 2011 12:20 PM ---
    Maybe maybe not I think it would give the old Hardrive a flogging tho I would recommend running duel Fast Sata drives in raid 0 ;).
    --- merged: Feb 13, 2011 12:22 PM ---
    I think the latest CB has added multiworld mobs or a means to control mob spawn at least might need to take a look at that.
  23. Offline


    running it on a 7200rpm sata drive :p
  24. Offline


    Should be fine we are running it on an amd x2 lol with a 7200rpm sata drive. the only time it slow and laggy is if mobs are on but the only seems to effect us :p, Mobs lag on our server I blame notch for his notchcode.
    --- merged: Feb 13, 2011 1:48 PM ---
    If your wondering how she goes locally zero lag chunks load as quick as normal world even if users are in other worlds.
    --- merged: Feb 13, 2011 1:49 PM ---
    Tho I would not get crazy with how many worlds u run Id probably stick to 3 4
  25. Offline


    Are you still having this problem?

    From what I can see MultiVerse is fully loading.
    --- merged: Feb 13, 2011 3:50 PM ---
    Will do.
    --- merged: Feb 13, 2011 3:51 PM ---
    Yes, it uses more than running one server but less than running two... theoretically :p... thats only running two worlds.

    Basically even if no ones on the second world its still storing the spawn area in memory so idling it uses more.
    --- merged: Feb 13, 2011 3:52 PM ---
    Looked into it I just think it's a case of if a server has mobs=off and animals=off then all WORLDS will be off... atm alternate worlds are completely ignoring the mobs and animal settings I believe.
  26. Offline


    This is great work Rigby. I have one suggestion though, is it possible to add a button to the gates to turn them on or off?
  27. Offline


    Not currently, will look into this though.
  28. Offline


    I've been having trouble with enabling this plugin through permissions. Permissions isn't too user friendly, and I can't get it to work, and my server log keeps giving me the message 'Permissions not enabled, disabling plugin blah blah blah'. I tried entering in that code at the top into the Permissions 'config.yml' but don't really know where to put it. So my question is, could somebody help me out and show me what the permissions config should look like with this enabled?
  29. Offline


    Make sure the Permissions.jar is in the plugins folder... Sounds like Permissions isnt even loading.

    You can always copy paste your server log to pastebin then paste the link here.

    Make sure you are running an up to date CraftBukkit and Permissions 2.0
  30. Offline


    Permissions is in the Plugins folder, Craftbukkit is 297 and Permissions is 2.0. The server log just tells me I havn't enabled Multiverse in permissions, which is what's confusing me. I attached pastebinned versions of the log and my Permissions config file.

    Attached Files:

  31. Offline


    Looking at the logs, Permissions is not loading full stop. This means its not an error with MultiVerse.

    Try printscreening your plugins directory but the fact its not my plugin that's erroring I'm not sure where to take it... Several things could be preventing it from loading, such as corrupt download.... wrong Operating System permissions on the files.... in the wrong directory and so on.

Share This Page