[EDIT/FUN/SEC] VoxelSniper v5.019 - Flexible Long-Range In-Game Map Editor [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Voxel Box, Jan 23, 2011.

  1. Offline

    Voxel Box

  2. Offline


  3. Offline


    for some reason i can't use /b oc it says no such brush i have essentials but i tryed to find anything whit b oc nothing.. any help?
  4. Offline


    The oceanator brush is "/b o"

    TheVoxelBox's wiki is amazing. It should answer any problems like this that you're having:
  5. Offline


    Figured i'd post what I did when I got bored with VoxelSniper.

    Brushes used: Overlay, Melt, Fill, Smooth, Canyonator, ball Replace, Disc.

    Hope you like it. :)




    Couldn't get the tree brush to work, So that was kind of disappointing that I had to go through and plant them all myself. but oh well, Not too bad for some more advanced Terraforming with VS, Unlike the little thing's I've been doing before.
  6. Offline


    I need a bit of help. Whenever I try to do anything with this plugin, it either says invalid target, or simply does nothing. What I'm really trying to use is the Oceanator, but that doesn't do anything either. Any help is appreciated.
  7. Offline


    Is anyone else having a problem with crouching? When anyone on my snipers list crouches they can't break any blocks at all. I wasn't sure if it was a conflicting plugin or not so i took every other plugin out and tried again and we still can't break anything. I'm using bukkit version 766. Any help would be appreciated.
  8. Offline


    Ok, I guess that Can somehow be regarded as a bug ... BUT, If your a sniper, why the fu hell would you break blocks manually? Crouch + RightClick while holding the gunpowder tool to remove any block instantly.

    Also, I rewrote the Sneak brush partially to allow Snipers to break block manually ... while crouching ...
  9. Offline


    hey kinda off topic, but how do you guys no-clip as seen in the first video? I really need this in my server.
  10. Offline


    Are you flying? If you are you could simply just be above the sky limit, Which I have found gives off an Invalid Target error.
    This happened to me too. In the snipers.txt what is typed there, is case sensitive. So if your name was... "AwEzOmEcOw" then the name on the snipers.txt would be "AwEzOmEcOw" And not "awezomecow"
  11. Offline


    The No-physics snipe doesn't seem to work... When i place sand with it, the sand falls... i typed /vs afterwards and it said the no physics snipe was on. Help please?
  12. Offline


    Everything seems to be working great, except setting the brush to an ID.

    I can crosshair a block and use /v and /vr, but issuing "/v 0" (or any data value from the wiki list) gives me an invalid block ID warning.

    I'm using bukkit 766 with VoxelSniper 4.683.

    Aside from this minor hiccup which is probably just user error, thanks for an amazing mod!

    edit: This began working after I added a space after the data value. Subsequent commands did not require the space. Weird.
  13. Offline


    Doesn't work for me. Whenever I type in a voxelsniper command it says: "Example: /v 1 -- loads the sniper with stone blocks" What do I do. Could it be a conflict between plugins??
  14. Offline


    For FUCKS sake, how many of you dipshits are going to ask the same goddamn question? Read the damn setup Guide. IF you did, you would KNOW that you need to be regarded as a sniper to perform sniper tasks!
    Drat333 likes this.
  15. Offline


    I can see how this can get goddamn annoying after all these months, lol.

    An issue I've been having: /b tree tree comes up as "no such brush". Am I doing the command wrong? This is what the Wiki says the command is.
  16. Offline


    Hrm, yeah. Its "/b t". If ever unsure of brush name simply try out "/vs brushes" or "/vs brusheslong"
  17. Offline


    I am on the snipers list, I am not a retard. Thats why I was posting this question because I installed properly and it didn't work.
  18. Offline


    I was trying to help SnowFlyer, it's not him, he set it up corectly, he is running a 64 bit computer. I have gotten it to work on my computer, i set it up exactly the same, it's something he needs help, we read the guide, its a simple c+p, stop trolling and try to help.
    EDIT: it seems to be only querying the example commands even though he is typing the command not /help or whatever.
  19. Offline


    The example command is a think that the Bukkitiers have invented because they think they are cool. It gets printed out whenever the Command Listener returns false. And that Only happens if you were to type in a Sniper command while NOT actually being a Sniper.

    That on the other hand, only happens if you have Setup the snipers.txt file wrong, which can be many things... wrong name, wrong capitalization, making a .txt.txt file, not formatting the names to be one per line, ignoring Case Sensitivity of the names on the list.

    I Write all the plugins on a 64bit machine! So don't fault the machine when its clearly user error. If you provide me TeamViewer access via PM I will setup the plugin within 50seconds.
  20. Offline


    Is it possible to change the default Gunpowder to something else? I use it on my server as a trading item and because I'm the person using the Sniper, I tend to accidentally break other people's houses, replace chests, and break Redstone mechanisms. :(
  21. Offline


    Ok, thanks a lot man.

    Are there gonna be videos soon showcasing the blob and splatter brushes? I still don't understand them very much...
  22. Offline


    Perhaps while I work on Tronics plusnine will make a video of them. To be honest with you the server is 20+ builds behind whats on my test server :p

    The new thing is the Blend brushes, which is like a twist of Erosion brush ... sortof...
  23. Offline


    Sounds great, can't wait for them!

    And my favorite brush by far is the Mind-Numbingly Pointless brush :D
  24. Offline


    Double-check your VoxelSniper.jar is the latest. Outdated jars can also cause this issue.
  25. Offline


    Thanks, got it working!
  26. Offline


    Hey guys I'm getting an error about an items.txt when I start my server, and then the /v command wont work (when I type /v grass it says "grass is not valid. /v bId>" - when I type /v 2 it says "Invalid Item ID. D:<") Running VS 4.683 and CB 766.

    22:46:58 [SEVERE] Exception while reading plugins/VoxelSniper/items.txt (Are you
     sure you formatted it correctly?)
    java.lang.ArrayIndexOutOfBoundsException: 1
            at com.thevoxelbox.VoxelSniper.loadItems(VoxelSniper.java:241)
            at com.thevoxelbox.VoxelSniper.onEnable(VoxelSniper.java:38)
            at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:127)
            at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:131)
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:109)
            at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:218)
            at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:205)
            at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:145)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:260)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    22:46:58 [INFO] [VoxelSniper] Config loaded
    22:46:58 [INFO] VoxelSniper version 4.683 is enabled! Snipe away.
  27. Offline


    You did not merge the MAC_OX folder. I encountered the same problem but that is the solution.
  28. Offline


    First 24 hours with VoxelSniper-- first off, what an amazing mod! This is what Adventure-mode level-editing should eventually look like, and, what I've always wanted for my server-- something on thevoxelbox scale from a moderator perspective, but still maintaining a reasonably vanilla SMP feel for standard players.

    I'm predictably drifting towards extreme adventures in terraforming while I get familiar with the tools. I'll probably be ridiculous with it for a week or two and eventually calm down ;]

    To the casual observer, these screenshots look like a random mess. In my imagination, they're some pretty Final Fantasy looking backdrop my regulars and I can try and survive in, against hoards of mobs. If any long-time sniper users have any advice on making things look more natural given these screenshots, I'm all ears.

    Lastly, one minor caveat with erosion brush, is that it will eat through bedrock. It seems to try and work around ladders and other blocks, but using /b e lift or melt on a very low area will eventually manipulate bedrock, which causes landforms to bleed through the "floor" and appear way up top on the map. I don't see anything in the documentation of the erosion brush that might prevent this.

    So, my feature-hungry request: some way of specifying blocks that erosion brushes shouldn't manipulate. Like /vr, but in reverse, yes/no?
  29. Offline


    Hey so im using the ocean brush and I have this issue. Im using a terran mod so I have my sea level set to 45 blocks instead of the usual 64. Anyway I can mod it so that voxel only fills to 45?
  30. Offline


    Thats actually not an Erosion, or Sniper in that matter, fault but instead it is Bukkit/Minecraft. You see, someone decided it would be fun, or something, to loop y coordinates around like the Sky and Bottom of the World were some goddamn portals. So you see, when the server requests say block x:132, y:130, z:21 It instead receives
    block x:132, y:2, z:21 (the y coordinates start from 0 and end on 127) ... In other words if you divide the Y coordinate by 127 the remainder of the equation ( aka Modulus % ) is What block you get. And I'm not about to check every block I change whether its above or below the world, that't not my duty, the server should handle that!
  31. Offline


    Thanks! I wasnt sure where to put it all so I just copied it in all the places it might go and it worked. Thanks a ton! (why I need a MAC_OSX folder on windows is beyond me...)

Share This Page