[EDIT] BioMed v0.7.1 - Change those biomes! [1.4.7-R1.0]

Discussion in 'Archived: Plugin Releases' started by Karl Marx, Jan 10, 2012.

  1. Offline


    I just need something simple, thanks a lot for the update :)
  2. Offline


    Nice to see that this plugin became updated :)
    I just wanted to ask if this request
    is doing progress in development?
  3. Offline

    Karl Marx

    That is already exactly what the "global biome" feature does. The easiest way to set it up is with the command "/biome set-global somebiome", where "somebiome" is the name of the biome you want.

    Edit: I just remembered that it updates anyways- man it's been a long time since I looked at that code.

    To be clear- running the set-global command will update all chunks that already exist; contrary to my original post. You can, however, manually edit the plugin config to set the global biome, which will not touch existing chunks.

    It would look something like this:

            global: jungle
    Replace "myworld" with the name of your map, and "jungle" with the biome you want all new chunks to be.
  4. Offline


    I finally came around to try that out, but regardless of what biome I tried to configure (i tried "Plains, plains, plain and ocean) the message "Unrecognized biome for world "world" came up ... :(
  5. Offline

    Karl Marx

    Err... my mistake. I changed a few things and accidentally made it case sensitive (originally, it was not.) I'll fix it in the next update, but until then use PLAINS - in all caps.

    EDIT: For reference, this is the list of biomes supported by Bukkit:
    The BioMed config expects one of those exact values.
  6. Offline


    Can you please explain the [world_name x z width height]?

    I tried to type in:
    /biome set 30 30 plains
    /biome set Mine 30 30 plains
    /biome set world 30 30 plains

    But it doesn't seem to work.
    Mine is the name I gave to my server on Minecraft
  7. Offline

    Karl Marx

    The command does not consider your current location (so that it can be used from the server console.) You must instead specify the location of where you want the region. X and Z are the "top-left" most (lowest) corner of the region, width is the length in the positive X direction, and height is the length in the positive Z direction.

    If the region you wanted to create started at the coordinate 100, 200 (X, Z) and ended at the opposite corner, 110, 215; the command would look something like this:
    /biome set Mine 100 200 11 16 plains
  8. Offline


    I tried:

    /biome set Mine 216 -244 50 50 plains
    Synthax Error

    I even tried your exact command
    Synthax Error

    /biome set world 216 -244 50 50 plains
    Said: Set your chunk's biome to plains

  9. Offline

    Karl Marx


    That particular "syntax error" message is the default error Bukkit provides when something goes wrong. Assuming that you did, in fact, enter the command exactly as you provided, the only possible cause of that message is that a world named "Mine" does not exist.

    From the text you provided...

    ...it appears that this command worked as expected. From this text, I would also conclude that the name of the map you are trying to change is actually "world" and not "Mine". This would be in line with my theory above. Unless you have explicitly changed the map name yourself, it defaults to "world", and not the name of the server - they are not the same thing.

    Of course, if the biome still isn't changing then we still have a problem. Stand at the exact X-Z coordinate you're trying to change (to make sure it's loaded) and try the command again. Sometimes the changes are too subtle to notice, so I recommend temporarily trying a more obvious change, i.e. swampland until you're certain the changes are taking.

    EDIT: Also, try the "/biome get" command in the area you are expecting to change, before and after you run the command. If anything's happening, that's the most certain way to tell.
  10. Offline


    The biome data was accepted now, but, unfortunately, only the "F3-Biome" of the newly generated chunks was affected, so they still looked like plains, deserts, jungles ... but not like intended :S
  11. Offline


    Okay, so I used World, but when it said ''Set your chunk's biome to plains'', nothing changed. Tried to change a swampland into plains, while I was standing at (216, -244). I had the F3 thing open, and I couldn't see any change in the biome. Neither in the map appearance, or in the F3 Panel
  12. Offline

    Karl Marx

    I did some more extensive testing while working on the 1.3.2 update, and I see what you mean. I'd been testing everything with the jungle biome, which looks fine. Other biomes, (like mushroom island and plains), however, are less reliable. Apparently, chunks are too well-formed by the time BioMed gets them now to affect much more than trees; so I'm going to have to go back to the old way of handling global biomes.

    I'm making this bug a priority for the next update, but for now there's no fix.

    I'm not able to reproduce the problem here. If you're receiving that message, then it should be working. Unless you're using an outdated version of CraftBukkit or BioMed, my best guess is that you're looking at the wrong place. If you have multiple worlds on your server, make sure you're in the right one. Try swapping the x and z coordinates around too. You should also check your server log for messages.
  13. Offline


    I just downloaded Bukkit and BioMed, since this is my first server, so outdated versio shouldn't be a problem

    Tried swapping X and Z... Still not working. I'm pretty sure I'm looking at the right place, since I got the good coordinates and nothing changes around me

    In my server log:

    01:54:32 [INFO] DawnStalker issued server command: /biome set world 216 -232 50 50 plains
    01:54:32 [ATTENTION] [BioMed] Trying to add region to unsupported world: world
    01:54:52 [INFO] DawnStalker issued server command: /biome set world -232 215 50 50 plains
    01:54:52 [ATTENTION] [BioMed] Trying to add region to unsupported world: world
  14. Offline

    Karl Marx

    Well, that changes things...
    That message only exists in older versions of BioMed that have been outdated for quite some time. If you look further up in your log, you'll probably find the version number of BioMed that you are running. If it isn't v0.6, you are, in fact, not running the latest version. The download page lists which version to use for which version of Minecraft - make sure you pick the right one.

    EDIT: I just checked out the "download" button on the project's main page, and it was indeed pointing to the wrong file. It seems bukkit-dev doesn't use the version number to decide which file to put on the project page (and doesn't allow direct control either.) I've manipulated the files a bit, and it seems to be providing the right file now. If you re-download the new file, everything should work just fine.
  15. Offline


    I downloaded the new version of BioMed, typed in:
    /biome set world 216 -244 50 50 plains
    Said: Synthax error. After looking at the server log, I found this:

  16. Offline


    Thank you :)
  17. Offline

    Karl Marx

    I am working to solve the issue, but in the mean time you can get rid of it by installing WorldEdit.

    I normally test with WorldEdit already installed, so I hadn't noticed the problem (although, it seems obvious now.) I'm not sure if this is due to recent changes, or has always been there; so if anyone can tell me for certain if it occurred prior to v0.6, you would be helping greatly.
  18. Offline

    Karl Marx

    Thanks for the report. It took a bit to sort out the problem, but it's now fixed. Try v0.6.1 instead.

Share This Page