[ECON] ChestShop 3.7.18 (iConomyChestShop) - Chest&sign shop for economy plugins [1.8]

Discussion in 'Archived: Plugin Releases' started by Acrobot, Feb 12, 2011.

  1. Offline


    An easy way to create shops - no protection plugin needed!
    You don't need to be on-line to earn money anymore!
    I've put a LOT of effort into making this plugin,
    you can donate if you appreciate my effort =)

    - An economy plugin supported by Register or Vault, for example iConomy, BOSEconomy or Essentials Eco.
    - For additional economy plugin support - Vault
    - For Permissions: bPermissions, PEX, or any other permission plugin
    - For additional protection: LWC, Lockette, Deadbolt
    - For other item names (aliases): OddItem

    Copy the .jar file from the .zip you downloaded into /plugins folder.
    You can also copy the example files if you want to generate statistics page.

    You can change the plugin's language, here's a list of all user-made translations.
    If you want to update or submit a translation, feel free to PM me.
    Translations (open)

    Arabic - Attarhsase2
    Bulgarian - Muff1Ncho
    Czech - LordPgsa
    Chinese (Simplified) - tab415263
    Danish - Cannafix
    Dutch - speedlegs
    French- DragonSlayer875
    German - RasCas
    Hungarian - Anachen
    Indonesian - Yahya98
    Italian - Massimo1993
    Korean - Zwing87
    Norwegian - _AlexN_ and TheUnkownGamer
    Polish - Holls1
    Portugese (Brasil) - FelipeMarques14
    Russian - VADemon from http://minemania.ru/
    Slovak - LordPgsa
    Slovenian - jEErc
    Spanish - thxaaaa
    Swedish - Maxell
    Turkish - Developer
    Traditional Chinese - hellboyincs
    Vietnamese - etrubi1 from http://minevn.com/

    How to create a ChestShop?
    - Place a chest, if you haven't already.
    - Place a sign 1 block near the chest (for example, above the chest)
    - On the sign, write:

    (Item name can actually be item ID or alias)
    First line will be filled in by the plugin automatically.
    Price is a combination of buy and sell price.
    You have to have B near buy price (people buy from you), and S near sell price (people sell to you).
    If you have both B and S, separate them with a colon - :
    For example:

    means that AcrobotPL wants to sell 64 diamonds for 10 currency, and buy them back from you for 5 currency.
    Also, if you put "free" instead of price, it is free to buy or sell :)

    - Now, when you finish editing the sign, if LWC is turned on in config, shop will be automatically created.
    Also, if your default protection is turned on in the config, people won't be able to break chest, sign or the block the sign is on.

    What is an Admin Shop?
    Admin shop is the shop that doesn't require a chest, because it has infinite stock.
    If you sell to it, the items will disappear, and if you buy from it, items will magically appear.
    To create one, you have to be Admin/OP. Just put "Admin Shop" (or anything specified in config file) on the first line of the sign.

    Restricting shops to some groups or regions
    You can either use permissions, or you can just put a sign ABOVE shop sign (you need to be in that group to create the sign) to restrict it to players with ChestShop.group.groupName permission
    The syntax is:
    Only those groups will be able to use that shop

    To restrict a shop to some regions:
    - If you're using Towny, turn TOWNY_INTEGRATION on. Residents will be able to create shops in economy plots (either their or, if specified in config, any)
    - If you're using WorldGuard, you can use an experimental "chestshop" flag. Turn WORLDGUARD_INTEGRATION on and flag a region. (f.e. /region flag ChestShopRegion chestshop allow)

    Do you want to limit the maximum prices for items?
    Well, there's an app.... wait, not that : P
    You can use an experimental feature in ChestShop.
    In your config.yml, add lines like:
    max-buy-price-5: 14
    max-sell-price-5: 15

    That means that the maximum price for items BOUGHT by PLAYER is 14, and items SOLD by PLAYER using the shop is 15.

    You can also use a global setting, like this:
    max-sell-price: 200

    That means that the maximum price for items SOLD to PLAYER is 200 (if there is, for example, a max-sell-price-5 found, it will be used instead of the global sell price)

    You could buy and sell by right and left clicking the sign for a long time.
    Now it's the only way to use the shops.
    It's SIMPLE!
    Just LEFT-CLICK to SELL to shop, and
    RIGHT-CLICK to BUY from shop.
    (This can be changed in the config file)

    If you want to delete your old shop, simply SNEAK and destroy the sign.
    It's that easy =)

    You can either open the chest and stock it up, or click on your own sign - it will open chest's inventory (that way you can have chests not openable by other people for sure :D)

    ItemInfo command
    It's a simple command that shows item information.
    If you use it without any arguments, it shows you information about the item you're holding.
    If you specify item id or item name after the command, it will show you information about that item.

    Source code
    ChestShop is Open-Source =)
    You can find its code on https://github.com/Acrobot/ChestShop-3

    Thanks to:
    - kali876, ziomekYOYO and Herocraft server for testing the plugin and finding every little bug =)
    - Everyone who uses this plugin - really big thanks for this, I never thought it will be so popular
    - Everyone who provided translation - many people's lives will be easier now
    - @Nijikokun for Register
    - @LennardF1989 for awesome Persistence Reimplemented
    - @Temaska for fixing the plugin while I was on holidays
    - @VADemon for providing a great support for other users
    - @Euthyphro for his patience and really good bug spotting
    - vagrant326 for making a great price sheet
    - Epics for his great help
    If something's not working
    You can't change the sign color - that breaks the formatting.
    If that's not the issue, please give me this information, so I can help you faster.
    - CraftBukkit version (type /version in chat)
    - ChestShop version (type /csversion in chat)
    - Your economy plugin (iConomy? BOSEconomy? other one?)
    - Have you got any Permission plugin? Which one?

    Changelog (open)

    Changelog can be found on BukkitDev - http://dev.bukkit.org/server-mods/chestshop/files/
  2. Offline


    Are you using Vault? How does your sign look like? Are you using Censorship plugin?
  3. Offline


    i am using vault. i am not using censorship.

    i tried stone, sand items. i can create chestshop for this items.
    i cant create dirt, diamond, cooked chicken
    i think there is a charset problem. when i use "i"(diamond,dirt...) there is a problem..

    and i have one more problem :/
    when i "stop and start" or "reload" server there is an error:
    when i delete chestshop directory in plugins, than restarting my server it is ok. but there is same error if i restart my server...

    19:35:58 [SEVERE] Error occurred while enabling ChestShop v3.50t0041 (Is it up t
    o date?)
    java.lang.IllegalArgumentException: Can not set static byte field com.Acrobot.Ch
    estShop.Configuration.Properties.NEWLINE_PREFERRED_ECONOMY_PLUGIN to java.lang.I
    at sun.reflect.UnsafeFieldAccessorImpl.throwSetIllegalArgumentException(
    Unknown Source)
    at sun.reflect.UnsafeFieldAccessorImpl.throwSetIllegalArgumentException(
    Unknown Source)
    at sun.reflect.UnsafeStaticByteFieldAccessorImpl.set(Unknown Source)
    at java.lang.reflect.Field.set(Unknown Source)
    at com.Acrobot.Breeze.Configuration.Configuration.pairFileAndClass(Confi
    at com.Acrobot.ChestShop.ChestShop.onEnable(ChestShop.java:68)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:217)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
    at org.bukkit.craftbukkit.v1_4_6.CraftServer.loadPlugin(CraftServer.java
    at org.bukkit.craftbukkit.v1_4_6.CraftServer.enablePlugins(CraftServer.j
    at net.minecraft.server.v1_4_6.MinecraftServer.j(MinecraftServer.java:32
    at net.minecraft.server.v1_4_6.MinecraftServer.e(MinecraftServer.java:30
    at net.minecraft.server.v1_4_6.MinecraftServer.a(MinecraftServer.java:25
    at net.minecraft.server.v1_4_6.DedicatedServer.init(DedicatedServer.java
    at net.minecraft.server.v1_4_6.MinecraftServer.run(MinecraftServer.java:
    at net.minecraft.server.v1_4_6.ThreadServerApplication.run(SourceFile:84
  4. Offline


    Oh, so that's a serious error. Mind posting your config on pastebin.com?

    And for the 'i' problem -> I've had it once, on another server, that used Turkish charset - we couldn't fix it, it automatically replaced the 'i' with other kind of 'i'.
  5. Offline


    how can i change my bukkit server's charset :/
  6. Offline


    - CraftBukkit version (type /version in chat)
    Build 2602
    - ChestShop version (type /csversion in chat)
    /csverstion returns "/csversion", but it's the latest.
    - Your economy plugin (iConomy? BOSEconomy? other one?)
    - Have you got any Permission plugin? Which one?

    Signs are not working at all. Won't create, existing won't buy or sell.

    at net.minecraft.server.v1_4_R1.ThreadServerApplication.run(SourceFile:849) [
    at net.minecraft.server.v1_4_R1.MinecraftServer.run(MinecraftServer.java:399) [
    at net.minecraft.server.v1_4_R1.DedicatedServer.init(DedicatedServer.java:149) [
    at net.minecraft.server.v1_4_R1.MinecraftServer.a(MinecraftServer.java:259) [
    at net.minecraft.server.v1_4_R1.MinecraftServer.e(MinecraftServer.java:300) [
    at net.minecraft.server.v1_4_R1.MinecraftServer.j(MinecraftServer.java:321) [
    at org.bukkit.craftbukkit.v1_4_R1.CraftServer.enablePlugins(CraftServer.java:264) [
    at org.bukkit.craftbukkit.v1_4_R1.CraftServer.loadPlugin(CraftServer.java:282) [
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:381) [
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:457) [
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:217) [
    at com.Acrobot.ChestShop.ChestShop.onEnable(ChestShop.java:76) [
    at com.Acrobot.ChestShop.Dependencies.load(Dependencies.java:30) [
    at com.Acrobot.ChestShop.Dependencies.initializePlugin(Dependencies.java:120) [
    at com.Acrobot.ChestShop.Economy.Vault.getPluginName(Vault.java:40) [
    java.lang.IncompatibleClassChangeError: Found class net.milkbowl.vault.economy.Economy, but interface was expected [
    2013-01-20 02:45:43 [SEVERE] Error occurred while enabling ChestShop v3.50t0040 (Is it up to date?)
    2013-01-20 02:45:43 [INFO] [ChestShop] LWC version 4.3.1 (b767-git-MANUAL) (November 15, 2012) loaded.
    2013-01-20 02:45:43 [INFO] [ChestShop] Enabling ChestShop v3.50t0040
  7. Offline


    i stopped my server. than i changed my server machine's language (region and language settings). than i reinstalled java.
    there is same problem("i" - "ı" char) when i start server :/
  8. Offline


    I'm afraid you'd have to change your system's language :/ Or just dual-boot linux!

    The latest Vault is not compatible with ChestShop.
    philulrich likes this.
  9. Offline


    Thank you.
  10. Offline



  11. Offline


    Uhh, I have no idea why did the NEWLINE_... lines generate - please either delete the config.yml file to regenerate it, or delete all lines beginning with NEWLINE :)
  12. Offline


    thanks for help. i solved my problems about chestshop
  13. Offline


    No problem :) Good luck with your server!
  14. Offline



    Soon to come!
  15. Offline


    Found a serious dupe/bug with ChestShops 3.46 - got time?
  16. Offline


    I have a very serious dupe for chestshop 3.50 . I will help you solve it, PM me a server you want to test it on.

    IGN: Jamie5132
    Skype: Rozyn.Hacks
  17. Offline


    Which one? The teleport one? Just PM me the bug.
  18. Offline


    Is there a way to Block Item ID's from being accessed in ChestShop?
  19. Offline


    Why I Cant destroy my own chestshop sign?

    and someone cant even buy it
  20. Offline


    Quick question, with this plugin, do admins of a server with the "permissions.*" node get these permissions included in that? I am admin on my server and I'm trying to set up a shop area, but it doesn't seem to be working for me. This is what I type on the sign (posted against a fence btw if that matters)
    "Admin Shop"
    B 20

    Am I doing it right? lol. Sorry if it's something retarded I'm missing. I'm using the latest build of bukkit. (1.4.7-R0.1) and just downloaded Chestshop today. Using permissionsEX for permissions. Thanks :)
  21. Offline


    "Being accessed"? Do you mean - block creating?

    Unfortunately, I can't help you, as you haven't provided me even with basic information.

    There is no '*' permission in Bukkit. PermissionEX breaks the system.

    Anyway, try without quotation marks.
  22. Offline


    Thanks! I figured it was something simple I was missing. What do you mean by "PermissionEX breaks the system" though? Also, I want others to be able to create their own shops if they want, but I didn't specify that in PEX yet, so what I'm asking is if it's on by default? Thanks!
  23. Offline


  24. Offline


  25. Offline


    Haha, no problem - bPermissions can auto-import your PEX stuff, though! :)
  26. Offline



    Doh! Now you tell me :p Oh well. I think I have bPermissions figured out and set up now. xD Although it's kinda buggy but no game breaking bugs as of yet.
  27. Offline


    Where is your version 1.4.7 please :'( the last build

    v3.50 t0041 - TEST VERSION create bug

    [SEVERE] Could not pass event PlayerInteractEvent to ChestShop v3.50t0041
    at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:427)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62)
    at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.java:477)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:462)
    at org.bukkit.craftbukkit.v1_4_R1.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:178)
    at net.minecraft.server.v1_4_R1.PlayerInteractManager.interact(PlayerInteractManager.java:376)
    at net.minecraft.server.v1_4_R1.PlayerConnection.a(PlayerConnection.java:656)
    at net.minecraft.server.v1_4_R1.Packet15Place.handle(SourceFile:58)
    at net.minecraft.server.v1_4_R1.NetworkManager.b(NetworkManager.java:290)
    at net.minecraft.server.v1_4_R1.PlayerConnection.d(PlayerConnection.java:112)
    at net.minecraft.server.v1_4_R1.ServerConnection.b(SourceFile:39)
    at net.minecraft.server.v1_4_R1.DedicatedServerConnection.b(SourceFile:30)
    at net.minecraft.server.v1_4_R1.MinecraftServer.r(MinecraftServer.java:598)
    at net.minecraft.server.v1_4_R1.DedicatedServer.r(DedicatedServer.java:224)
    at net.minecraft.server.v1_4_R1.MinecraftServer.q(MinecraftServer.java:494)
    at net.minecraft.server.v1_4_R1.MinecraftServer.run(MinecraftServer.java:427)
    at net.minecraft.server.v1_4_R1.ThreadServerApplication.run(SourceFile:849)
    Caused by: java.lang.NullPointerException
    at com.Acrobot.ChestShop.Listeners.Player.PlayerInteract.preparePreTransactionEvent(PlayerInteract.java:135)
    at com.Acrobot.ChestShop.Listeners.Player.PlayerInteract.onInteract(PlayerInteract.java:96)
    at sun.reflect.GeneratedMethodAccessor78.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:601)
    at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:425)
  28. Offline


    Thanks for reporting that! It seems like you've found an unrecognised item, what is your sign's 4th line?

    Haha, sorry :D

    What bugs are we talking about?
  29. Offline


    I was messing with the different chats (local/global) and it was telling me (as an OP) that when i used "join local" I "didn't have administrator permission to use that command", but still let me join it anyway. Then when i used "focus global" to switch back to global chat, it tells me the same admin error, and says "You are now in local chat" even though it switches me to global. haha. Just weird bugs that aren't effecting my play, but looks funny cause it's wrong xD
  30. Offline


  31. Offline


    I should probably specify that it's not DIRECTLY bPermissions that has this error, but its counterpart plugin, bChatManager. lol. At least I believe it's that anyway

Share This Page