Disk full, but it's not.

Discussion in 'Bukkit Help' started by Lolmewn, Sep 9, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    Lolmewn Retired Staff

    So, today I started having weird problems with my VPS.
    It's not really bukkit related, but there's no general help forum, so I'll just post it here.
    I am getting errors because the disk seems to be full.
    The command 'df -h' tells me 100% is used.
    However, it also tells me it's 157GB. And when I use a command to count all data I have, I only get to about 16GB. What is going on?

    Yes, I've mailed the hosting company, but they seem to be quite slow with their response...

    ~Mewn
     
  2. Offline

    TnT Retired Staff

    Using Orebfuscator by chance?
    ramdisk?

    I have seen this myself when running on a ramdisk and having the orebfuscator cache on that ramdisk.
     
  3. Offline

    Lolmewn Retired Staff

    Nope, neither. I don't see how Orebfuscator would cause Disk Full errors, while there should be over 140GB left while there isn't :confused:
     
  4. Offline

    TnT Retired Staff

    What do you get from the du -h command?

    Does it still say your disk is full when you shut down and start up your CB server?
     
  5. Offline

    MyPictures

    What file system do you use on your VPS?
    Did you check if the permissions on the folder are right? (also tried to run as sudo?)
     
  6. Offline

    Lolmewn Retired Staff

    It tells me this:

    6.2G .
    I also have a small PERL script (this one: du -k | sort -n | perl -ne 'if ( /^(\d+)\s+(.*$)/){$l=log($1+.1);$m=int($l/log(1024)); printf ("%6.1f\t%s\t%25s %s\n",($1/(2**(10*$m))),(("K","M","G","T","P")[$m]),"*"x (1.5*$l),$2);}' ) and that gives me this:

    4.0 G ********************** ./root
    6.1 G *********************** .
    Aka, the same. However, when I go to my VPS control panel, I find this:
    disk space total 160.00 GB
    disk space used 160.00 GB
    disk space free 0.00 KB
    It doesn't really make a difference if I restart CB, as it's the actual server being full.
    Well, It's debian. I've never had any permissions problems, and I've checked them just now too. They're fine.
     
  7. Offline

    Muffin89

    Have you tried to get in contact with your provider? :)
    Well that is my suggestion to you
     
  8. Offline

    Lolmewn Retired Staff

    I'm trying to, they're a bit slow. So I thought: Let's give it a try here :)
     
Thread Status:
Not open for further replies.

Share This Page