Inactive [DEV] SpoutPlugin - Unleash the flow of endless possibilities [1.0-1.3.2]

Discussion in 'Inactive/Unsupported Plugins' started by SpoutDev, Aug 1, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    In order to centralize support of our legacy projects, we will no longer be providing support on Bukkit. Please use for support with our projects going forward.
  2. Offline


    got 1060 + new spout

    alot of cant keep up spamming, but now its gone and seems to be fine :)
  3. Offline


    Just curious. How does 1060 run with the rest of your plugins?
  4. Offline


    16:29:45 [INFO] skeletonofchaos [/] logged in with entity id 32 at ([world] -700.9005212048698, 70.0, 163.69733010543354)
    16:29:45 [SEVERE] java.lang.NullPointerException
    16:29:45 [SEVERE] at java.lang.System.arraycopy(Native Method)
    16:29:45 [SEVERE] at
    16:29:45 [SEVERE] at
    16:29:45 [SEVERE] at net.minecraft.server.Packet51MapChunk.a(
    16:29:45 [SEVERE] at net.minecraft.server.Packet.a(
    16:29:45 [SEVERE] at net.minecraft.server.NetworkManager.f(
    16:29:45 [SEVERE] at net.minecraft.server.NetworkManager.d(
    16:29:45 [SEVERE] at
    This occurs every time I try to log in with the latest RB.
    thepackett likes this.
  5. Offline


    Just left Spout running in the background while browsing the forums..

    I've got 8GB of RAM, so that's not the problem.
    Any ideas?
  6. Offline


    no errors at all, havent checked plguins working itself but ill find out

    got a texture pack? a big one?

    got 32bit os?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Nov 13, 2016
  7. Offline


    Never mind was a spout plugin that was outdated sorry for the trouble.
  8. Offline


    @SpoutDev So, I know you probably already have this figured out, but how does this not break the terms of use of Minecraft? (Since you are redistributing MC through Spoutcraft). Isn't this the same as someone providing an illegal .minecraft merge folder?
  9. Offline


    Everything goes throughout Mojang's download system. When you login to minecraft, it gives you some info, including a download ticket that is used to download the latest minecraft.jar from their Amazon S3 Server. So if there is an update, or files are missing it uses their download system.
  10. Offline


    I'm gonna sound like a n00b here, I do apologise, I've done some looking about and can't seem to find this question being asked already, may be that it's obvious to others, may be that I'm the only one getting it (hence I felt I should check).

    Since I updated my SpoutCraft and the Spout Server Plugin none of my spout based Plugins are working, I've seen no Plugins updating here on bukkit and no one seems to be asking the creators of them when they'll be updated. So I'm wondering if this is a simple case of 'developers just need to update their plugins' or if I (or Spout) has screwed up?

    Ta muchly :)
  11. Offline


    @SpoutDev @alta189 (Because you're replying and on haha)

    NVM just updated no more stream errors :) but... you might wanna change the title there. its confusing i wasnt even aware there was a update.
  12. Offline


    I believe the update for the server has a new name. I moved the original spout.jar out of the plugins directory and this took care of the problem.
  13. Offline


    Nope and nope.

    New error!

    No idea what this one is..
  14. Offline


    i get this too
  15. Offline


    10:59:25 [INFO] libraryaddict [/] logged in with entit
    Im getting this too :(
  16. Offline


    seriosly you need to add some install instructions to this it's a little rediculus
  17. Offline


    @colin8696909 Pretty simple to install, just drop and go..
    Mukrakiish and alta189 like this.
  18. Offline



    1) clients have updated to while the server still runs 1.0.1, so many plugins don't work

    2) I can't update to Spout 1060 because there are no instructions on how to install it.

    But the download link gives us spout-dev-SNAPSHOT.jar which is different from the one I only have which is Spout.jar
  19. Offline


    rename it. the jenkins server just names it like that...
  20. I still can't hear any audio <.<
  21. Offline


    lol ok, simple enough. You might wanna change the name automatically so that people don't get it confused with replacing it with the bukkit jar :p
  22. Offline


    You need to start your client with more memory
  23. Offline


    While I know the autoupdating is an attempt to mitigate the tech support issues surrounding a constantly updating plugin like this, I feel like the whole thing has caused more trouble than it's prevented so far. Defaulting all automatic updates to off will at least switch the tone of the next 90 pages from "Why it stop working without me doing anything!!" to "Why it not work with new plugin!!!", which will at least add a bit of variety to the constant, surprisingly cosmopolitan whining.
  24. Offline


    The main reason we have it autoupdate is so that it can keep up with the auto-updating for clients
  25. Offline


    I just recently updated my server to 1060 from 1000. Now everyone who tries to connect instantly gets "End of Stream" before they even get into the game. With this printing to the console:

    18:54:16 [INFO] Server [/] logged in with entity id 119 at ([world] 315.484570843062, 83.0, -432.8464000330024)
    18:54:16 [SEVERE] java.lang.NullPointerException
    18:54:16 [SEVERE] at java.lang.System.arraycopy(Native Method)
    18:54:16 [SEVERE] at
    18:54:16 [SEVERE] at
    18:54:16 [SEVERE] at net.minecraft.server.Packet51MapChunk.a(
    18:54:16 [SEVERE] at net.minecraft.server.Packet.a(
    18:54:16 [SEVERE] at net.minecraft.server.NetworkManager.f(
    18:54:16 [SEVERE] at net.minecraft.server.NetworkManager.d(
    18:54:16 [SEVERE] at

    After removing and re-adding all my plugins I found that Spout 1.0.1 is causing it( ). Is there an update?

    EDIT: Got the update and its working so far. Shouldn't the thread title be changed to alert users of an update?
  26. Offline


    Hey, im having trouble installing the laucher it was previously installed but was deleted, upon downloading it a second time it doesnt seem to run it will etheir ask me what to run it on or act as a java installer. The first time i had spout none of this happened
  27. Offline


    Yah, every time I tried to, the forums crashed... but it is updated now
  28. Offline


    Also an update to the changelog with the new version would be appreciated.

    Any change you can add a /spoutversion command since logblock auto downloads spout I'm just worried it might download the wrong version after I already copied the correct one.

    Lastly can you add a link to craftbukkituptodate so it auto gets the new releases.
  29. Offline


    Right, but my client just autoupdated (and isn't set to update to dev builds) yet my Spout.jar remained at version 1.0.1 with autoupdate enabled, with the end result of Spout abruptly failing to function for no immediately apparent reason. Half an automatic update is measurably worse than one that is fully manual, and you will measure this in the amount of page-eating version spam you're about to get. Again.

    Let me reiterate, I'm not asking for help. I know what happened and fixed it pretty quickly. But for everyone that fails these tests you keep throwing, that is another pile of soulsucking internet spam that didn't need to happen. Some people just want to be left in a state of outdated peace, and I suggest you let them. For your own sake, partly.
  30. Offline


    Can someone tell me how to get spout working on my server? and installing the client one. whenever i log in with the client it says end of stream or timed out or javaclassexception-null or something like that. is there any place that gives instructions that are n00b friendly?
  31. Offline


    Just download the new spout.jar 1.0.2 and put in the server plugin folder. Run the server and it should work just fine.
    For the client I recommend downloading the launcher instead of modifying your current client
Thread Status:
Not open for further replies.

Share This Page