Inactive [DEV] SpoutPlugin - Unleash the flow of endless possibilities [1.0-1.3.2]

Discussion in 'Inactive/Unsupported Plugins' started by SpoutDev, Aug 1, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    In order to centralize support of our legacy projects, we will no longer be providing support on Bukkit. Please use for support with our projects going forward.
  2. Offline


    What build of CraftBukkit, Spoutcraft, and SpoutPlugin?
  3. Offline


    Are the latest (1201+) versions of SpoutPlugin playing nice with custom blocks again? I want to resolve the double text issue but I had to roll back to version 1110 a while back because all my custom blocks were showing up as flint. Thanks!
  4. Offline


    Should be, that's the word on street at least!
    AndyFox42 likes this.
  5. Offline


    ClassCastExceptions are commonly caused by outdated/incompatible versions. What version of Spout and CraftBukkit do you have?
  6. Offline


    We should probably mention that any custom blocks placed after a certain dev build (I forget which) and before 1212 will revert to non-custom blocks upon updating to 1212... I hope they come out with a better transition for that, but there's no telling :/.

    But at least we can place custom blocks without the game crashing now :D.
  7. Offline


    I use CraftBukkit R4 and the Spout build 1212


    I found the problem i use EndReset to reset my end world every 8 hrs. After the rest of an end world those errors i mentioned in an previous post starts. Without this plugin i get no error.
  8. Offline


    Dev builds 1166 and above. For users on the previous recommended build or before 1166, they should be fine when updating to 1212.
  9. Offline


    Need help!!!!!! so i was on my server and got a new plugin then did /reload and now my server kicks me if i dont have spoutcraft...... WHY?

    So i try logging in to my brothers account and he dont get kicked same with the other players on my server....PLZ HELP!!!!!

    Skype: KicksTV
  10. Offline


    The reload command is not supported. Do a proper stop and start.
    See for more info.
  11. Offline


    You now any way of fixing the problem?
  12. Offline


    Don't use /reload?
  13. Offline


    I noticed a rather worrying problem with spout on my server. I have it installed because logblock requires it for chest logging and I don't require my players to use spout. Normally, everything works fine.
    However, today I tried to test out Orebfuscator on my server by connecting using an x-ray cheat client. After a few seconds, I was kicked with the message "This server requires Spoutcraft! http://unleashtheflow". In my log I see this:

    Spout: Failed to authenticate zolcos's Spoutcraft client in 200 server ticks.
    Spout: Kicking zolcos for not running Spoutcraft
    Now, I'm totally cool with auto-kicking people using xray but that is very much the wrong message to show. The fact that it is going down some code path that's ostensibly for enforcing all players use Spoutcraft (when that's not the case) makes me worry that there may be other, more legitimate use cases where Spout does this.
  14. Offline


    That message only shows because you are forcing them to use the Spoutcraft client due to you likely setting the wildcard * node and forcing the spout.plugin.forcespoutcraft node on them. Basically, stop using the wildcard node and setup your permissions properly. We do not have it force Spoutcraft by default. So it's just your setup.
  15. Offline


    I know now what exactly cause this errors. They appear if parts of (or the whole) world are regenerated by an plugin. EndReset and the //regen command from world edit cause this error if someone try to break an block in the regenerated regions. After a server Restart you can break blocks without problems. Its annoying if you get kicked with Internal Server Error if you try to destroy an block in regenerated areas. If you try to place an block everything works fine.

    Spout Version: 1244
    Craft Bukkit : 1.2.5 R4
    World edit: 5.3
    EndReset: 1.1

    Its very easy to reproduce the error.


    I found another bug in 1244. Every pickax is enchanted with no enchantment (only visual effect) after you craft it.
  16. Offline


    That was already fixed in dev builds of SpoutPlugin.
  17. Offline


    This bug is fixed now (Spout 1259) but the other one is still present:

    I found an problem with Spoutit only appears if you have Orebfuscator, Spout and WorldEidt installed on your server.

    Console error:

    How to reproduce this bug:
    1.) Destroy some blocks
    2.) Select the chunk with the destroyed blocks chunk (world edit)
    3.) Regenerate the chunk with regen (world edit)
    4.) Destroy/build any block in this chunk

    After an server restart you can build in this area again.
  18. I haven a problem with the spoutplugin plugin disconnecting me because I don't have spoutcraft.

    I've searched for an answer to this and found some posts about not using wildcards.

    The thing I find strange thought is that it worked for weeks and never gave me this problem until last night and I haven't changed anything on the server during this time.
  19. Offline


    I am having a problem with the SpoutPlugin. When I go into the configuration and make it so spout doesn't kick me for not having spoutcraft installed, and I log on, it still kicks me. I don't want my server to be mandatory with Spoutcraft for everyone, so can you please help.
  20. I'm looking for an answer to this to. All I've found is old answers to similar problems which says you should never give anyone (not even admin) full access to all permissions through wildcards (That's the - '*').

    I am using a wildcard for admins like that but the thing I don't get is why it worked up until now even thought I haven't updated spout or changed anything else on the server.

    A simple solution until you find a better one is change the ticks until clients get kicked from 200 to 20000000000000 in the config.
  21. Offline


    Okay, thanks. And I know, it was working fine for me too. Then I went on the server and it said I needed spout, couldn't find spout, etc. and kicked me. But if you find an answer id appreciate it so that I could fix it, because I really don't want my server to be full spout.
    And thanks again.
  22. Offline


    It's because you are using the wildcard * permission node instead of properly setting up your permission system. Essentially by using that, you are assigning both spout.plugin.forcespoutcraft and spout.plugin.ignorespoutcraft nodes to each user with that wildcard set. You can negate a permission node with - if your plugin supports it though.
  23. Offline


    I'm not using the wildcard * permission though and the same thing is happening to me. Any suggestions?
  24. Offline


    Are your users OPs?
  25. Offline


    I tried getting this and i did then i crafted a blank disc, but when i put in the recipe, i got flint :(
  26. Offline


    Please ask in the JukeBukkit developer's thread.
  27. Offline


    Nope. But I just realized that my one friend who didn't have skype could get on and not get kicked without spout, but I got kicked for not having spout.
    Note: No one on my server has OP. Not even me.
  28. Offline


    Well, somehow you and your users are getting are having that spout.plugin.forcespoutcaft set on them, only reason I can see.
  29. Offline


    Okay, I'll have to take a look through the config and permission a little more. Thanks though.
  30. Offline


    I'm having a problem with spout:

    here is my config:
    ForceMinecraftVersionCheck: false
    ForceSinglePlayerClient: false
    ForceSinglePlayerClientKickMessage: This server requires Spoutcraft!
    AuthenticateSpoutcraft: false
    AuthenticateTicks: 200
    ChunkDataCache: true
    DeadlockMonitor: false
    TeleportSmoothing: true
    AllowEntityLabelCheat: false
    AllowClearWaterCheat: false
    AllowCoordsCheat: true
    AllowSkyCheat: false
    AllowStarsCheat: false
    AllowTimeCheat: false
    AllowVoidFogCheat: false
    AllowWeatherCheat: false
          x: 0
          y: 64
          z: 0
          x: 0
          y: 64.5
          z: 0
    Even with force single player client false it denies people from logging in from regular minecraft, and I dont know why...
  31. Offline


    Please see my previous few posts, as I answered your question already.
Thread Status:
Not open for further replies.

Share This Page