Inactive [DEV] SpoutPlugin - Unleash the flow of endless possibilities [1.0-1.3.2]

Discussion in 'Inactive/Unsupported Plugins' started by SpoutDev, Aug 1, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    In order to centralize support of our legacy projects, we will no longer be providing support on Bukkit. Please use for support with our projects going forward.
  2. Offline


    im assuming that you need an premium account to log in?
  3. Offline


    Any chance you are using the latest Multiinv? It is known to cause teleport lag at this current moment.

    Spoutcraft requires a premium Minecraft account. You will be given ZERO support if you decide to ask for assistance in bypassing this ;)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Nov 13, 2016
  4. Offline


    At Spout Test Server, every time I try to kill a mob, any mob, I get:
    "Connection Lost
    Internal exception: Received string length is less than zero! Weird string!"
    SpoutCraft #693
    I know it's a dev build, I'm just reporting :p
    Same thing with #690
    No problem with #684
    Same bullshit with #700 :oops:
    I cannot even touch a mob with right-click, any mob.
    Maybe it has something to do with the plug-in that makes that thing appears up on the screen, someone versus pig, someone versus skeleton etc. although it's just a guess ;)
  5. Offline


    no example for slab/stairs/weapon or armor with spout?

    Thank you
  6. Offline


    where can I find the texturepack folder on a mac. I had some trouble with finding the .minecraft folder on a mac too. Found that though. But I don't know where to search now.
  7. Offline


    There is a button you can click on the Texture Pack page in-game that should open the folder for you. If you are using our launcher, it stores everything under .spoutcraft instead of .minecraft too.
  8. Offline


    nope, that doen't work for mac. But I'll search for the .spoutcraft
  9. Offline


    I think the path is:
    Users/YourUserName/Library/Application Support/Minecraft/texturepacks
    You could read this too:
  10. Offline


    Yes. I am.
  11. Offline


    Close, the path is (escaped for terminal):
    ~/Library/Application\ Support/sooutcraft/texturepacks/
    ~/Library is hidden by default so you need to open terminal and type/copy and paste:
    open ~/Library/Application\ Support/sooutcraft/texturepacks/
    After that, hit enter and the folder should appear in Finder. Similarly, replace "spout craft" with "minecraft" to install texture packs for the default version.
  12. Offline

    Marcos Cosmos

    hehe sprout..
  13. Offline


    I keep getting this:
    2011-10-29 11:05:31 [SEVERE] java.lang.NullPointerException
    2011-10-29 11:05:31 [SEVERE]     at org.getspout.spout.player.SimpleAppearanceManager.onPlayerJoin(
    2011-10-29 11:05:31 [SEVERE]     at org.getspout.spout.PlayerManager.onSpoutcraftEnable(
    2011-10-29 11:05:31 [SEVERE]     at org.getspout.spout.SpoutNetServerHandler.a(
    2011-10-29 11:05:31 [SEVERE]     at net.minecraft.server.Packet18ArmAnimation.a(SourceFile:36)
    2011-10-29 11:05:31 [SEVERE]     at net.minecraft.server.NetworkManager.b(
    2011-10-29 11:05:31 [SEVERE]     at net.minecraft.server.NetServerHandler.a(
    2011-10-29 11:05:31 [SEVERE]     at org.getspout.spout.SpoutNetServerHandler.a(
    2011-10-29 11:05:31 [SEVERE]     at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
    2011-10-29 11:05:31 [SEVERE]     at net.minecraft.server.MinecraftServer.h(
    2011-10-29 11:05:31 [SEVERE]     at
    2011-10-29 11:05:31 [SEVERE]     at
    After I am forcing the player's name/display name to a certain value on the onPlayerJoin() event.
    The error never appears when I remove my plugin. So my plugin must be causing the error.
    What should I do?

    I'm using the latest released Spout/Spoutcraft and CB 1337.
  14. Offline


    I recommend you don't use onPlayerJoin. That's where Spout is setting up the information for players once they are in the game, and it seems likely that your listener is being called before spout's. Typically, we recommend using onSpoutCraftEnable, a custom event that is raised when Spoutcraft player's join and confirm to the server they are using Spoutcraft. It happens less than a second after onPlayerJoin in most cases.
  15. Offline


  16. Offline


    Ah i see.
    Since I posted that I sort-of fixed it by catching the onPlayerLogin() instead.
    Ill try using onSpoutCraftEnable().
  17. Offline


    Is there a debug mode for spout? i get disconnected everytime i try to use /regios and when i do get in the menu is black and if i click on more then one button the words overlay and wont go away. Also if i close and try to type /regios again it boots me saying either bad packet 126 or 92 any idea?
  18. Offline


    on #502 i get

    17:11:22 [INFO] [Spout] Failed to authenticate KongoLegend's client in 200 server ticks.
    17:11:22 [INFO] [Spout] Failed to authenticate matlix1337's client in 200 server ticks.
    17:11:22 [INFO] [Spout] Failed to authenticate minecraftscott18's client in 200 server ticks.
    17:11:22 [INFO] [Spout] Failed to authenticate cabbagemonster9's client in 200 server ticks.
  19. Offline


    Oops, sorry. Will fix that shortly.

    Open issue:

    What builds of Spout and Spoutcraft are you running?

    You'll be able to submit it to our list once is open for registration.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  20. What have you guys been doing to the launcher what ones used to run perfectly fine with 30FPS on avarage on my laptop now only gets 10Fps it has droped FPS by half for an updated version i find this very distressing

    Another thing with custom blocks there is lighting glitching it flickers when moving close to the block and away from the block like it cant deside what shade to make it haha
    P.s Running all RB of spout and Bukkit and the launcher
    Also on my tower with a GTX560Ti used to get 150FPS+ it now runs at 90FPS+ thats a big drop if you ask me
    My g/f Computer has a GTX275 Used to get 60 to 80FPS now is 20FPS so is now not playable
  21. Offline


    The setDirty() method on Spout doesn't seem to be working properly in 502 (or the new Spoutcraft). Even something as simple as changing a button's text colour won't update. Check version 1.6.1 my plugin to see the difference in redrawing the screen with the previous Spout(craft) and the latest one.
  22. Offline


    Since I this morning my spout craft has been playing up. When I open my SC everything is normal but as soon as I go into SP or MP it does a weird graphic error:

    <Edit by Moderator: Redacted mediafire url>

    This picture shows what my screen looks like in the begin. It does sometime fixs itself but. I may take up to 30 mins to fix. I hope this get fix or advice is given to me to fix it.

    PS. What I have tried:

    * Deleting and Downloading SC.
    * Changing render to lowest
    * Changing render to highest
    * Changing them back to default.
    Last edited by a moderator: Nov 13, 2016
  23. Offline


    Found it! For some reason it's a hidden file, but at the same time actually not. So it's not visible. But when I choose "show invisible files" with secrets, it does show it. But not as a hidden file. If you know what I mean...
    If not, nevermind, just for the people with the same problem: show invisible files using secrets
  24. Offline


    So how do you get onto the public server list? :p
  25. Offline


  26. Offline


    Every time I'm turning the volume up, the client crashes :'(
  27. Figured out the FPS lagspike on my server was caused by the plugin YouControl an admin GUI so it seems to me its linked with displaying a custom GUI
    As soon as the GUI was activated the lag spike happend but its not just a spike it stays spiked at low FPS untill the client is restarted Conclushion was to remove the plugin from the server.
    Has anyone else had this problem with any other Custom GUI plugins with the new spout RB

    Thank you Afforess we have had to disable both the suspected plugins for now to maintain spout as the main plugin used on our server hope this issue can be sorted ASAP

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 28, 2018
  28. Offline


    Using the latest build of Spoutcraft (build #703), it stops responding whenever I log into a server. Any help?
  29. Offline


    The server should be running the compatible version of Spout (#502 or above). Do you know if they are using an old build?

    Could you post your log from .spoutcraft/logs ?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Nov 13, 2016
  30. FPS glitch is realy bad thats 2 plugins confirmed to be affected by this Custom GUI glitch
    YouControl and mcMMO with the EXP bar as soon as it appears FPS drops from like 90FPS to 15FPS something is very wrong with the custom GUI managment
  31. Offline


    I can confirm that redstone goes through glass with Spout build 502 now.
    Disabled Spout for now, hope it gets fixed soon.
Thread Status:
Not open for further replies.

Share This Page