Inactive [DEV] SpoutPlugin - Unleash the flow of endless possibilities [1.0-1.3.2]

Discussion in 'Inactive/Unsupported Plugins' started by SpoutDev, Aug 1, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    SpoutDev

    In order to centralize support of our legacy projects, we will no longer be providing support on Bukkit. Please use www.spout.org for support with our projects going forward.
     
  2. Offline

    NinjaZidane

    The Spout plugin IN ITSELF does NOT autodownload (unless per another plugin) so your terminology can be misleading

    Spout (if it is installed by the user) CAN update if it has a Reccomended Build (configured via the config.yml in Spout's folder). If you go into your plugin folder and delete Spout.jar I assure you it won't magically show back up

    Unless....

    Plugin Developers decide to put a small tidbit of code into their plugin to AUTO download Spout and install it. As Olloth said above, they can only just yell at them to try and make them stop but that is the full extent to what is possible.
     
  3. Offline

    fulafisken

    I disagree, it works wonderfully. You just got to use the right craftbukkit-build. In this case 1060, as stated in the topic of this thread.
     
  4. Offline

    Deeh

    Hey...
    I've searched for this, and found nothing:

    How I install Spoutcraft in a non-premium client? (The free classic client)
     
  5. Offline

    Jego

    No one in here will help you with that, I think. Buy MineCraft instead.
     
  6. Offline

    Deeh

    Why? And I can't buy :/
     
  7. Offline

    Buckethead

    mc 1.8.1 spout 1.1.339

    Code:
    18:58:48 [SEVERE] Error occurred while enabling Spout v1.1.339 (Is it up to date?): bz
    java.lang.NoSuchFieldError: bz
            at org.getspout.spout.block.mcblock.CustomBlock.<init>(CustomBlock.java:65)
            at org.getspout.spout.block.mcblock.CustomBlock.replaceBlocks(CustomBlock.java:356)
            at org.getspout.spout.Spout.onEnable(Spout.java:213)
            at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
            at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:885)
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:278)
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:171)
            at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:154)
            at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer.java:104)
            at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigurationManager.java:52)
            at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:136)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:348)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
     
  8. Offline

    xenofixus

    Spout is not backwards (or forwards) compatible. It works for the version of Minecraft that it was specifically created for (both Spout for server and Spoutcraft for client).
     
  9. Offline

    Marcos Cosmos

    You can't do it that way, there's files that only exist after you legitimately login. Anyone who has legitimtely used it can then pirate it, but not the other way around. They made a failsafe ;)
     
  10. Offline

    Buckethead

    spout is its own thing its independent f the same data in .minecraft folder. im telling u i am doing this i told other people to do it. i have 1.8 server with newest spout and there are 0 problems

    levae whtevers in the .minecraft folder that isnt in the .spoutcraft

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Nov 13, 2016
  11. Offline

    Marcos Cosmos

    Oh Yes It IS. Most definitely, you need to log into spoutcraft once before you can crack it like that. Otherwise you need external files. I know, I tried to crack it before I logged into spout the first time. Delete your .spoutcraft and then try doing it without logging in lol.

    ... http://spout.in/exe

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Oct 10, 2018
  12. Offline

    alryaz

    Long till Spout is Out?
    Or f*ck the server up and go play Terraria?
     
  13. Offline

    awaping

    Hello all.
    I'm a french user of bukkit, and I have a problem. (Sorry for my English).
    When I started my server, the "Done" line in console do not appear.
    And when I want to connect on my server, I can not ...
    It's a very big problem for my server..
    I think it's spout, because when he didn't install, the bug not appear.

    I want help please .
    Cordially, awaping
     
  14. Offline

    Charant

    Code:
    15:55:12 [SEVERE] Error occurred while enabling Spout v1.1.339 (Is it up to date
    ?): bz
    java.lang.NoSuchFieldError: bz
            at org.getspout.spout.block.mcblock.CustomBlock.<init>(CustomBlock.java:
    65)
            at org.getspout.spout.block.mcblock.CustomBlock.replaceBlocks(CustomBloc
    k.java:356)
            at org.getspout.spout.Spout.onEnable(Spout.java:213)
            at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
            at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader
    .java:885)
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
    r.java:278)
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:171)
            at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:154
    )
            at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer.java:104)
            at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigur
    ationManager.java:52)
            at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:136)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:348)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    When are you update spout?
     
  15. Offline

    slimpyman

    Does this allow the use on a client with custom recipes? like if i wanted to change the recipe to make a sword, it will work on both client and server?
     
  16. Offline

    BlockCat

    will there someday come a plugin which can install spoutcraft automatically, without installing it with the .jars from here?
     
  17. Offline

    Buckethead

    or u can go downloadal the files somewhere else if that doesnt work and still use crack launcher for it

    Sure would be nice to hear some kinda word after posting like 3 error logs:(

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Nov 13, 2016
  18. Offline

    olloth

    The word is we read the logs and if they aren't already fixed in the dev build they go on the list. :)
     
  19. Offline

    xenofixus

    Spout the Bukkit plugin: Spoutcraft the client mod? no.
     
  20. Offline

    Buckethead

    spoutcraft whatver know what i mean

    sigh..... ok ty:rolleyes:

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Nov 13, 2016
  21. Offline

    xenofixus

    I knew what you meant but if you back track through the entire convo. you will see that the original question was how to get Spoutcraft working in client versions it was not specifically made for, not the Spout Bukkit plugin :p.
     
  22. Offline

    Buckethead

    oh :oops:

    i also kinda meant to know if its like something im doing a conflict update idk?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Nov 13, 2016
  23. Offline

    harrisonduell

    I got a problem, i accidently clicked in the options on spoutcraft to clear cache and now it is saying my sputcraft is 1.8 even thought it is 1.7.3 What should i do?
     
  24. Offline

    cronikkk

    @alta189
    @Afforess
    Do you have some sort of function/class to check if user has spout installed or is using spoutcraft?
     
  25. Offline

    Wulfspider

    Check if you have a backup under .spoutcraft or manually mod an original 1.7.3. jar with Spoutcraft.

    You are using a 1.7.3 build on a 1.8+ server. Builds older than the past couple of days will not work on 1.8+ servers.

    Console logs would be useful. Are you using Spout (server plugin) and Spoutcraft (client mod)?

    Pretty sure Zino was looking for a away to automatically install the Spoutcraft files without having to login. ;)
    Unlikely, but maybe some year.

    There is no support for the free alpha classic client and no support for non-premium beta clients.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Nov 13, 2016
  26. Offline

    Afforess

    player.isSpoutCraftEnabled()
     
    acuddlyheadcrab likes this.
  27. Offline

    cronikkk

    Oh wow. Ur a life saver!
     
  28. Offline

    Wulfspider

    You are using a 1.7.3 build on a 1.8+ server. Builds older than the past couple of days will not work on 1.8+ servers.
     
  29. Offline

    Afforess

    You can make custom recipes with just bukkit and no client mods.

    We support Recommended Builds. We list the supported builds in the title. You are using a non-recommended build. You got errors. And you are mad at us?

    Logic Fail.

    Spout development builds already work with 1.8.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Nov 13, 2016
  30. Offline

    Wulfspider

    Spout and Spoutcraft has been out. There are just no recommended builds for Minecraft 1.8 or CraftBukkit builds for 1.8. It all works fine for a 1.7.3 setup.
     
  31. Offline

    harrisonduell

    How would i mod the original???
     
Thread Status:
Not open for further replies.

Share This Page