CraftBukkit thinks the port is being used by another server. Mojang server disagrees

Discussion in 'Bukkit Help' started by Siderz, Jun 7, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    Siderz

    I opened the ports and have been using CrafBukkit for about a week now. But when starting it up, it claims that it can't bind to the port and that it might already have a server running on it.

    This hasn't happened during the week I've been using it. The official server software (One from Minecraft.net) works perfectly fine. It wasn't running when CraftBukkit claimed to not work.

    Restarting my computer does nothing. Last time I had this problem, I restarted my computer to close all the programs and it worked. My friend suggested restarting the router, just did that, nothing happened.

    I'm on a Mac running Mac OS 10.6.7 and using CraftBukkit build #818. I was thinking of updating to build #835, but it doesn't say it's recommended.
     
  2. Offline

    TnT Retired Staff

    Post your server.properties file. Post the script you use to start your server.
     
  3. Offline

    Siderz

    Code:
    #Minecraft server properties
    #Tue May 31 16:51:05 BST 2011
    level-name=world
    allow-nether=true
    view-distance=10
    spawn-monsters=false
    online-mode=false
    spawn-animals=true
    max-players=8
    server-ip=[I put the internal IP here]
    pvp=true
    level-seed=
    server-port=25565
    allow-flight=false
    white-list=false
    spawn-protection=16
    I believe that's the script?

    Sorry I'm a bit of a n00b at this.
     
  4. Offline

    TnT Retired Staff

    Leave the server-ip= line blank.
     
  5. Offline

    Siderz

    The tutorial I watched told me to put the internal IP there. And it worked fine like that.

    Thanks a lot! Worked!

    But why did it suddenly cause problems?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 16, 2016
  6. Offline

    TnT Retired Staff

    Then you haven't read any of my tutorials where I say to leave it blank. It might work, but it really causes more problems than anything.

    May suddenly cause problems if your internal IP changes.
     
  7. Offline

    Siderz

    Turns out my internal IP did change.

    Friends are reporting that they can't connect now that I've removed the IP from the server.properties. If I put it back, with the new IP, it again says it can't bind to the port. Removing the IP works again, but it still times out.

    My external IP didn't change.
     
  8. Offline

    cjc343

    If your internal IP changed, you likely need to fix port forwarding.

    Using an internal dynamic IP is an even-worse idea than an external dynamic IP.
     
  9. Offline

    Siderz

    So I just need to delete the Minecraft port then port forward again?

    If I have to reset the ports, I don't think I'll go through with that. My friend said he reset his ports and couldn't port forward again.

    He's on the same network and has the same router.
     
  10. Offline

    TnT Retired Staff

    Yes, just delete and re-add the new IP
     
Thread Status:
Not open for further replies.

Share This Page