CraftBukkit for Minecraft 1.8.1 now available

Discussion in 'Bukkit News' started by EvilSeph, Sep 21, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    A new CraftBukkit Recommended Build (#1185) with Minecraft 1.8.1 support is now available. Along with support for Minecraft 1.8.1, this new build contains several new API additions and some bugfixes. Please note: for those of you who are considering generating a new world for Minecraft 1.8, please remember that you will likely have to do the same for Minecraft 1.9.

    Will plugins break with this build?
    Provided the developers of the plugins you are using are keeping up with the development of Bukkit, all your plugins should work fine.

    For more detailed information on what is contained in this update, please see the Recommended Build announcement thread here:

    Download CraftBukkit #1185 here

    To keep up to date on our latest Recommended Builds we have an RSS feed you can subscribe to:
  2. Offline


    I love you Bukkit! :D Thank you for updating, now we can continue to be "Vanilla". :3
  3. I'm getting extreme server lag with nothing in the logs :( 5 second delay on everything!
  4. Offline


    vanilla bug. .
  5. Offline


    Yes its big lag Build, thats not on Build 1157
  6. Offline


    Looks like bukkitcontrib, try disabling that plugin.
  7. Offline


    Nice job guys 1 problem whenever someone on my server opens their inventory the server disconnects everyone and noone can get back on until the server restarts my terminal says this...

    17:16:30 [SEVERE] java.lang.NoSuchMethodError: net.minecraft.server.InventoryPlayer.j()Lnet/minecraft/server/ItemStack;
    17:16:30 [SEVERE] at org.bukkitcontrib.ContribNetServerHandler.a(
    17:16:30 [SEVERE] at net.minecraft.server.Packet102WindowClick.a(SourceFile:28)
    17:16:30 [SEVERE] at net.minecraft.server.NetworkManager.b(
    17:16:30 [SEVERE] at net.minecraft.server.NetServerHandler.a(
    17:16:30 [SEVERE] at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
    17:16:30 [SEVERE] at net.minecraft.server.MinecraftServer.h(
    17:16:30 [SEVERE] at
    17:16:30 [SEVERE] at
    17:16:30 [SEVERE] Unexpected exception
    java.lang.NoSuchMethodError: net.minecraft.server.InventoryPlayer.j()Lnet/minecraft/server/ItemStack;
    at org.bukkitcontrib.ContribNetServerHandler.a(
    at net.minecraft.server.Packet102WindowClick.a(SourceFile:28)
    at net.minecraft.server.NetworkManager.b(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
    at net.minecraft.server.MinecraftServer.h(

    bad with figuring this stuff out please help:oops:

    lol you put that up like 1 second before me xD ill try that right now

    tested it it works fine... so far thx a lot!:D

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 19, 2016
  8. Offline


    The Plugin "openinv" is your problem.
  9. Offline

    joe sykes

    were is the code for the .bat file ???
  10. Offline


    Thanks for all the hard work bukkit team!! everything is working great except I get this error once in a while when someone disconnects. Any ideas?

    14:11:02 [SEVERE] Socket closed
    14:11:02 [SEVERE] at
    14:11:02 [SEVERE] at
    14:11:02 [SEVERE] at
    14:11:02 [SEVERE] at
    14:11:02 [SEVERE] at
    14:11:02 [SEVERE] at
  11. Offline


    getting some very bad errors and cannot start my server with the new update... any ideas anyone??

    22:51:16 [SEVERE] at
    22:51:16 [SEVERE] at
    22:51:16 [SEVERE] at$000(URLClassLoader.jav
    22:51:16 [SEVERE] at$
    22:51:16 [SEVERE] at Me
    22:51:16 [SEVERE] at
    22:51:16 [SEVERE] at java.lang.ClassLoader.loadClass(
    22:51:16 [SEVERE] at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.j
    22:51:16 [SEVERE] at java.lang.ClassLoader.loadClass(
    22:51:16 [SEVERE] at java.lang.ClassLoader.defineClass1(Native Method)
    22:51:16 [SEVERE] at java.lang.ClassLoader.defineClassCond(ClassLoader.jav
    22:51:16 [SEVERE] at java.lang.ClassLoader.defineClass(
    22:51:16 [SEVERE] at
    22:51:16 [SEVERE] at
    22:51:16 [SEVERE] at$000(URLClassLoader.jav
    22:51:16 [SEVERE] at$
    22:51:16 [SEVERE] at Me
    22:51:16 [SEVERE] at
    22:51:16 [SEVERE] at java.lang.ClassLoader.loadClass(
    22:51:16 [SEVERE] at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.j
    22:51:16 [SEVERE] at java.lang.ClassLoader.loadClass(
    22:51:16 [SEVERE] at org.bukkit.plugin.SimplePluginManager.getDefaultPermi
    22:51:16 [SEVERE] at org.bukkit.permissions.PermissibleBase.recalculatePer
    22:51:16 [SEVERE] at org.bukkit.permissions.PermissibleBase.<init>(Permiss
    22:51:16 [SEVERE] at org.bukkit.command.ConsoleCommandSender.<init>(Consol
    22:51:16 [SEVERE] at org.bukkit.craftbukkit.command.ColouredConsoleSender.
    22:51:16 [SEVERE] at net.minecraft.server.ServerConfigurationManager.<init
    22:51:16 [SEVERE] at net.minecraft.server.MinecraftServer.init(MinecraftSe
    22:51:16 [SEVERE] at
    22:51:16 [SEVERE] at
    22:51:16 [SEVERE] Unexpected exception
    java.lang.ClassFormatError: Invalid code attribute name index 0 in class file co
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClassCond(
    at java.lang.ClassLoader.defineClass(
    at Method)
    at java.lang.ClassLoader.loadClass(
    at sun.misc.Launcher$AppClassLoader.loadClass(
    at java.lang.ClassLoader.loadClass(
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClassCond(
    at java.lang.ClassLoader.defineClass(
    at Method)
    at java.lang.ClassLoader.loadClass(
    at sun.misc.Launcher$AppClassLoader.loadClass(
    at java.lang.ClassLoader.loadClass(
    at org.bukkit.plugin.SimplePluginManager.getDefaultPermissions(SimplePlu
    at org.bukkit.permissions.PermissibleBase.recalculatePermissions(Permiss
    at org.bukkit.permissions.PermissibleBase.<init>(
    at org.bukkit.command.ConsoleCommandSender.<init>(ConsoleCommandSender.j
    at org.bukkit.craftbukkit.command.ColouredConsoleSender.<init>(ColouredC
    at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigur
    at net.minecraft.server.MinecraftServer.init(
  12. Offline


    I'm getting the following error.

    jacob@jacob-ubuntu:~/Minecraft_server$ ./
    161 recipes
    17 achievements
    19:50:08 [INFO] Starting minecraft server version Beta 1.8.1
    19:50:08 [INFO] Loading properties
    19:50:08 [INFO] Starting Minecraft server on *:25565
    19:50:08 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-1067-g6301507-b1185jnks (MC: 1.8.1)
    19:50:08 [INFO] Preparing level "world"
    19:50:08 [INFO] Default game type: 0
    19:50:08 [INFO] Unable to find spawn biome
    19:50:08 [SEVERE] java.lang.NullPointerException
    19:50:08 [SEVERE]       at net.minecraft.server.WorldServer.c(
    19:50:08 [SEVERE]       at net.minecraft.server.World.a(
    19:50:08 [SEVERE]       at net.minecraft.server.Chunk.addEntities(
    19:50:08 [SEVERE]       at net.minecraft.server.ChunkProviderServer.getChunkAt(
    19:50:08 [SEVERE]       at net.minecraft.server.ChunkProviderServer.getOrCreateChunk(
    19:50:08 [SEVERE]       at net.minecraft.server.World.getChunkAt(
    19:50:08 [SEVERE]       at net.minecraft.server.World.getTypeId(
    19:50:08 [SEVERE]       at net.minecraft.server.World.isEmpty(
    19:50:08 [SEVERE]       at net.minecraft.server.World.a(
    19:50:08 [SEVERE]       at net.minecraft.server.WorldProviderHell.canSpawn(SourceFile:37)
    19:50:08 [SEVERE]       at net.minecraft.server.World.canSpawn(
    19:50:08 [SEVERE]       at net.minecraft.server.World.c(
    19:50:08 [SEVERE]       at net.minecraft.server.World.<init>(
    19:50:08 [SEVERE]       at net.minecraft.server.WorldServer.<init>(
    19:50:08 [SEVERE]       at net.minecraft.server.SecondaryWorldServer.<init>(
    19:50:08 [SEVERE]       at net.minecraft.server.MinecraftServer.a(
    19:50:08 [SEVERE]       at net.minecraft.server.MinecraftServer.init(
    19:50:08 [SEVERE]       at
    19:50:08 [SEVERE]       at
    19:50:08 [SEVERE] Unexpected exception
    Any idea on how to fix this?

    johnwolf159 likes this.
  13. Offline


    thx so much!
  14. Offline


    anyone know if their permissions nodes in permissions.yml in the root directory are working? I can't seem to get mine to work.
  15. Offline


    I don't know if this is part of the bukkit mod or anything, and I didn't install a mod for this, but /spawnmob will not work for me at all it keeps giving me this error "Error: org.bukkit.craftbukkit.entity.CraftEntity.teleportTo(Lorg)bukkit/Location:)V" everytime I try this command. This might be the wrong place to submit a bug, but I figured I'd post it here to get this addressed.

    IF I have done something wrong, please someone help me fix this issue! Would like to spawn wolves :(
  16. Offline


    I was running vanilla 1.8.1 up until today when I tried to switch to Bukkit. Even running Bukkit with no plugins causes such terrible lag that it is unplayable with other people. The server running Bukkit was only at half CPU usage and still had over 200MB of unused RAM, so it's not like it was running out of resources. I am baffled.
  17. Offline


    This is exactly the position we are in. Our server is crashing with 300-500mb spare on minimum load when it is stable as a rock on ANY vanilla build. It's strange that the same day notch rolls out 1.9PRE we finally get a promoted 1.8.1 build, and bukkit on its own is still considerably less stable than the prerelease builds we're getting.

    On behalf of the other server owners, we don't care if you take a lot longer than usual to get the update out, we don't care if it breaks every plugin and your grandmother's dog, just please make it stable enough to run! It's just frustrating seeing all of this work done (125 builds!) and we still have a build that is far too unstable to run on a server.
  18. Offline


    I found a new, strange bug. I'm using 1185. Whenever I eat food, my entire hunger meter is refilled, instead of only how much the food is supposed to refill. So like, if I only had one hunger left, and I ate one piece of bread, all of the other nine hunger parts get refilled instead of only 2.5 hunger getting refilled. This happens with all of my plugins disabled, so it must be a bug with Bukkit. Does anybody else get this?
  19. Offline


  20. Offline


    I want you to know I created an account just to answer your question.

    I has the exact same problem after a crash after converting to a 1.8 build, and trying to use pluggins to edit the landscape. After getting the error, the only thing I could get to fix it was to start a new map. I have since some to the conclusion that:
    1. you can fix the problem by starting a new map or:
    2. get your server map from a backup or:
    2. fix the problem by opening up your server in an external editor like MCEdit, and changing the spawn location, or regenerating the chunks around the spawn.

    4. this problem was likely caused by memory corruption around the spawn.

    I hope this helps fix your problem.
    Don Redhorse likes this.
  21. Offline


    That seems likely, I used MCEdit to delete unwanted chunks as I wanted 1.8 content without losing most of the creations on the server. I'll see if I can fix this by re-editing the map. Thanks for the help!
  22. Offline



    great update, lots of content, and fast delivery more special shtuff from a special community <3
  23. Offline


    Everytime someone on my server uses there inventory the server crashes this goes for chests not when you open or close just when you take or put items in.

    the only chest related thing im running is LWC
    NO openinv
  24. Offline



    I am having problems starting craftbukkit server using latest recommended build.
    Vanilla version works just fine.
    World is freshly generated, tried removing it and re-running as well.

    Linux #7 SMP i686

    java version "1.6.0_26"
    Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
    Java HotSpot(TM) Server VM (build 20.1-b02, mixed mode)

    8GB of RAM, around 5GB of free memory, 8GB swap partition, whole free.

    Console output:

    $ java -Xincgc -Xmx2G -jar craftbukkit-0.0.1-SNAPSHOT.jar
    161 recipes
    17 achievements
    14:00:43 [INFO] Starting minecraft server version Beta 1.8.1
    14:00:43 [INFO] Loading properties
    14:00:43 [INFO] Starting Minecraft server on *:25565
    14:00:43 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-1067-g6301507-b1185jnks (MC: 1.8.1)
    14:00:43 [INFO] Preparing level "world.1.8_test"
    14:00:43 [INFO] Default game type: 0
    14:00:43 [INFO] Preparing start region for level 0 (Seed: 275588263)
    14:00:44 [INFO] Preparing spawn area: 81%
    14:00:45 [INFO] Preparing start region for level 1 (Seed: 275588263)
    14:00:45 [SEVERE] Exception in thread "Listen thread"
    14:00:45 [SEVERE] java.lang.OutOfMemoryError: unable to create new native thread
    14:00:45 [SEVERE]     at java.lang.Thread.start0(Native Method)
    14:00:45 [SEVERE]     at java.lang.Thread.start(
    14:00:45 [SEVERE]     at net.minecraft.server.NetworkManager.<init>(
    14:00:45 [SEVERE]     at net.minecraft.server.NetLoginHandler.<init>(
    14:00:45 [SEVERE]     at
    14:00:45 [INFO] Preparing spawn area: 73%
    14:00:46 [INFO] Server permissions file permissions.yml is empty, ignoring it
    14:00:46 [INFO] Done (0,266s)! For help, type "help" or "?"
    14:00:48 [SEVERE] Exception in thread "Connection #0 read thread"
    14:00:48 [SEVERE] java.lang.OutOfMemoryError: unable to create new native thread
    14:00:48 [SEVERE]     at java.lang.Thread.start0(Native Method)
    14:00:48 [SEVERE]     at java.lang.Thread.start(
    14:00:48 [SEVERE]     at net.minecraft.server.NetworkManager.a(
    14:00:48 [SEVERE]     at net.minecraft.server.NetworkManager.h(
    14:00:48 [SEVERE]     at net.minecraft.server.NetworkManager.c(
    14:00:48 [SEVERE]     at
  25. Offline


    Is there a glitch i downloaded this new craftbukkit i use toomanyitems for my server admins when i click on the items i dont get the items i have to log out and log in again can someone tell me
  26. Offline


    how can people join me
  27. Offline


    Kick out BukkitContrib and install Spout instead ;) Spout is an updated BukkitContrib.
  28. Offline


    when I deleted bukkitcontrib it worked fine
  29. Offline


    There's this thing called a 'period' (.).
  30. Offline


    Why does spout keep downloading in my plugins WHEN I DONT WANT IT!
  31. Because you have another plugin installed THAT KEEPS DOWNLOADING IT.

    Go read up on your plugins.
    acuddlyheadcrab likes this.
Thread Status:
Not open for further replies.

Share This Page