CraftBukkit for Minecraft 1.7.5 DEVELOPMENT build is now available!

Discussion in 'Bukkit News' started by EvilSeph, Mar 22, 2014.

Thread Status:
Not open for further replies.
  1. Offline

    EvilSeph Retired Staff

    A new CraftBukkit for Minecraft 1.7.5 DEVELOPMENT build is now available! We strongly suggest that you only use this build if you would like to help us get a Beta build out sooner and are experienced with using unsupported development builds.

    Despite the updates following Minecraft 1.7's release being relatively small and purely for the client, I decided it would be a good idea for us to keep pace with them in order to help with larger future updates. Unfortunately, after we had completed the update for 1.7.4, a 1.7.5 update was released which meant we had to start the update over. At the same time, we found ourselves battling against technical issues with our core infrastructure leading to a much longer update period than should have been necessary.

    Will plugins break with this build?
    Minecraft 1.7 is one of the most involved updates to date, with Mojang having touched a reported ~220k+ lines of code. As a result, a significant amount of the code base has shifted making it difficult to ensure any stability with regards to our API. That being said, it is difficult to determine if plugins will be breaking with our 1.7.x update and the state of the API in our earlier development builds should NOT be relied upon in any way.

    What is a Development Build?
    A Development build is provided AS IS and COMPLETELY UNSUPPORTED. You should only be running these builds if you are completely aware of how to properly make use of them. Support requests of ANY KIND will be removed without warning. If you have to ask where or how to get the development build, you should NOT be running it and posts of that nature will be deleted.

    Known Issues:
    • None

    Download the development build CraftBukkit 1.7.5-R0.1-SNAPSHOT here
     
    Rabsington, TnT, endrju and 16 others like this.
  2. Offline

    Brikel

    yeah. Had to switch to vanilla as none of the latest bukkits will work. bye bye fly for now. With the notice of the Heartblood bug Tuesday though it is understandable. It is impacting everyone.
     
  3. Offline

    Bobcat00

    Heh. Dinnerbone can't get it right. 1.7.6, 1.7.7, 1.7.8.
     
  4. Offline

    TnT Retired Staff

Thread Status:
Not open for further replies.

Share This Page