CraftBukkit for Minecraft 1.5(_02) available

Discussion in 'Bukkit News' started by EvilSeph, Apr 25, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    EvilSeph Retired Staff

    When rumours were abound of the coming of Minecraft 1.5, we were quite frantic since we were just beginning work on a new, better update handling process and were afraid the update would hit before we were ready to handle it. Luckily, to our delight, Mojang experienced a feature creep and couldn't meet the original estimated time of release, resulting in the update being delayed until the week after. While some of you were disappointed with the delay, we were happy and thankful as it gave us the weekend to push to complete the transition to our new update process.

    Unfortunately, when the Minecraft update was finally released, we were still finalising the move over to our new update process and this caused some delay. Quite a few of you were unhappy about this and we understand your frustration but we, honestly, feel the delay was for the better. With this new update process, barring local issues we have with our development environments, there should be less confusion and hard to trace bugs with future Minecraft updates. While we could have released a Recommended Build shortly after we had the update done (since we had Bukkit compatible and working with Minecraft 1.5_02 already), I made the decision for us to work out some of the issues that we were sure people would experience due to changes in Minecraft: like the addition of strict limits on certain things like chat or sign text, etc.

    Anyway, let's cut to the chase:
    We're happy to finally make available a Recommended Build for Minecraft 1.5_02 that you can grab and put on your servers right now, using the link below.

    Download CraftBukkit for Minecraft 1.5_02

    If you're just getting started, please read and follow this guide:
    BukkitWiki - Setting up a server

    Common Problems/Questions:
    I downloaded build 733 but got some other build!
    You're probably reading the version string incorrectly.

    Here's an example version string:
    git-Bukkit-0.0.0-700-gf3ae4c3-b733jnks (MC: 1.5_02)

    This version string is for build 733, as you can tell by the "b733jnks" at the end.

    Whenever I use a plugin that changes blocks, I can't see the changes until I reconnect!
    We had an issue with blocks not updating properly but this has since been fixed from build #707. This bug affected plugins that changed blocks in game, like WorldEdit. Update to the Recommended Build b733 to fix this.

    Help! My console keeps getting spammed with this error whenever someone gets kicked or disconnects and it lags the server!
    This is a bug we've fixed from build #701 onwards.

    Update to the Recommended Build b733 to fix this.

    I can't build or destroy anything! Help!?
    The common cause of this issue is a client mod called Single Player Commands, please try uninstalling all your client mods and seeing if this fixes the issue. If this is the case, then it isn't a Bukkit issue and you should contact the author of the mods you use.

    Every time I connect to the server and load a sign, the client crashes. What's wrong?
    Minecraft 1.5 has added limits for sign text. Plugin developers commonly used longer sign text to store extra data or add colours to signs. This is no longer possible, so we now cut off any line in a sign longer than 15 characters (as of build #712).

    Update to the Recommended Build b733 to fix this.

    I get kicked when flying and am told that flying hasn't been enabled on this server. How do I enable flying?
    Minecraft 1.5 added anti-flying checks. You can enable flying by setting allow-flight=true in server.properties.

    Whenever I try to send a long message in chat, it gets cut off at roughly two lines.
    A limit on chat has been added with Minecraft 1.5.

    Update to the Recommended Build b733 to fix this.

    Help! When I use the CLI arguments to set ports (or any setting), the server always starts up on 25565 or ignores the setting![/COLOR][/U]
    There was a bug that prevented the server from reading settings passed through CLI arguments. This has since been fixed from build #706 onwards.

    Update to the Recommended Build b733 to fix this.

    When lightning strikes a painting, the server crashes!
    There was a bug that caused the server to throw an error or freeze when a painting was struck by lightning, this has since been fixed from build 734 onwards. While this isn't a Recommended Build, it contains only this change and shouldn't break anything, so feel free to upgrade to this build to fix this issue.

    People are using a duping exploit involving workbenches!
    We've fixed this duping issue from build b735 onwards.

    While this isn't a Recommended Build, it contains only this change and shouldn't break anything, so feel free to upgrade to this build to fix this issue.

    Whenever I do something in game, like place a block, I get disconnected with an End of Stream error!
    This can be caused by an outdated or broken texture pack. Please try testing with a completely unmodified Minecraft client and see if it works then. If it does, you'll need to find a new texture pack or mod, get the author to fix it or run Minecraft without them.

    I can't ban anyone!
    This issue is usually caused by an outdated plugin, like Essentials. You should be keeping your plugins up to date - especially when an update hits - as they could contain fixes that make all the difference in the operation of your server.

    As Essentials isn't properly communicating updates with the community at the moment (and their plugin appears to be the leading cause of this issue), many of you are still running a version that prevents banning from working. Please update to 2.2.x (or whatever the latest is) to fix this issue.

    If this hasn't fixed this issue, make sure you've updated all your other plugins too.

    I can't spawn any mobs!
    This issue is usually caused by an outdated plugin, like Essentials. You should be keeping your plugins up to date - especially when an update hits - as they could contain fixes that make all the difference in the operation of your server.

    As Essentials isn't properly communicating updates with the community at the moment (and their plugin appears to be the leading cause of this issue), many of you are still running a version that prevents spawning mobs from working. Please update to 2.2.x (or whatever the latest is) to fix this issue.

    If this hasn't fixed this issue, make sure you've updated all your other plugins too.

    Mobs aren't spawning!
    This issue is usually caused by an outdated plugin, like Essentials. You should be keeping your plugins up to date - especially when an update hits - as they could contain fixes that make all the difference in the operation of your server.

    As Essentials isn't properly communicating updates with the community at the moment (and their plugin appears to be the leading cause of this issue), many of you are still running a version that prevents mobs from naturally spawning. Please update to 2.2.x (or whatever the latest is) to fix this issue.

    If this hasn't fixed this issue, make sure you've updated all your other plugins too.

    The easiest fix for most problems is to update to the Recommended Build b733.

    Thanks for your patience, support and the many kind words you've all sent our way!
     
  2. Offline

    PhantomGamers

  3. Offline

    toastynator

    yup it's set to zero but thanks
     
  4. Offline

    Axiol

    Hum ... When I generate a new world, everything is fine. But if I use the old map, everybody spawn in the Nether :/ Any solution ?
     
  5. Offline

    RocksandGems22

    @Axiol maybe you ARE using a Nether world? Do you have it set to 'hellworld'?
     
  6. Offline

    OrtwinS

    Dont think its the RAM, I think MC reads/writes to HDD, and servers are supposed to be pretty fast with that, and since you are online your client only has to keep stuff in RAM, which is way faster than having to read/write from HDD <-> RAM all the time.
    But I might be mistaken :p
     
  7. Offline

    fuzzy_cobalt

    Quick (bug?) note; whenever anyone on my server tries to create powered rails they lose connection. I do not know if this happens with any other workbench recipe or if it is just a plugin problem, but it started happening with this build. I hope this helps with working out bugs. (BTW there is no console output except for:

    16:30:17 [INFO] PLAYER lost connection: disconnect.endOfStream
    16:31:33 [INFO] Reached end of stream
     
  8. Offline

    PeanutTheMan

    I have a bug!

    Whenever I use the /spawnmob command, It says "Cow Spawned", but I can't see the cow, and I do not seem to get pushed by it.

    Help.
     
  9. Offline

    shaggy2010

    Thanks.

    Thats an essentials issue - update your plugins.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 14, 2016
  10. Offline

    PeanutTheMan

  11. Offline

    Pikachu645

    Slow download.
     
  12. Offline

    LonelyLittleUke

    Wow, thanks a whole lot for this. I haven't tested it yet, but reading some of these comments I have a good feeling about it. Thanks, once again! (Since, the first few times I was unable to thank you in such an open way. :D)
     
  13. Offline

    chompthis

    Does anyone know how to get powered rails or detector rail?
     
  14. Offline

    PhantomGamers

    And this is on build 733?
    Pretty sure this was fixed quite a while back...
     
  15. Offline

    Celtic Minstrel

    Once Fill goes live, I believe it will be used for automatic updating... optional, of course.
     
  16. Offline

    PhantomGamers

    I was talking about currently...
    Never heard of Fill though, that's interesting news! Thanks. :)
     
  17. Offline

    Spastic_Lime

    Please help! No one on the server can destroy or place any blocks (including op) i have read the posts and seen it has been mention before, my spawn protection is set to 0 and it is still happening.
     
  18. Offline

    shaggy2010

    You tried moving all your plugin jar's out the plugin folder then loading up server and trying (dont delete) then if it works you can see if its plugins or not. and if it works without plugins, you can then try and see what plugin causes it.
    Have a good look at the logs during server start, look for any errors (and figure out what plugin is spamming them).
    Wouldnt hurt to re-download the RB (green star) from Jenkins either.
    Turn off server, delete your server.log file and restart, Can you pastebin the log content here?
     
  19. Offline

    Spastic_Lime

    ok, i took out all the plugin files and started the server up and i still couldn't build. Then i re-downloaded the build and it still didnt work. i deleted the server.log file and started it up and i still can't build. i have checked the log and there are no errors. I have also re-written my name in the ops file to make sure its right, i still can't build.

    this is the log:
    Code:
    2011-04-27 10:20:21 [INFO] Starting minecraft server version Beta 1.5_02
    2011-04-27 10:20:21 [INFO] Loading properties
    2011-04-27 10:20:21 [INFO] Starting Minecraft server on *:25565
    2011-04-27 10:20:21 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-700-gf3ae4c3-b733jnks (MC: 1.5_02)
    2011-04-27 10:20:21 [INFO] Preparing level "world"
    2011-04-27 10:20:21 [INFO] Preparing start region
    2011-04-27 10:20:22 [INFO] Done (0.067s)! For help, type "help" or "?"
    2011-04-27 10:20:29 [INFO] SpasticLime [/127.0.0.1:51936] logged in with entity id 152
    2011-04-27 10:20:51 [INFO] SpasticLime lost connection: disconnect.quitting
    2011-04-27 10:20:51 [INFO] Connection reset
    2011-04-27 10:25:13 [INFO] SpasticLime [/127.0.0.1:52040] logged in with entity id 463
    
    Edit: I FIXED IT! It was singleplayer commands, i deleted my minecraft.jar and re-updated and it now works fine =)
     
  20. Offline

    Skrolan

    Hey i have a problem about Server.bat when i Run it it opens for like 1 sec and closes again please help!
     
  21. Offline

    fuzzy_cobalt

    turns out it only happens with a texture pack, and its not just with the workbench, its anything but walking and jumping. totally stops the game and kicks the player unless they use original textures
     
  22. Offline

    Skrolan

    I got a problem i just made a Server.bat and when i try to run it it just goes on for 1 sec and then turns off please help happens everytime i try to run it i rly wanna play! Thanks!
     
  23. Offline

    swisscows

    Well, no one can help you unless you tell us what your Server.bat says. So if you want any kind of help i suggest you post that.
     
  24. Offline

    Spastic_Lime

    re
    rename the craftbukkit-0.0.1-snapshot to just 'craftbukkit'
     
  25. Offline

    Skrolan

    i did that dident work

    K but how am i suppose to see what it says when it turns off in 1 sec

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 14, 2016
  26. Offline

    Spastic_Lime

    ok i dont know then
     
  27. Offline

    swisscows

    No, right-click your sever.bat and click edit. It should open notepad. Then copy paste what that says.
     
  28. Offline

    Skrolan

    @echo off
    "C:/Program/Java/jred6/bin/Java.exe"-Xms1024M -Xmx1024M -jar craftbukkit-0.0.1-SNAPSHOT.jar nogui
     
  29. Offline

    swisscows

    Hmmmm, there is a pause at the end of my luncher. Here this is my launcher that works perfectly.
    Code:
    @echo off
    java -Xms1024M -Xmx1024M -jar craftbukkit.jar nogui
    pause
    Hope that works :D

    edit: obviously you need to rename craftbukkit-0.0.1-SNAPSHOT.jar to craftbukkit.jar
     
  30. Offline

    Skrolan

    Thanks Alot!:p
     
  31. Offline

    Lying_Cake

    This build seems less stable then 709. It crashes, lags, and i get "connection reset" errors constantly :(

    I love bukkit but i need something more stable to work with!
     
Thread Status:
Not open for further replies.

Share This Page